[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3542
  • Last Modified:

Unable to connect to Windows Update

I have a very strange situation with my main desktop system (MSI, Pentium 4, 2.4 GHz, Win XP SP3, IE7, Firefox 3.0.8) in that, despite Internet connectivity showing connected (in both Windows and Network Magic Pro 5) I cannot access Windows Update.  I am also unable to access many other websites.  However, Symantec Live Update functions properly.  The situation is quite complex, given that the system was idle for about three months.  On restarting the system, I updated my NIS 2008, my Zone Alarm Suite 8 before attempting to update Windows.  When I finally tried to update Windows, the relevant webpage stuck on "searching for updates" for a prolonged period (greater than 15 minutes).  I suffered a continuous rebooting situation which was finally resolved through Microsoft telephone support staff assistance.  Folowing correction of the continuous rebooting problem, I was required to restart my system for some reason other than a Windows update requirement.  When the close down reached the stage on "Do not switch the computer off, updating windows (1 of 10)", the display remained on that screen for over three hours before I finally rebooted the system.  I do not know how any updates were downloaded, because the Windowa Update process did not go beyond the "searching for updates stage".  On a further manual shutdown, the closing screen referred to "Do not shut off the system, Windows is applying updates (2 of 10)".  However, on a subsequent manual shutdown, the closing screen reverted to "... updating (1 of 10)", with the system never shutting down automatically.  The last update in the Update History was in late Dec 08.  I have attached a Word document with as much description and supporting screen shots as I can provide at this time (Please disregard the last portion which refers to a similar problem with my wireless connected (Cisco Linksys WRT 160N V2 new router, at least for  now).  Any help. advice, and or other assistance to resolve this perplexing situation will be very greatly appreciated.  Arbyem
main-internetconnectproblem-0904.doc
0
R_Bruce_Morris
Asked:
R_Bruce_Morris
  • 14
  • 12
  • 7
  • +2
3 Solutions
 
Donald StewartNetwork AdministratorCommented:
You most likely have conficker, try www.bdtools.net
0
 
JonveeCommented:
It does look like a Malware or virus infection.
Also try downloading then updating Malwarebytes' Anti-Malware:
http://www.malwarebytes.org/mbam.php
When updated, reboot into Safe Mode by selecting F8 at bootup & run a scan.

Tutorial available, if you require >
http://www.bleepingcomputer.com/forums/lofiversion/index.php/t169669.html
0
 
JonveeCommented:

Additionally you could try the Kaspersky free online virus scanner which is a good way to find out if you have any viruses or spyware without having to uninstall your existing antivirus software>
http://www.kaspersky.co.uk/virusscanner

If still unresolved you could take a look at your Zone Alarm Suite 8.  Possibly the last update is causing the issue.  If it is due to ZA you could consider uninstalling it, reinstalling it, and retesting.
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
JonveeCommented:
Finally, if you still have the problem after following all of the suggestions above, suggest you install and run Trend HijackThis 2.02:
http://majorgeeks.com/Trend_Micro_HijackThis_d5554.html

Create a folder where you would like the HijackThis file to reside and run it from there, not from the Desktop or a temporary folder.
Run the scan & save the logfile.  Then click the "Attach Code Snippet" box, paste the logfile into the "Code Snippet" page and then we can get it analysed.  
0
 
R_Bruce_MorrisColonel (Retired)Author Commented:
Hi Jonvee: I have started from your last recommendation.  I have downloaded and run HijackThis 2.2.  The relevant logfile is attached.  I will respond separately to the other suggestions. Appreciatively, Arbyem
Logfile of Trend Micro HijackThis v2.0.2
Scan saved at 8:41:20 PM, on 20/04/09
Platform: Windows XP SP3 (WinNT 5.01.2600)
MSIE: Internet Explorer v7.00 (7.00.6000.16762)
Boot mode: Normal
 
Running processes:
C:\WINDOWS\System32\smss.exe
C:\WINDOWS\system32\winlogon.exe
C:\WINDOWS\system32\services.exe
C:\WINDOWS\system32\lsass.exe
C:\WINDOWS\system32\svchost.exe
C:\WINDOWS\System32\svchost.exe
C:\Program Files\Common Files\Symantec Shared\ccSvcHst.exe
C:\Program Files\Lavasoft\Ad-Aware\aawservice.exe
C:\WINDOWS\system32\spoolsv.exe
C:\WINDOWS\Explorer.EXE
C:\Program Files\Common Files\Apple\Mobile Device Support\bin\AppleMobileDeviceService.exe
C:\Program Files\Symantec\LiveUpdate\AluSchedulerSvc.exe
C:\Program Files\Bonjour\mDNSResponder.exe
C:\WINDOWS\System32\svchost.exe
C:\Program Files\Common Files\Microsoft Shared\VS7DEBUG\MDM.EXE
C:\Program Files\Norton SystemWorks\Norton Utilities\NPROTECT.EXE
C:\WINDOWS\System32\nvsvc32.exe
C:\Program Files\Retrospect\Retrospect 7.6\retrorun.exe
C:\WINDOWS\System32\tcpsvcs.exe
C:\WINDOWS\System32\snmp.exe
C:\PROGRA~1\NORTON~2\SPEEDD~1\nopdb.exe
C:\WINDOWS\System32\svchost.exe
C:\Program Files\Uniblue\DiskRescue\UBDiskRescueSrv.exe
C:\Program Files\Common Files\Pure Networks Shared\Platform\nmsrvc.exe
C:\Program Files\Common Files\Real\Update_OB\realsched.exe
C:\Program Files\Common Files\Symantec Shared\ccSvcHst.exe
C:\WINDOWS\SOUNDMAN.EXE
C:\Program Files\Common Files\Pure Networks Shared\Platform\nmctxth.exe
C:\Program Files\Pure Networks\Network Magic\nmapp.exe
C:\WINDOWS\system32\LVCOMSX.EXE
C:\Program Files\Logitech\Video\LogiTray.exe
C:\Program Files\iTunes\iTunesHelper.exe
C:\WINDOWS\system32\ctfmon.exe
C:\Program Files\iPod\bin\iPodService.exe
C:\Program Files\Logitech\Video\FxSvr2.exe
C:\PROGRA~1\COMMON~1\SYMANT~1\CCPD-LC\symlcsvc.exe
C:\WINDOWS\Explorer.EXE
C:\HijackThis\HiJackThis22.exe
 
R0 - HKCU\Software\Microsoft\Internet Explorer\Main,Start Page = http://by102w.bay102.mail.live.com/mail/todaylight.aspx?n=461298691
R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Default_Page_URL = http://go.microsoft.com/fwlink/?LinkId=69157
R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Default_Search_URL = http://go.microsoft.com/fwlink/?LinkId=54896
R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Search Page = http://by102w.bay102.mail.live.com/mail/todaylight.aspx?n=461298691
R0 - HKLM\Software\Microsoft\Internet Explorer\Main,Start Page = http://by102w.bay102.mail.live.com/mail/todaylight.aspx?n=461298691
R0 - HKLM\Software\Microsoft\Internet Explorer\Search,SearchAssistant = 
R0 - HKLM\Software\Microsoft\Internet Explorer\Search,CustomizeSearch = 
R0 - HKCU\Software\Microsoft\Internet Explorer\Main,Local Page = 
R0 - HKLM\Software\Microsoft\Internet Explorer\Main,Local Page = 
O2 - BHO: Adobe PDF Reader Link Helper - {06849E9F-C8D7-4D59-B87D-784B7D6BE0B3} - C:\Program Files\Common Files\Adobe\Acrobat\ActiveX\AcroIEHelper.dll
O2 - BHO: Skype add-on (mastermind) - {22BF413B-C6D2-4d91-82A9-A0F997BA588C} - C:\Program Files\Skype\Toolbars\Internet Explorer\SkypeIEPlugin.dll
O2 - BHO: RealPlayer Download and Record Plugin for Internet Explorer - {3049C3E9-B461-4BC5-8870-4C09146192CA} - C:\Program Files\Real\RealPlayer\rpbrowserrecordplugin.dll
O2 - BHO: WormRadar.com IESiteBlocker.NavFilter - {3CA2F312-6F6E-4B53-A66E-4E65E497C8C0} - (no file)
O2 - BHO: REALBAR - {4E7BD74F-2B8D-469E-C0FF-FD60B590A87D} - (no file)
O2 - BHO: Spybot-S&D IE Protection - {53707962-6F74-2D53-2644-206D7942484F} - C:\PROGRA~1\SPYBOT~1\SDHelper.dll
O2 - BHO: NCO 2.0 IE BHO - {602ADB0E-4AFF-4217-8AA1-95DAC4DFA408} - C:\Program Files\Common Files\Symantec Shared\coShared\Browser\2.5\coIEPlg.dll
O2 - BHO: Symantec Intrusion Prevention - {6D53EC84-6AAE-4787-AEEE-F4628F01010C} - C:\PROGRA~1\COMMON~1\SYMANT~1\IDS\IPSBHO.dll
O2 - BHO: SSVHelper Class - {761497BB-D6F0-462C-B6EB-D4DAF1D92D43} - C:\Program Files\Java\jre1.6.0_07\bin\ssv.dll
O2 - BHO: (no name) - {7E853D72-626A-48EC-A868-BA8D5E23E045} - (no file)
O2 - BHO: Windows Live Sign-in Helper - {9030D464-4C02-4ABF-8ECC-5164760863C6} - C:\Program Files\Common Files\Microsoft Shared\Windows Live\WindowsLiveLogin.dll
O2 - BHO: ST - {9394EDE7-C8B5-483E-8773-474BF36AF6E4} - C:\Program Files\Windows Live Toolbar\stmain.dll
O2 - BHO: Google Toolbar Helper - {AA58ED58-01DD-4d91-8333-CF10577473F7} - c:\program files\google\googletoolbar4.dll
O2 - BHO: Google Toolbar Notifier BHO - {AF69DE43-7D58-4638-B6FA-CE66B5AD205D} - C:\Program Files\Google\GoogleToolbarNotifier\3.0.1225.9868\swg.dll
O2 - BHO: CIEExtension Object - {B51DC573-E998-4834-9B45-BAB7C2AE0A75} - (no file)
O2 - BHO: Windows Live Toolbar Helper - {BDBD1DAD-C946-4A17-ADC1-64B5B4FF55D0} - C:\Program Files\Windows Live Toolbar\msntb.dll
O2 - BHO: NAV Helper - {BDF3E430-B101-42AD-A544-FADC6B084872} - (no file)
O3 - Toolbar: REALBAR - {4E7BD74F-2B8D-469E-C0FF-FD60B590A87D} - (no file)
O3 - Toolbar: Windows Live Toolbar - {BDAD1DAD-C946-4A17-ADC1-64B5B4FF55D0} - C:\Program Files\Windows Live Toolbar\msntb.dll
O3 - Toolbar: &Google - {2318C2B1-4965-11d4-9B18-009027A5CD4F} - c:\program files\google\googletoolbar4.dll
O3 - Toolbar: Show Norton Toolbar - {7FEBEFE3-6B19-4349-98D2-FFB09D4B49CA} - C:\Program Files\Common Files\Symantec Shared\coShared\Browser\2.5\CoIEPlg.dll
O4 - HKLM\..\Run: [NvCplDaemon] RUNDLL32.EXE C:\WINDOWS\System32\NvCpl.dll,NvStartup
O4 - HKLM\..\Run: [ccApp] "C:\Program Files\Common Files\Symantec Shared\ccApp.exe"
O4 - HKLM\..\Run: [TkBellExe] "C:\Program Files\Common Files\Real\Update_OB\realsched.exe"  -osboot
O4 - HKLM\..\Run: [SoundMan] SOUNDMAN.EXE
O4 - HKLM\..\Run: [osCheck] "C:\Program Files\Norton Internet Security\osCheck.exe"
O4 - HKLM\..\Run: [nmctxth] "C:\Program Files\Common Files\Pure Networks Shared\Platform\nmctxth.exe"
O4 - HKLM\..\Run: [nmapp] "C:\Program Files\Pure Networks\Network Magic\nmapp.exe" -autorun -nosplash
O4 - HKLM\..\Run: [LVCOMSX] C:\WINDOWS\system32\LVCOMSX.EXE
O4 - HKLM\..\Run: [LogitechVideoTray] C:\Program Files\Logitech\Video\LogiTray.exe
O4 - HKLM\..\Run: [LogitechVideoRepair] C:\Program Files\Logitech\Video\ISStart.exe 
O4 - HKLM\..\Run: [Kernel and Hardware Abstraction Layer] KHALMNPR.EXE
O4 - HKLM\..\Run: [iTunesHelper] "C:\Program Files\iTunes\iTunesHelper.exe"
O4 - HKLM\..\Run: [LELA] "C:\Program Files\Linksys\Linksys EasyLink Advisor\Linksys EasyLink Advisor.exe" /minimized
O4 - HKLM\..\Run: [KernelFaultCheck] %systemroot%\system32\dumprep 0 -k
O4 - HKCU\..\Run: [ctfmon.exe] C:\WINDOWS\system32\ctfmon.exe
O4 - HKCU\..\Run: [LogitechSoftwareUpdate] "C:\Program Files\Logitech\Video\ManifestEngine.exe" boot
O4 - HKUS\S-1-5-18\..\Run: [ALUAlert] C:\Program Files\Symantec\LiveUpdate\ALUNotify.exe (User 'SYSTEM')
O4 - HKUS\.DEFAULT\..\Run: [ALUAlert] C:\Program Files\Symantec\LiveUpdate\ALUNotify.exe (User 'Default user')
O4 - .DEFAULT User Startup: CUseeMe Setup.lnk = ? (User 'Default user')
O9 - Extra button: (no name) - {08B0E5C0-4FCB-11CF-AAA5-00401C608501} - C:\Program Files\Java\jre1.6.0_07\bin\ssv.dll
O9 - Extra 'Tools' menuitem: Sun Java Console - {08B0E5C0-4FCB-11CF-AAA5-00401C608501} - C:\Program Files\Java\jre1.6.0_07\bin\ssv.dll
O9 - Extra button: CUseeMe Conferencing Companion - {44EFB53C-C965-43CF-9F45-52242D134187} - C:\Program Files\CUseeMe\Amigo.exe
O9 - Extra button: Skype - {77BF5300-1474-4EC7-9980-D32B190E9B07} - C:\Program Files\Skype\Toolbars\Internet Explorer\SkypeIEPlugin.dll
O9 - Extra button: Bonjour - {7F9DB11C-E358-4ca6-A83D-ACC663939424} - C:\Program Files\Bonjour\ExplorerPlugin.dll
O9 - Extra button: Research - {92780B25-18CC-41C8-B9BE-3C9C571A8263} - C:\PROGRA~1\MICROS~2\OFFICE11\REFIEBAR.DLL
O9 - Extra button: (no name) - {CD67F990-D8E9-11d2-98FE-00C0F0318AFE} - (no file)
O9 - Extra button: (no name) - {DFB852A3-47F8-48C4-A200-58CAB36FD2A2} - C:\PROGRA~1\SPYBOT~1\SDHelper.dll
O9 - Extra 'Tools' menuitem: Spybot - Search & Destroy Configuration - {DFB852A3-47F8-48C4-A200-58CAB36FD2A2} - C:\PROGRA~1\SPYBOT~1\SDHelper.dll
O9 - Extra button: (no name) - {e2e2dd38-d088-4134-82b7-f2ba38496583} - C:\WINDOWS\Network Diagnostic\xpnetdiag.exe
O9 - Extra 'Tools' menuitem: @xpsp3res.dll,-20001 - {e2e2dd38-d088-4134-82b7-f2ba38496583} - C:\WINDOWS\Network Diagnostic\xpnetdiag.exe
O9 - Extra button: Messenger - {FB5F1910-F110-11d2-BB9E-00C04F795683} - C:\Program Files\Messenger\msmsgs.exe
O9 - Extra 'Tools' menuitem: Windows Messenger - {FB5F1910-F110-11d2-BB9E-00C04F795683} - C:\Program Files\Messenger\msmsgs.exe
O15 - Trusted Zone: http://download.windowsupdate.com
O16 - DPF: {0B79F48A-E8D6-11DB-9283-E25056D89593} (F-Secure Online Scanner 3.1) - http://support.f-secure.com/ols/fscax.cab
O16 - DPF: {17492023-C23A-453E-A040-C7C580BBF700} (Windows Genuine Advantage Validation Tool) - http://go.microsoft.com/fwlink/?linkid=39204
O16 - DPF: {2ED9BC2B-4DF1-472E-9B5E-55477D2C97F5} (Microsoft Data Collection Control) - https://support.microsoft.com/OAS/ActiveX/odc.cab
O16 - DPF: {4CCA4E80-9259-11D9-AC6E-444553544200} (FixController Control) - http://h30155.www3.hp.com/ediags/dd/install/HPInstallMgr_v01_5.cab
O16 - DPF: {5F8469B4-B055-49DD-83F7-62B522420ECC} (Facebook Photo Uploader Control) - http://upload.facebook.com/controls/FacebookPhotoUploader.cab
O16 - DPF: {85BA505F-FD01-4A91-836C-F7D502E89C9A} (Image Uploader Control) - http://www.evite.com/html/imageUpload/ImageUploader4.cab
O16 - DPF: {BDBDE413-7B1C-4C68-A8FF-C5B2B4090876} (F-Secure Online Scanner 3.3) - http://support.f-secure.com/ols/fscax.cab
O16 - DPF: {CB50428B-657F-47DF-9B32-671F82AA73F7} (Photodex Presenter AX control) - http://www.photodex.com/pxplay.cab
O16 - DPF: {FFD85DC8-5261-4D11-B728-F7C59D911691} (iolo.ProductDetector) - http://www.iolo.com/app/ocx/UpgradeVerify.ocx
O18 - Protocol: intu-qt2007 - {026BF40D-BA05-467B-9F1F-AD0D7A3F5F11} - C:\Program Files\QuickTax 2007\ic2007pp.dll
O18 - Protocol: intu-qt2008 - {05E53CE9-66C8-4A9E-A99F-FDB7A8E7B596} - C:\Program Files\QuickTax 2008\ic2008pp.dll
O18 - Protocol: skype4com - {FFC8B962-9B40-4DFF-9458-1830C7DD7F5D} - C:\PROGRA~1\COMMON~1\Skype\SKYPE4~1.DLL
O23 - Service: Lavasoft Ad-Aware Service (aawservice) - Lavasoft - C:\Program Files\Lavasoft\Ad-Aware\aawservice.exe
O23 - Service: Apple Mobile Device - Apple Inc. - C:\Program Files\Common Files\Apple\Mobile Device Support\bin\AppleMobileDeviceService.exe
O23 - Service: Automatic LiveUpdate Scheduler - Symantec Corporation - C:\Program Files\Symantec\LiveUpdate\AluSchedulerSvc.exe
O23 - Service: Bonjour Service - Apple Inc. - C:\Program Files\Bonjour\mDNSResponder.exe
O23 - Service: Symantec Event Manager (ccEvtMgr) - Symantec Corporation - C:\Program Files\Common Files\Symantec Shared\ccSvcHst.exe
O23 - Service: Symantec Settings Manager (ccSetMgr) - Symantec Corporation - C:\Program Files\Common Files\Symantec Shared\ccSvcHst.exe
O23 - Service: Symantec Lic NetConnect service (CLTNetCnService) - Symantec Corporation - C:\Program Files\Common Files\Symantec Shared\ccSvcHst.exe
O23 - Service: COM Host (comHost) - Symantec Corporation - C:\Program Files\Common Files\Symantec Shared\VAScanner\comHost.exe
O23 - Service: Google Updater Service (gusvc) - Google - C:\Program Files\Google\Common\Google Updater\GoogleUpdaterService.exe
O23 - Service: InstallDriver Table Manager (IDriverT) - Macrovision Corporation - C:\Program Files\Common Files\InstallShield\Driver\1150\Intel 32\IDriverT.exe
O23 - Service: iPod Service - Apple Inc. - C:\Program Files\iPod\bin\iPodService.exe
O23 - Service: Logitech Bluetooth Service (LBTServ) - Logitech, Inc. - C:\Program Files\Common Files\Logishrd\Bluetooth\LBTServ.exe
O23 - Service: Linksys Updater (LinksysUpdater) - Unknown owner - C:\Program Files\Linksys\Linksys Updater\bin\LinksysUpdater.exe
O23 - Service: LiveUpdate - Symantec Corporation - C:\Program Files\Symantec\LiveUpdate\LuComServer_3_4.EXE
O23 - Service: LiveUpdate Notice - Symantec Corporation - C:\Program Files\Common Files\Symantec Shared\ccSvcHst.exe
O23 - Service: Pure Networks Platform Service (nmservice) - Cisco Systems, Inc. - C:\Program Files\Common Files\Pure Networks Shared\Platform\nmsrvc.exe
O23 - Service: Norton Unerase Protection (NProtectService) - Symantec Corporation - C:\Program Files\Norton SystemWorks\Norton Utilities\NPROTECT.EXE
O23 - Service: NVIDIA Display Driver Service (NVSvc) - NVIDIA Corporation - C:\WINDOWS\System32\nvsvc32.exe
O23 - Service: Pml Driver HPZ12 - HP - C:\WINDOWS\System32\HPZipm12.exe
O23 - Service: Retrospect Launcher (RetroLauncher) - EMC Corporation - C:\Program Files\Retrospect\Retrospect 7.6\retrorun.exe
O23 - Service: Retrospect Helper - EMC Corporation - C:\Program Files\Retrospect\Retrospect 7.6\rthlpsvc.exe
O23 - Service: Speed Disk service - Symantec Corporation - C:\PROGRA~1\NORTON~2\SPEEDD~1\nopdb.exe
O23 - Service: Symantec Core LC - Unknown owner - C:\PROGRA~1\COMMON~1\SYMANT~1\CCPD-LC\symlcsvc.exe
O23 - Service: Symantec RemoteAssist - Symantec, Inc. - C:\Program Files\Common Files\Symantec Shared\Support Controls\ssrc.exe
O23 - Service: Uniblue DiskRescue - Uniblue - C:\Program Files\Uniblue\DiskRescue\UBDiskRescueSrv.exe
 
--
End of file - 13262 bytes

Open in new window

0
 
R_Bruce_MorrisColonel (Retired)Author Commented:
Hi again Jonvee & dstewartjr:  While awaiting a response to the review of the HijackThis log , I note that I have used an up-to-date NIS 2008 to scan my Main system, with no malware detected.  I have an additional, perhaps related problem in that, when I tried to run ZA Pro 8, after having it updated, it would not open!  Furthermore, when I tried to uninstall it, my system crashed before the uninstall could be completed.  A second attempt, using RevoUninstaller produced the same result - a system crash [IRQL_NOT_LESS_OR_EQUAL STOP 0x0000000A (0x000002F0, 0x00000002, 0x00000000, 0x804E39A7)].  I was unable to upload the HijackThis logfile to Trend Micro, because I receive a "Network Timeout" error message from Firefo 3.0.8.
I also ran Spybot S&D v1.6.0 with no malware being detected.
I realize that my system could be vulnerable, given no Windows updates since Jan 09.
I continue to be able to have Symantec Liveupdate update NIS 2008 successfully, but not  able to connect to Windows Update website.   More to follow.  Thanks to all. Arbyem
0
 
Donald StewartNetwork AdministratorCommented:
did you atleast try the tool from bdtools.net?
0
 
JonveeCommented:
The delay in a review response is of course due to Time Zone differences .. have now logged in ... now analysing your HijackThis logfile ..
0
 
JonveeCommented:
These entries can be 'Fixed' with HijackThis.  The "Realbar" entries look like part of an earlier RealPlayer installation which you may want to remove anyway>>
 
O2 - BHO: REALBAR - {4E7BD74F-2B8D-469E-C0FF-FD60B590A87D} - (no file)
O2 - BHO: CIEExtension Object - {B51DC573-E998-4834-9B45-BAB7C2AE0A75} - (no file)
O3 - Toolbar: REALBAR - {4E7BD74F-2B8D-469E-C0FF-FD60B590A87D} - (no file)
O2 - BHO: NAV Helper - {BDF3E430-B101-42AD-A544-FADC6B084872} - (no file)

Apart from those 4 items there does not *appear* to be any bad infection.  HijackThis does not usually detect rootkits, for example.   However it's always prudent to check with a number of scanners because they tend to compliment each other.

Malwarebytes' Anti-Malware is excellent, and it would be useful if you're able to run it.

Hopefully you've been able to run "bdtools", suggested by dstewartjr ?

You could also try Superantispyware:                        
http://www.superantispyware.com/

0
 
R_Bruce_MorrisColonel (Retired)Author Commented:
I fixed all items from the Spybot S&D scan results.  I ran Bit defender and it showed sysem clean.  I installed SUPERAntiSpuware, but was unable to determine if I successfully retrieved the latest sypyware definitions from the server (with Internet connectivity indicated as connected).  There were no error messages, so perhaps connectivity was achieved!  The scan results were duly processed.  After all of the above, I still cannot connect to Windows Update via either IE7 or Firefox!
0
 
Donald StewartNetwork AdministratorCommented:
0
 
R_Bruce_MorrisColonel (Retired)Author Commented:
What very strange behavior!  Following a shut-down, the 10 Windows Updates, somehow waiting in a queue (how or where is unknown to me), were installed, apparently successfully.  I was able, finally, to access the Windows Update website/page.  But before I checked for further updates (Express), I tried to review my update history.  The website crashed, and I could once again, not access the Windows Update website server!  I have yet to try the recommended actions from dstewartjr.  Frustratingly, Arbyem
0
 
R_Bruce_MorrisColonel (Retired)Author Commented:
I remain unable to contact to the Windows Update website via either IE7 or Firefox.  However, I am still able to update NIS 2008 via Symantec Liveupdate.  Attached is the Windows Network Diagnostic file from 19 Apr 09.  For some reason, I do not seem to be able to obtain a more recent version, despite having run Windows diagnostic sevices today (even though the Internet connection appears OK for both Windows Networks and Network Magic Pro).  I did note today that, after a
disk Cleanup operation, my C:\ drive has only 4.6 GB free of the 59 GB total in the main partition (120 GB  WD internal drive).  But this fact ought not to be affecting my ability to connect to the Internet websites other than Live Update.  Hopefully, some rational solution may be forthcoming.  Thanks, Arbyem
Windows-Last-diagnostic-run-time.doc
0
 
JonveeCommented:

To regain HD space, and possibly affect your main problem, i suggest you initially reduce the number of running apps using the SCU >
http://netsquirrel.com/msconfig/msconfig_xp.html

Or if you prefer, use this method of running the command "services.msc" (no quotes)>
http://www.blackviper.com/WinXP/service411.htm

Did you have the opportunity to look at Zone Alarm ?    Assuming yes, and in view of your recent findings, i would then be inclined to uninstall NIS 2008 using this link >

The steps differ depending on what product you have.
http://service1.symantec.com/SUPPORT/tsgeninfo.nsf/docid/2005033108162039?Open&docid=2005092709200113&nsf=sharedtech.nsf&view=docid

Then try the Windows update website connection.

0
 
JonveeCommented:
Found this Microsoft article that may help.  If you look under "Resolution" you'll see a number of different methods for resolving the problem, in particular Method 3: Rename the Catroot2 folder, and Method 4: Reregister DLL files that are associated with Cryptographic Services.

Note that if the problem is resolved by any particular method, you do not have to use the remaining methods.
 
"You cannot install some updates or programs":
http://support.microsoft.com/kb/822798/

0
 
Donald StewartNetwork AdministratorCommented:
Better yet, Try Dial-a-Fix



http://wiki.lunarsoft.net/wiki/Dial-a-fix
0
 
R_Bruce_MorrisColonel (Retired)Author Commented:
Hi again experts:  I continue to attempt to resolve my current unfortunate situation in respect of being unable to access the Windows Update website through my desktop system.  I have tried all of the proposed solutions, except that I have not yet uninstalled my NIS 2008 product.  The symptoms previously remain, despite the application of those potential solutions.  My Windows Networking and Network Magic Pro (when enabled) still show a successful LAN connection through my cable modem.  My Laptop still works via the wireless link on my new Linksys 160N V2.  I still cannot install the Cisco Linksys EasyLink Advisor or the Linksys Router on my desktop (it is installed successfully on my laptop).  Symantec Live Update still runs successfully, most of the time.  I still cannot connect to any website through Firefox 3.0.8, although the response varies between "Address not found" and "Network Timeout".   None of my various anti-malware programs, or my DriverAgent and Driver Detective programs are able to connect to the Internet for updates.  I still cannot uninstall Zone Alarm Pro, because the system crashes before the uninstall process is complete (via either Windows uninstall or RevoUninstaller).  I am unable to determine what ought to be tried next!  Any other ideas? Thanks to all for the assistance to date.  Arbyem
0
 
R_Bruce_MorrisColonel (Retired)Author Commented:
Hi again experts:  I wanted to return to some basics regarding the Internet connection, or rather the failure to be able to connect.  I tried several "pings" (via run: cmd/ C:\ ping ) to commonly used websites.  The one to cogeco.net worked, as did the one to mozilla.com.  However, those to cogeco.ca (my ISP server), and to windowsupdate.microsoft.com did NOT.  This appears to be consistent with the results of pinging used by the technician at the Cogeco Help Desk.  He reported that he was able to receive a ping from my system, but that he could not send one to my system that would be received at his test site.  Does this indicate any particular type of problem?  Why am I able to successfully ping only a few servers? Appreciatively, Arbyem
0
 
JonveeCommented:
Arbyem,
While i ponder on your last enquiry regarding pinging (which Dial-a-Fix should perhaps have resolved), you may like to view this ongoing thread dealing with a similar issue, particularly this MS link>

"Microsoft Update":
http://winhlp.com/node/36

http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Windows/XP/Q_24360005.html#a24248264
0
 
JonveeCommented:
In the "winhlp" link above, please note the Marc Liron's Web and the Kelly's Korner links.

You may also find this article useful, & worth studying>
"Blocking Unwanted Parasites with a Hosts File":
http://www.mvps.org/winhelp2002/hosts.htm
0
 
R_Bruce_MorrisColonel (Retired)Author Commented:
Hi Jonvee:  Thanks for the further pointers to follow.  I am not finished my review of the contents of each.  Meanwhile, attached is a copy of my Windows Update Log (28 Apr 09).  Perhaps there may be some clue to my problem?  Appreciatively, Arbyem
WindowsUpdate-090428.log
0
 
Donald StewartNetwork AdministratorCommented:
The error in your log points to here
http://support.microsoft.com/kb/836941 
0
 
Donald StewartNetwork AdministratorCommented:
also read here for that error as well
 
Troubleshooting Error 0x80072efd
0
 
JonveeCommented:

From your Windows update log, both errors 0x80072ee7 and 0x80072efd are evident.

So another approach may be to view the information in this forum.  Scroll down to the comments by PA Bear [MS MVP], and you'll see a list of instructions.  There are several steps to follow, that offer a possible solution  >>

Can't get into update - error 0x80072EE7
http://www.eggheadcafe.com/software/aspnet/34135466/cant-get-into-update--e.aspx

0
 
R_Bruce_MorrisColonel (Retired)Author Commented:
Hi again jonvee & dstewartjr:  I have taken some further steps to diagnose the problem.  I used the Ultimate Boot CD (V4.1.1) to run Memtest86+ (v1.70) with the unfortunate result of 98 errors (10 failure entries for Test #2).  I was unable to acquire a screen shot of the results, but I did make some written notes of the highlights.  Presumably, this points to RAM problems!
I reconfigured my network to remove the Cisco Linksys WRT160N V2 router. I further tried the solution in the last post above.  I downloaded the requisite files, transferred them from my laptop to my main system, and executed the FixWU.cmd file in the DOS window.  The process appeared to run to completion, with the final entry "Automatic Updating is started".
However, Windows Update still produced the IE7 error "Cannot load the webpage".  Also, running the update.windows.microsoft in Firefox 3.0.8 produced a "Network Timeout" error.
Throughout these processes, I noted that both Window Networking Status and Network Magic Pro showed that the LAN was connected.  I am attaching the xpnetdiag.xml file from Windows Networking Status.
  I repeated the "ping" tests, with the same results as before i.e. update.symantec.com was successful (NIS 2008 updates are still working correctly - most of the time), cogeco.net was successful, but cogeco.ca was not, mozilla.com was successful, but I could not achieve a connection to any website/webpage via Firefox 3.0.8.
  I remain totally perplexed as to the nature of any resolution to my problem, short of replacing my Main system!  Please help with any other alternative possibilities before having to take such a dire solution.  Thanks, in advance, Arbyem
Last-diagnostic-run-time-xpnetdi.doc
0
 
Donald StewartNetwork AdministratorCommented:
Have you tried disabling windows firewall and any other firewalls you may have?
0
 
R_Bruce_MorrisColonel (Retired)Author Commented:
Hi dstewartjr: Yes, I do NOT use Windows Firewall, and I have tried to access Windows Update with NIS 2008 de-activated. The one possible area of concern is that I have, despite repeated attempts, been unable to complete the installation of the Cisco Linksys WRT160N V2 router on my Main System.  The installation process repeatedly halts with an Error 322 Unable to detect the router.  I have successfully loaded the router on my HP Laptop System so that I could read the Linksys Easylink Advisor material.  I had obviously wanted to see if I was doing anything wrong so as to jeopardize the installation of the router onto my Main System.  To use my HP Laptop on wireless, plus my wife's Win ME-based cdesktop, located upstairs, I have to have the router configured between my RCA Cable Modem (from Cogeco, my ISP) and my Main desktop system.
I acknowledge that both the errors 0x0072ee7 and 0x007efd, from my Windows Update log, are the root cause of some aspects of my problems in not being able to access Windows Update.  As I noted above, I am unable to do so even after executing the resolution process described in the referenced webpage.  So what now?  Appreciatively,
Arbeyem.
0
 
R_Bruce_MorrisColonel (Retired)Author Commented:
Hi again Experts:  I continue to try different possible resolutions for my Windows Updates failures to connect.  My latest involved conducting the processes recommended by dstewartjr.  I completed the process, apparently successfully.  
By using System Configuration Utility in Startup Tab to Hide all Microsoft services, and disabling all others, Windows Update actually made a successful connection, with Selective Mode enabled. During this session, the response times for all operations were extremely slow!  In particular, opening MS WORD 2003, to record the details of my attempts to resolve the problem, resulted in very slow responses.  However, in attempting to download and install the four updates detected by Windows Update, none of the updates (total of 343 MB) could be downloaded  the initial one almost downloaded before the connectivity was degraded (throttling?), while the remaining three never had any portion downloaded before failure was signified.  The Review Update History recorded the following status: (see attached file).
Actually, two further pages revealed that 11 updates had been successful on 22 Apr 09, 10 on 20 Apr 09, and two had failed, one on 15 Apr 09, and one on 16 Apr 09.  
However, any further attempts to connect to Windows Updates failed.  The Main system had to be closed down (to permit one update to be installed), then restarted, leaving the System configuration Utility in its Selective Startup mode.  Windows update could again be accessed, but only for one operation from the website, before the connection was again inaccessible!  Further, during operations within this mode, all operations were extremely slow, with MS Word 2003 not even completing its open status!
The Main system was restarted, and placed back in Normal Mode.   However, Windows Update was again unsuccessful in accessing the website!  Despite a further restart, Windows Update website was again unable to open the webpage in IE7!  I have yet to retry the System Configuration Utility process described above to permit, hopefully, a successful connection to Windows Update, so as to download the four updates, and install them on my Main system.  At least I now have updates for Windows, up to the last four!
Any more ideas on what further complications have been introduced into my system?
Appreciatively, Arbyem


Extract-MainInterconnectionWindo.doc
0
 
JonveeCommented:
Collected one or two more suggestions, and MS articles that may help, although it's now possible that there's repetition as the thread lengthens >>

An earlier thread>
"windows xp update":  Automatic Updates stops working:
http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Windows/XP/Q_23064208.html

This is worth studying although the 'fix' may well be covered earlier by "Dial-a-Fix" >>
Windows update fail to install no error code:
http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Windows/XP/Q_22667251.html

Incidently have you tried deleting your temporary internet files *and* the contents of the "C:\Windows\Software Distribution" folder ?     If no, please try it, then try Windows Update again.

Although i'm not absolutely sure whether you have done a repair install recently, you may wish to see if these two are relevant >>
Updates are not installed successfully from Windows Update, from Microsoft Update, or by using Automatic Updates after you repair a Windows XP installation:
http://support.microsoft.com/kb/943144

Automatic Updates stops working after a repair install of Windows XP
http://support.microsoft.com/kb/555615

Finally, if you still find no resolution above, and between us we have no further suggestions, you may wish to consider a repair install >>
How to Perform a Windows XP Repair Install:
http://www.michaelstevenstech.com/XPrepairinstall.htm

0
 
JonveeCommented:
Ahh, here's another possibility, particularly the "Windows Genuine Advantage" and the "Validate Now" links >>

Windows update. Udates failed to install now constantly wanting to install every restart:
http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Windows/XP/Q_23082015.html
0
 
blue-screenCommented:
If you have memory errors, NOTHING ELSE MATTERS.  Replace the memory now (or adjust the timings in BIOS, if they are set incorrectly).  You need a complete clean bill of health in memtest before proceeding on any other part of this problem.

By the way, you have a string of several questions here - you should award points on the individual fixed steps and open a new question.  I don't care if I get any points, but you are unfairly jumping from problem to problem in this post.

If you were running with bad memory, it is possible that you have an irrevocably corrupted Windows install, depending on how the errors played themselves out.  Before doing ANYTHING ELSE, you absolutely MUST fix the memory problems.  Running a system on faulty memory is a time bomb.  At any rate, ANY of the problems you are seeing could be bad memory, so get it fixed, and fixed soon before doing any more diagnosis.
0
 
R_Bruce_MorrisColonel (Retired)Author Commented:
Hi blue-screen (info jonvee & dstewartjr):  I acknowledge your observation regarding too many problems within this single post, despite the fact that all are inter-related!  I will terminate this thread once I provide a "final" report on my current, still unsatisfactory, status.
In the matter of RAM status, I have not replaced my 1 GB of RAM.  Although I did have one Memtest86+ result which indicated 10 errors from test #2, I have since rerun both Memtest86+ V1.70, and Memtest86 V3.3 with no errors detected/reported.  I can draw no rational conclusion from this situation.  
  To date, I have accomplished only a partial resolution to the Access to Windows Update, in that I can at least access Windows Update by booting my system using run/msconfig to shut down (disable) all Non-Microsoft services, leave the system in Selective Mode, and obtain a one-time connection to Windows Update.  However, I am unable to perform a second access to any Windows Update functions, and I cannot access Firefox webpages.  After many failed attempts, I was finally able to update IE from v7 to v8.
This situation prevails regardless of the fact of both Windows Networking and Network Magic Pro showing correct connectivity (BTW, I just updated my Linksys Easylink Advisor to Cisco's Network Magic Pro 5.1, thereby combining the previously separate Linksys Easylinkk Advisor - part of my newly installed Cisco WRT 160N v2 router - and Network Magic Pro 5.0). Also, proof of a working Internet connection is that NIS 2008 Symantec Live Update works correctly most of the time.  However, the Update processes for most other Anti-Malware products do not achieve the requisite connectivity.
Once this post is acknowledged, I will cause it to be closed, and start a new thread to address my continuing problems with only limited access to Windows Update (still unable to complete the installation of the remaining three priority updates).  My latest updated document tracking my long series of problems is attached.
Appeciatively, Arbyem

main-internetconnectproblem-0905.doc
0
 
JonveeCommented:
Arbyem .. i regret that we were unable to help you with a final solution even though you gave us what i consider to be some of the most thoroughly written reports that i have seen!

Good luck with your new thread.
Jonvee.
0
 
ComputerHelperGuyCommented:
Thank you!!! bdtools.net worked for me!
0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

  • 14
  • 12
  • 7
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now