[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 277
  • Last Modified:

how should internet outbound messege route from ex2003 server in a mix ex2007 environment

Dear Experts,

We installed an exch. 2007 server in single forest, single domain, single exch. 2003 server environment. We did a typical installation and installed hub transport, client access and mailbox role on the same machine. All went smooth and looks working fine with few issues. We moved few mailbox on new server and are working fine
1: mailbox users on both servers can send and recieve mails to each other.
2: mailbox users on both servers can recieve mails from internet
3: mailbox users on exch 2007 server can send mails to internet.
Now the problems:
1: mail sent to internet from mailbox user on exch 2003 does not go and stay in the queue on the 2K3 exchange server. (please note that we have an email proxy installed at the internet gateway (filewall level) and that is now configured to allow outboud mails from exch.  2007 server and Exch. 2007 is NAT to our public IP). My understanding is that outbound internet mails from the exch. 2003 should go to exch. 2007 server and from there it shoud use the exch 2007 internet send connector to deliver the mail to internet. If we just reverse the setting on our firewall all the mails accumulated in the queue on EXCH 2003 are instantly delivered which means exch 2003 server is still using its own smtp internet connecter.
ON the system manager of exch 2003 under Routing group/First routing group/ connectors I can see two connecters
a) exch 2003 to exch 2007
b) internet
My questing is should we jsut delete the second one or some other setting needs to be done to resolve the issue?
2: Moving of the mailbox from exch 2003 to exch 2007 server finished with success and the users is able to work without any issue on the exch 2007 server but exch. 2003 still shows the mailbox with a red cross on it. We manually tried to purge but it gives follinwing error form the system manager. "the operation cannot be performed because the mailbox was alerady reconnected to an existing user."  We have stopped moving further mailbox just to make sure if this is not a serious issue.
3: Only Non domain users on exch. 2007 are unable to download offline address book.

Mohsin
0
skylife19
Asked:
skylife19
  • 5
  • 3
  • 3
2 Solutions
 
RammesteinCommented:
1) you can delete the second connector safely.
2)Disconnect the mailboxes from 2007.
  Then,run clean-mailboxdatabase from the shell.
  goto 2003,purge the mailbox.
  goto 2007,disconnected mailboxes and reconnect the mailbox.
3)When u say non-domain users,are they in the local lan?
  Are they use rpc over http,pop,imap??
0
 
skylife19Author Commented:
Thankyou boss, first two problems are resolved as you suggested. Regarding third my mistake in writing non-domain users. We are facing the problem with all the user domian/ noo-domain. All are in the local lan using outlook 2007. The error they recived while downloading offline address book is is following.
"Task 'Microsoft Exchange' reported error (0x8004010F) : 'The operation failed. An object cannot be found.'"

mohsin
0
 
RammesteinCommented:
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
skylife19Author Commented:
Hi,

We have already checked the above article.
Our error number is same but we are not facing issue in system manager etc this article is talking about.
We do not have this download issue with the users on exchange 2003 server, only problem is wiht exhcange 2007 users.
Our guess is that something wrong with the replicaiton of offline address book on new server or creation of the same in the new server??

Mohsin
0
 
MesthaCommented:
Have you replicated the OAB system folders from the Exchange 2003 server to the Exchange 2007 server? It doesn't happen automatically. You have to go in to the folder properties in ESM and add the new server to the list of replicas.

If you do not have an SMTP Connector on the Exchange 2003 server, then all email will be routed out through the Exchange 2007 server. Ensure that you do not have a smart host set on the SMTP virtual server in ESM which will cause a problem with email delivery.

Simon.
0
 
skylife19Author Commented:
Yes I have replicated the OAB folder from EXCH 2K3 but still the problem is there, what else should we check?

mohsin
0
 
MesthaCommented:
Does the OAB folder actually have any content in it? I have lost count the number of times people have said they have replicated the content and in actual fact nothing has happened.

get-publicfolderstatistics | where {$_.name -match "oab"}

should give you results like this.
If any of them are 0, then replication isn't working.

Name                                     ItemCount               LastAccessTime
----                                     ---------               --------------
OAB Version 2                            70                 19/03/2009 00:59:28
OAB Version 3a                           70                 19/03/2009 00:59:28
OAB Version 4                            8                  19/03/2009 00:59:28
/o=Company/cn=addrlists/c 0                  19/03/2009 00:20:41
n=oabs/cn=Default Offline Address List


Simon.
0
 
skylife19Author Commented:
we repllicated and then recently moved the OAB to new exch 2007 server. In our case the value is not zero.

outlook 2003 cleint recently moved to exch 2007 server are not facing this issue, only outlook 2007 client are getting the error.

mohsin
0
 
MesthaCommented:
If Outlook 2003 clients are not affected then it isn't public folder replication at fault. Which OAB distribution methods do you have enabled?

Simon.
0
 
skylife19Author Commented:
Thanks, my problem is already resolved. As I was exploring different forums I found fews things. This is what I did for info. to all. (please note that we are not looking for internet base access to our exchange at the moment so the settings we used are for local lan clients only, for internet access on exchange self assigned certificate would not work as per microsoft)

1: As my OAB was not on EXCH 2K7, wed base distribution was greyed in my case. To resolve I move the OAB to exch 2K7 and then was able to enable Web base dist.
2: Added a hostA record for autodiscover.<mydomain>.<ext> in my internal DNS server
3: Restart the active dierctory domain controllers and both exchange servers.

These above steps actually resolved the issue but in our case we have web proxy server and as OAB distribution is through web this was also causing problem. Without giving proxy in IE users are able to download OAB without issues.

There are still two things we need to work on but I suppose our main problem is resolved.
1: We still have to find a way to by pass proxy for OAB download.
2: Domain users on local lan are able work without any warning but non-domain users always get a security alert for the certificate whenver they open the outlook. Accepting the alert by clicking yes they can also porceed and work with no further issues. (this is a bit irritating)

In total my two queries resolved By Mr. Rammestien and third was resolved by exploring diff. forums.


0
 
RammesteinCommented:
Cool man
Have a look at this one as well
http://support.microsoft.com/kb/940726
0

Featured Post

Important Lessons on Recovering from Petya

In their most recent webinar, Skyport Systems explores ways to isolate and protect critical databases to keep the core of your company safe from harm.

  • 5
  • 3
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now