[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

Cisco Routing/VLANS

Posted on 2009-04-20
14
Medium Priority
?
465 Views
Last Modified: 2012-05-06
I have 2 layer 3 Cisco switches in site A and 2 switches in site B,  I also have a new LES circuit connecting the 2 sites.  The switches are configured in a vlan for the LES Circuit in each site.
There is also a router connecting both sites (LES Circuit will Replace the Router) All traffic going to Site B will go out the default route of 10.15.0.100 I want  the traffic to go via the LES Circuit by creating static routes on the Layer 3 switch.

From the switch in Site A I can ping the les circuit vlan Interface in site B however this is sending the traffic out via the les circuit vlan, however I am unable to ping from the server vlan.

I have a static route configured in each site i.e.site A 172.17.2.0 255.255.255.0 vlan 2
I need to able to ping from Site A from the Sever VLAN 10.15.1.1 to 172.17.2.1 (les circuit)
Site A server vlan 1 10.15.1.0x/24
Site A Les Curcuit Vlan 2 10.15.2.0/24
Site B Server vlan 1 172.17.2.x/24
Site B Circuit Vlan 2 10.15.3.0/24

SITEA
S       172.17.30.0 is directly connected, Vlan1
S       172.17.8.0 is directly connected, Vlan12
     10.0.0.0/24 is subnetted, 10 subnets
C       10.15.5.0 is directly connected, Vlan3
C       10.15.4.0 is directly connected, Vlan5
C       10.15.1.0 is directly connected, Vlan2
C       10.15.0.0 is directly connected, Vlan1
C       10.15.3.0 is directly connected, Vlan4
C       10.15.10.0 is directly connected, Vlan12
C       10.15.151.0 is directly connected, Vlan7
C       10.15.153.0 is directly connected, Vlan9
C       10.15.152.0 is directly connected, Vlan8
C       10.15.154.0 is directly connected, Vlan10
S*   0.0.0.0/0 [1/0] via 10.15.0.100

SITEB
     172.17.0.0/24 is subnetted, 7 subnets
S       172.17.40.0 is directly connected, Vlan7
C       172.17.30.0 is directly connected, Vlan7
S       172.17.9.0 [1/0] via 172.17.2.77
C       172.17.8.0 is directly connected, Vlan8
C       172.17.5.0 is directly connected, Vlan5
C       172.17.1.0 is directly connected, Vlan1
C       172.17.2.0 is directly connected, Vlan2
     10.0.0.0/24 is subnetted, 1 subnets
S       10.15.10.0 is directly connected, Vlan8
S*   0.0.0.0/0 [1/0] via 172.17.1.1

Any ideas ?
0
Comment
Question by:skywalker101
  • 7
  • 7
14 Comments
 
LVL 50

Expert Comment

by:Don Johnston
ID: 24183395
Use a next hop address in your static route.

ip route 172.17.2.0 255.255.255.0 <next hop address>

Also, each end of the LES circuit appears to be on a different network. Did the provider require those addresses?
0
 

Author Comment

by:skywalker101
ID: 24183828
Don,

No the LES Provider did not require those address as both sites are on different VLANs, how do I implement the LES circuit to be on the same the same subnet ?

In the IP route statement <next hop address> being the remote switch IP address?
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 24183878
Okay, I think I see your problem. Your LES circuit is a private link. Just like an E1 line. Both ends have to be on the same network. So if the SiteA end is 10.15.2.1, then the SiteB end has to be on the 10.15.2.0 network also.



0
Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

 

Author Comment

by:skywalker101
ID: 24184010
Okay, How do I configure this on the Switch do I need to create a VLAN for the LES circuit on both Sites ?

As I have multiple VLANS in each switch which will be differnet networks, the Switch betwwen both switches are not in the same VTP domain so the VLANs in SIte A no nothing about the VLANS in site B.

I had configured a VLAN in site A and place the LES Circuit in that VLAN Site A Les Circuit Vlan 2 10.15.2.0/24

Site B 172.17.8.0 is directly connected, Vlan8

How do I configure the LES to be on the Network and will I be able to route the other Vlans to send traffic over the LES Circuit ?
0
 
LVL 50

Accepted Solution

by:
Don Johnston earned 2000 total points
ID: 24184080
I would make the interfaces connecting to the LES circuit layer 3 interfaces. And given the number of networks, use a routing protocol.



Site A:
 
int f0/1 !(or whatever interface the LES is connected to)
 no switchport
 ip address 10.15.2.1 255.255.255.0
 no shutdown
!
router eigrp 100
 network 10.0.0.0
 no auto-summary
 
Site B:
 
int f0/1 !(or whatever interface the LES is connected to)
 no switchport
 ip address 10.15.2.2 255.255.255.0
 no shutdown
!
router eigrp 100
 network 10.0.0.0
 network 172.17.0.0
 no auto-summary

Open in new window

0
 

Author Comment

by:skywalker101
ID: 24184295
As the VLANS will be seen as directly connected networks in the Routing table will they not alway prefer the directly connected network over a Routing Protocol based on the AD ?

As for the routing on the switches I want to be able send traffic from site A Subnet 10.15.5.x/24  and from site B 172.17.5.x/24 all the other traffic should go via the routers out the default route between the 2 sites.
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 24184391
>As the VLANS will be seen as directly connected networks in the Routing table will they not alway prefer the directly connected network over a Routing Protocol based on the AD?

Yes. Directly connected routes are preferred over routes learned through routing protocols.

>As for the routing on the switches I want to be able send traffic from site A Subnet 10.15.5.x/24  and from site B 172.17.5.x/24 all the other traffic should go via the routers out the default route between the 2 sites.    

Create a default route on each switch with the next hop address of the local router.

0
 

Author Comment

by:skywalker101
ID: 24184909
OK The router is managed by my ISP and there is a default on the switch pointing to routes hsrp address.

I want to able send the traffic via the LES Circuit and not via the router.  All traffic is currently going out via the Router and I want move subnet one at a time via the LES Circuit.

i.e 10.15.5.x site A via the LES Circuit, Return traffic from Site B 172.17.5.x

All other traffic/subnets will go out via the default route - Router
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 24184998
The order of selection by layer 3 devices is:

Most specific route
Lowest AD
Lowest Metric

In your case, since there will be a 10.15.5.0/24 route in the table pointing to Site B, that path will take precedence over the default route.

So just use the config I provided and that will accomplish what you want.
0
 

Author Comment

by:skywalker101
ID: 24185503
OK, I have configured LES Circuit on the interfaces as below:

I can ping the interface on both sides of the link but not from the server vlan 10.15.5.x

int f0/1  no switchport
 ip address 10.15.2.1 255.255.255.248
 no shutdown

Site B:
 
int f0/1  no switchport
 ip address 10.15.2.2 255.255.255.248
 no shutdown


0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 24185587
What is the default gateway of the devices on the 10.15.5.0 network? It should be the IP address of the VLAN interface on the switch.
0
 

Author Comment

by:skywalker101
ID: 24191669
yes that is correct the default gateway for the 10.15.5.0 network is 10.15.5.1 which is the vlan interface on the switch
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 24192573
Are there routes for each site in the routing table of both switches?
Please post the output of a "show ip route".

0
 

Author Comment

by:skywalker101
ID: 24192860
Don,

I got it working I needed route on the switch site B for the return traffic.
0

Featured Post

What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In this article, the configuration steps in Zabbix to monitor devices via SNMP will be discussed with some real examples on Cisco Router/Switch, Catalyst Switch, NAS Synology device.
In this article I will be showing you how to subnet the easiest way possible for IPv4 (Internet Protocol version 4). This article does not cover IPv6. Keep in mind that subnetting requires lots of practice and time.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're looking for how to monitor bandwidth using netflow or packet s…

825 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question