Address book not synchroizing in OCS 2007...

Posted on 2009-04-20
Last Modified: 2013-11-29
Whenever we create new user on OCS, his ID not getting reflected/searched with other users. if i want to add his contact then i need to write whole ID like
We are facing this issue from last 1 months before that everything was working fine also i would like to mention that we had install an virtual server on OCS, i dont know whether it is belongs to this issue or not.
Question by:pdixit1977
    LVL 10

    Expert Comment

    Did you run ABSERVER.exe -SYNCNOW

    When you do, take note of any errors noted.. you could have a normalization issue, or did not modify (rename) their SAMPLE normalization file
    LVL 4

    Expert Comment

    start here for the Address Book error&

    You can also try to look at the output on the client after you make an update.
    Create the following registry key to export the galcontacts.db file to CSV
    Dword: DumpContactsToCsvFile
    Value= 1
    The file is accessed directly from MOC, simply select Tools -> View Received Files.

    Author Comment

    we have already tried that but no luck.
    LVL 4

    Expert Comment

    ABServer dumpRules

    Also check the Event Log and tell me if you see any errors related to the Address Book Server. Specifically, something like this:

    Event Type: Warning
    Event Source: OCS Address Book Server
    Event Category: (1008)
    Event ID: 21034
    Date: 04.07.2007
    Time: 11:51:28
    User: N/A
    Computer: SERVER-OCS
    One or more phone numbers failed to normalize

    This would put you on the path jayca was directing you to..

    Author Comment

    we have been tried all possible solution but no luck, here i would like to mention 1 thing.
    we have OCS server on 2.5 GB of RAM, would it be causing issues.

    Author Comment

    we have resolved it by own. how ? will share you soon

    Expert Comment

    What was your resolution?  I have a similar issue and would like to get it resolved.

    Accepted Solution

    we have pushed GALcontacts.db file to "Local Settings\Application Data\Microsoft\Communicator" path of every user and issue resolved.
    I know that is not right resolution but i believe we have had this issue because our OCS server is running on 3 GB of RAM whether minimum requirement is 4 GB as per microsoft.

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    IT, Stop Being Called Into Every Meeting

    Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

    Problem Description: Actually I found the below issue with some customers after migration from SMS 2003 to SCCM 2007 and epically if they change site code, some clients may appear in the console with old site code, plus old sites still appearing …
    My previous article  ( one possible method to get SCCM 2007 installed an…
    This video is in connection to the article "The case of a missing mobile phone (". It will help one to understand clearly the steps to track a lost android phone.
    Polish reports in Access so they look terrific. Take yourself to another level. Equations, Back Color, Alternate Back Color. Write easy VBA Code. Tighten space to use less pages. Launch report from a menu, considering criteria only when it is filled…

    760 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    12 Experts available now in Live!

    Get 1:1 Help Now