• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1545
  • Last Modified:

How to enable telnet on Cisco 827 ADSL router?

Hi,
I am not able to connect to telnet from private network (192.168.0.1 address) to Router (192.168.0.10). Is there something wrong in configuration below?

Internet works OK.


Current configuration : 2648 bytes
!
! Last configuration change at 14:31:13 MSK Mon Apr 20 2009
! NVRAM config last updated at 14:31:17 MSK Mon Apr 20 2009
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
!
logging queue-limit 100
enable secret 5 $1$H7ut$xE0anzF6UZ5WGJER8Uj2y/
enable password 7 1158485446435A
!
username CRWS_Prem privilege 15 password 7 015757406C5A002E65431F062A2007135A5F507C7B747C616177
username CRWS_Gayatri privilege 15 password 0 $1$W1fA$o1oSEpa1111144392
username CRWS_Vijay privilege 15 password 0 $1$W1fA$o1oSEpa2126142855
username CRWS_Santhosh privilege 15 password 0 $1$W1fA$o1oSEpa1283099191
username CRWS_Sangeetha privilege 15 password 0 $1$W1fA$o1oSEpa1468679699
username CRWS_Kannan privilege 15 password 0 $1$W1fA$o1oSEpa36809727
username CRWS_Jaidil privilege 15 password 0 $1$W1fA$o1oSEpa925948672
username CRWS_Ritesh privilege 15 password 0 $1$W1fA$o1oSEpa951553489
clock timezone MSK 3
ip subnet-zero
ip name-server 194.8.160.90
ip name-server 195.131.185.207
ip dhcp excluded-address 10.10.10.1
!
ip dhcp pool CLIENT
   import all
   network 10.10.10.0 255.255.255.0
   default-router 10.10.10.1
   lease 0 2
!
!
ip audit notify log
ip audit po max-events 100
vpdn enable
!
vpdn-group pppoe
 request-dialin
 protocol pppoe
!
no ftp-server write-enable
!
!
!
!
partition flash 2 10 2
!
!
!
!
interface Ethernet0
 ip address 192.168.0.10 255.255.255.0
 ip nat inside
 no ip mroute-cache
 no cdp enable
 hold-queue 100 out
!
interface ATM0
 no ip address
 no ip mroute-cache
 no atm ilmi-keepalive
 dsl operating-mode auto
 hold-queue 224 in
!
interface ATM0.1 point-to-point
 pvc 1/32
  encapsulation aal5snap
  pppoe-client dial-pool-number 1
 !
!
interface Dialer1
 mtu 1492
 ip address negotiated
 ip nat outside
 encapsulation ppp
 ip tcp adjust-mss 1452
 dialer pool 1
 dialer-group 1
 no cdp enable
 ppp chap hostname hostname
 ppp chap password 0 password
 ppp pap sent-username username password 7 10633E2D2843412728
!
ip nat inside source list 1 interface Dialer1 overload
ip nat inside source list 101 interface Dialer1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
ip http server
ip http secure-server
!
access-list 1 permit 192.168.0.0 0.0.0.255
access-list 23 permit 10.10.10.0 0.0.0.255
access-list 101 permit ip any any
dialer-list 1 protocol ip list 101
no cdp run
!
line con 0
 exec-timeout 120 0
 no modem enable
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 access-class 23 in
 exec-timeout 120 0
 privilege level 15
 password 111111
 login
 length 0
!
scheduler max-task-time 5000
sntp server 192.43.244.18
!
end
0
9310444
Asked:
9310444
3 Solutions
 
JFrederick29Commented:
Add this:

conf t
access-list 23 permit 192.168.0.0 0.0.0.255
0
 
suggestionstickCommented:
Hi

access is controlled by the  line "  access-class 23 in" towards the end of the config

line vty 0 4
 access-class 23 in
 exec-timeout 120 0
 privilege level 15
 password 111111
 login
 length 0

you need to add your local network  to access list 23 to allow access

 access-list 23 permit 192.168.0.0 0.0.0.255


Trevor
0
 
ged125Commented:
A better solution would be to use SSH, as telnet does not encrypt your password.  If you want to go this route you will need an IOS image that supports encryption (indicated by "K9" in the file name).  To enable, do the following:

Crypto Key Generate RSA
Line Vty 0 4
  transport input SSH

The same access-list 23 can be used for this purpose, but you can allow it to a broader range of IP's, since the traffic is encrypted.
0

Featured Post

Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now