• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2549
  • Last Modified:

Network settings for VirtualBox

I'm trying to install virtualbox virtual machines on my laptop. I have a working installation of Windows. The only problem is that I can't get the network configured. I'm used to VMware, which configures a local network automatically. Now I get an ip address like 10.0.0.1 (my local network is on 192.168.1.*), and I can't ping to and from the vm. The same happens when using a Linux vm. Running the vm on a mac or pc doesn't make a difference.
0
R7AF
Asked:
R7AF
1 Solution
 
fosiul01Commented:
have you install vmware tool ??

when you will create a virtual OS, it will asked you to select network bridge mood, have you done that ??
0
 
R7AFAuthor Commented:
I want to use Sun VirtualBox, not VMware. In the settings of the vm, I can set bridge mode, but still it won't work.
0
 
JulienVanCommented:
Hi, I've got the same problem. There is no problem to share my internet connection with a Windows XP image in VMWare, but it doesn't work with VirtualBox. I obtain a warning message telling me about limited connectivity (probably due to an IP address conflict).
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
R7AFAuthor Commented:
I think we may have to configure NAT somehow, but really? And where (host OS or router), and how?
0
 
ranit8Commented:
I've posted a brief comment on JulienVan's question.
http://www.experts-exchange.com/Networking/Misc/Q__24344140.html

If your physical network uses static addresses, bridge the Virtual adapter and the real interface and set the guest interface to bridged or internal host.

If the router runs DHCP, and the guest can't get the DHCP address, OR if the guest needs no access to/from the local network, then change the guest interface to NAT.

Ping didnt work at all with older versions of Virtualbox.
0
 
R7AFAuthor Commented:
I finally solved this issue. Using bridged networking I finally have network configured correctly, both on Windows and OSX.
virtualbox-network.png
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now