• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1446
  • Last Modified:

Ran diskpart, disk has extended but the volume is the same size

Hi,

I have a virtual machine running Windows Server 2003 R2 Std 32bit which has one 15GB hard disk.

I extended the disk size by 15GB and restarted the virtual machine.

I checked disk management in Windows and there was a 15GB C: volume and 15GB unused space.

I ran diskpart.exe as follows:

diskpart
list volume
select volume 0
extend

The command prompt Window hung on extend, I left it for over a day and it did not change.

I checked disk management and DISK 0 is showing the size as being 30GB but the C: volume is still only 15GB.

I have found various articles on the internet advising to run "extend filesystem" as advised here: http://www.tomshardware.co.uk/forum/page-194981_36_0.html but this does not work (see code).

I have tried to run gparted live (advised here: http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/2000_Server/Q_22409507.html) but that does not work either as it see's the partition as 30GB so there is nothing to extend.

This MS article describes the problem I am having but is only for 2K and XP : http://support.microsoft.com/default.aspx?scid=kb;en-us;329826

Any ideas how I can resolve this?





DISKPART> list volume
 
  Volume ###  Ltr  Label        Fs     Type        Size     Status     Info
  ----------  ---  -----------  -----  ----------  -------  ---------  --------
* Volume 0     C   SYSTEM       NTFS   Simple        30 GB  Healthy    System
  Volume 1     Z                       CD-ROM          0 B  Healthy
 
DISKPART> select volume 0
 
Volume 0 is the selected volume.
 
DISKPART> extend filesystem
 
The volume you have selected may not be extended.
Please select another volume and try again.
 
DISKPART>

Open in new window

0
hertel-dev
Asked:
hertel-dev
  • 2
1 Solution
 
oBdACommented:
You can't expand the system partition with diskpart.
You can try (make a backup of the virtual disk first!) to attach the disk temporarily to another virtual machine, expand the disk on this machine, then link it back to the original machine.
0
 
hertel-devAuthor Commented:
The problem is that diskpart has already extended the disk??

In disk management it shows "Disk 0  - (C:) 30.00GB NTFS" on the bar/diagram at the bottom but at the top it has volume C:, NTFS 15GB.  In My Computer the C: drive also appears as 15GB.

I have cloned the VM to figure out how to resolve the problem.  I have thought about using Acronis to take an image of the server and then re-apply it to a new VM with a larger disk but surely there must be an easier way?

Thanks
0
 
oBdACommented:
Disk management will show you the full size as soon as the volume is expanded; but that doesn't change the size available to Windows.
Again: diskpart will NOT extend the system partition, which is what you've been trying to do. You can only extend this partition if you mount it into another machine as additional disk.
0

Featured Post

Get your Conversational Ransomware Defense e‑book

This e-book gives you an insight into the ransomware threat and reviews the fundamentals of top-notch ransomware preparedness and recovery. To help you protect yourself and your organization. The initial infection may be inevitable, so the best protection is to be fully prepared.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now