[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1362
  • Last Modified:

Globalization

I develop a web application in VS 2008, the Login component among others is showing the text in my local language since I have set the uiculture in the web.config file(see code).

This is working fine on my devolpmen machine.
When I deploy the solution to a remote Win server 2008 with swedish language installed(so they say), it shows english in the login control.

What need to be done to fix this, is the problem on the server or can I fix it in code/settings?
<globalization
      requestEncoding="utf-8" responseEncoding="utf-8"
      uiCulture="sv" culture="sv-SE" />

Open in new window

0
SNilsson
Asked:
SNilsson
  • 4
  • 4
1 Solution
 
David RobitailleAnalyst ProgrammerCommented:
try to add
enableClientBasedCulture="false"
 
It will force it to use swedish

<globalization
      requestEncoding="utf-8" responseEncoding="utf-8"
      uiCulture="sv" culture="sv-SE" enableClientBasedCulture="false"/>

Open in new window

0
 
SNilssonAuthor Commented:
No joy, its acting the same.
I tried that on my dev machine also, but using uiCulture="es" culture="es-MX" it will not show spanish on my local computer either.
Does it have to do with if I have language packs installed on the operative system?
0
 
David RobitailleAnalyst ProgrammerCommented:
I`m not sure about this, but you may need to do a "iis reset" for that setting to be "active"
also, check in Internet Options->General->Languages (for IE) if the target language is avilable. try to switch it first to ckeck.
finally, check at the top fo the individual page if there @ Page directive about culture ( <%@ Page UICulture="es" Culture="es-MX" %>) i think it override the web.config settings.
 
here some link
http://msdn.microsoft.com/en-us/library/bz9tc508.aspx 
http://www.codeproject.com/Kb/aspnet/localizationByVivekTakur.aspx
0
Efficient way to get backups off site to Azure

This user guide provides instructions on how to deploy and configure both a StoneFly Scale Out NAS Enterprise Cloud Drive virtual machine and Veeam Cloud Connect in the Microsoft Azure Cloud.

 
SNilssonAuthor Commented:
Thanks davrob
I`m not sure about this, but you may need to do a "iis reset" for that setting to be "active"
I will try this on my local IIS with the 'es' language before suggesting it to my web hosting.
check in Internet Options->General->Languages (for IE) if the target language is avilable. try to switch it first to ckeck.
It should ignore IE settings, language will be handled as I set it(with your suggestion of "enableClientBasedCulture="false" it will ignore it)
check at the top fo the individual page if there @ Page directive about culture ( <%@ Page UICulture="es" Culture="es-MX" %>) i think it override the web.config settings.
Yes I have tried this variant before and it act the same as the global setting in web.config(yes it do override)
I belive I have visited those links before, but I will check them for tips.
What about installed languages on the operative I have not found anything that say it is needed.
Maybe you can do a quick test on your machine and se if you can get uiCulture="sv" to work with a login control (unless you have Swedish language on your system that is).
0
 
David RobitailleAnalyst ProgrammerCommented:
I made test, and i cannot get it in swedish as you.
I installed that language pack, it<s what you are talking about?
http://www.microsoft.com/downloads/thankyou.aspx?familyId=bf56c11a-1713-43e0-bdf4-4b5737474ae4&displayLang=en
Anyway, i now think it have to be from the way the server is set. does it run in English?
Also, on the devolpment machine, do you use IIS or the web server bundled with visual studio?
Another solution will be to fill the Text values of the "text" values of the controls (Failure text, etc.) or use a resource file. I think the Default values are set from the computer that "compile" just in time the .net code.
FYI, personally, I use the setting  uiCulture="en-CA" culture="en-CA" enableClientBasedCulture="false" because we have many client (as me) that have the Fr-Ca as their primary culture installed on their computer and it solve my problems for "." Vs "," as the decimal point. and in my cas, it work.
0
 
SNilssonAuthor Commented:
Another solution will be to fill the Text values of the "text" values of the controls (Failure text, etc.) or use a resource file. I think the Default values are set from the computer that "compile" just in time the .net code.
I was afraid of that, its the most secure thing if you want to have it static, lots of translations though when you know the text is translated somewhere.
Even if my web provider manage to enable Swedish on the server and I then change provider, I might have the same problem again.
I use mostly use the VS web server, I will enable my local IIS to see what happens.
Thanks a lot for your help, guess I have lots of places to find and change to Swedish in the controls now >)
 
0
 
SNilssonAuthor Commented:
Thanks, hopefully everyone talks english in the near future and we don have to mess with all the culture variants :)
0
 
David RobitailleAnalyst ProgrammerCommented:
than, if you have multiple controls of the same type, you could use a global culture-neutral  resource (resx) file (in swedish) and then use meta:resourcekey tag to link them. You could have only one "key" for each control class.
http://quickstarts.asp.net/QuickStartv20/aspnet/doc/localization/localization.aspx
I m glad i could help
0

Featured Post

Vote for the Most Valuable Expert

It’s time to recognize experts that go above and beyond with helpful solutions and engagement on site. Choose from the top experts in the Hall of Fame or on the right rail of your favorite topic page. Look for the blue “Nominate” button on their profile to vote.

  • 4
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now