• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 618
  • Last Modified:

Changing permissions on apache files/folders using WHM (Web Host Manager)

I have to change permissions on some folders in an apache installation.  And I found this link that gave part of the solution, but I am not sure exactly how do do it using WHM Manger Accelerated.

FYI this WHM for an entire hosting box, so I assume that means I have access down to the root.  I assume I don't need to have access to the root to do this, but I am providing this for your info in case you need to know it in answering my question.

The installation that I need to change the permissions are for a joomla site that I just installed.  I assume you don't need to know that either, but info anyway.  BTW the Joomla files were installed via Fantastico but they installled the files without properly setting the permissions.

ANYWAY here is the link to the sequence of commands I have to do, but I don't know where in either the WebHostManager or in the CPANEL to execute those commands:

http://www.netadmintools.com/art560.html

Thanks

Rowby
0
Rowby Goren
Asked:
Rowby Goren
  • 3
  • 2
1 Solution
 
Julian MatzCommented:
That's strange - Fantastico should have set the permissions.

Anyway, there are a few ways of doing this...

1. You could use the EasyApache script to install suPHP, which allows users to run Apache as themselves, and therefore you wouldn't need to change permissions ever again :) Basically, it allows files and directories to be writable without needing to set insecure permissions.

2. In WHM, go to Account Information, search for the account you need to modify, click on the cPanel icon. This opens cPanel for the account you're modifying. Then go to Files and open File Manager. From File Manager then you can set the proper permissions.

3. Via SSH / command line - use Putty to log into your server and cd to the user's directory and use chmod to set permissions.

4. Using Fantastico, remove the Joomla installation and then re-install it. I've noticed that sometimes Fantastico doesn't install the database properly first time around. It could be something similar with your permissions.

Hope this helps. Let me know if you have any questions.
0
 
Rowby GorenAuthor Commented:
Hi Juliamatz,

Thanks for those suggestions.  I've tried redoing the fantastico but it still doesn't do the permissions.

I will try #1 and then the others.

I will be doing this tomorrow so stay tuned!

Rowby
0
 
Julian MatzCommented:
No problem. Let me know how you get on. Oh, I nearly forgot - if you have suPHP enabled, I think you also need to go into your Fantastico settings and make sure that it knows you're using suPHP. In fact, maybe it thinks you are already using it and maybe that's why it's not changing or setting the permissions. Just a shot in the dark ...
0
 
Rowby GorenAuthor Commented:
Thank.  I used ftp to make the permission changes.  And will keep your suggestions in my Knowedge Base.
0
 
Julian MatzCommented:
Glad I was able to help. Thanks for the grade.
0

Featured Post

Granular recovery for Microsoft Exchange

With Veeam Explorer for Microsoft Exchange you can choose the Exchange Servers and restore points you’re interested in, and Veeam Explorer will present the contents of those mailbox stores for browsing, searching and exporting.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now