IIS 6 asking for username/password from LAN users

I am making a Intranet site and i need it to allow access to all the users that already authenticated on their local PC. so i clicked on Directory Security > Edit > and turned off anonymous off and checked integrate windows authentication.
however when i browse to the site now it is asking for my user/pass. its as if my credentials are not passed to the IIS.
any idea?

Thank you,
Raul77Asked:
Who is Participating?
 
lamaslanyCommented:
0
 
lamaslanyCommented:
You need to add the site to the Local Intranet zone
0
 
Raul77Author Commented:
i forgot to mention it works with no problem using Internet Explorer 7. but in FireFox it doesnt seem to work
0
Cloud Class® Course: Ruby Fundamentals

This course will introduce you to Ruby, as well as teach you about classes, methods, variables, data structures, loops, enumerable methods, and finishing touches.

 
Raul77Author Commented:
after some further testing, IE seem to only work for me ! other users when using FF they get user/pass dialog and when using IE they get

error in application \
Access Denied
0
 
Saqib KhanSenior DeveloperCommented:
integrate windows authentication is part of Windows only, and this is the reason it only works with IE. if you want to use it with Firefox & IE then you need to use Basic Authentication Method, but in that case every user needs to enter their login info Manually.
0
 
Raul77Author Commented:
thanks, solved it
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.