Quickbooks Error -6190, -816 trying to open QBW file simultaneously from two computers via Server


Running QuickBooks 2009 Premiere Contractor edition.
QuickBooks file hosted on a Windows 2003 Server
2 Client machines running XP Home.
Like many others, I am getting "unable to open the company file" message with error (-6190 -816) when another computer already has the file open.

My Company QBW file is hosted by a server with only the QuickBooks Database Server Manager running on the server.
I have two machines using the company file - both have Hosting set to OFF.
Both client machines can open the Company file independently, so I don't think there are any firewall/network issues.
But they both get the same error when the other machine already has the file open.
I have followed instructions in other threads; deleting the Transaction log file on the Server, deleting the ND file on the server, restarting the QuickBooksDB19 and QBFCMonitorService on the Server, and rebooting the Server.

Thanks for reading!
samsteridAsked:
Who is Participating?
 
samsteridConnect With a Mentor Author Commented:
I finally got access to my Company QBW file on the server from 2 desktops simultaneously.  The "solution" was to give up on only having the Database Server Manager installed on the server.

It only started working after I installed the full version of Quickbooks 2009 on the server and chose Multi-User mode.  Then the ND file changed and finally listed the IP address of the server and changed the ServerMode = 1 to ServerMode=2.

When only the Database Server Manager was installed the ND file had very minimal info listed and always had ServerMode=1.  IF ServerMode=1 means Single-User Mode, I don't understand why or how that could get set with only the Database Server Manager installed.

Here's the best troubleshooting thread I found in my search:
https://community.intuit.com/post/detail/aZwmiueBir3zw9abTJhmjm?page=2

I also followed the advice for Firewall settings here:
http://support.quickbooks.intuit.com/support/pages/knowledgebasearticle/403317


Even after I had it all working the first time, the Server file somehow got switched back to Single-User mode and I had to choose Muti-User from the main Quickbooks program on the server - again.

0
 
gsgiCommented:
After many many hours on the phone with Intuit.... drum roll please ... took mcafee off the server and wala.

-gsgi
0
 
gsgiCommented:
I also had to install the full version of Quicken on the server, but it still didn't work until mcafee was removed.
0
All Courses

From novice to tech pro — start learning today.