Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 368
  • Last Modified:

SQL 2005 - SQL Server Services fail to install on Windows 2003 Cluster

Hi,

Environment - Windows 2003 Enterprise Edition x32 SP2 with SQL 2005

Problem - SQL Server Services fail to install

Background - This is a new installation, the cluster groups are setup (cluster group has MSDTSC, Quorum, IP and Name, APP1 & APP2 groups have disk resources only).  The install pre-checks are all green, all components install cleanly (from what I can see) but the SQL server part is failing.  Im using a domain administrator account for the install, I am logged on with mstsc /console (connected to 1 server only), my distribution media is on the local C:\kits\SQL2005\Servers & Tools directories.  I'm selecting a named instance.

The logs show:

Summary.txt
All good....till the SQL Server part.
--------------------------------------------------------------------------------
Machine         : NODENAME01
Product         : Microsoft SQL Server 2005
Product Version : 9.00.1399.06
Install         : Failed
Error Number    : 67
--------------------------------------------------------------------------------
Machine         : NODENAME02
Product         : Microsoft SQL Server 2005
Product Version : 9.00.1399.06
Install         : Failed
Error Number    : 67

SQLSetup0012_NODENAME02_Core:
Error: Action "LaunchLocalBootstrapAction" threw an exception during execution.  Error information reported during run:
"C:\Program Files\Microsoft SQL Server\90\Setup Bootstrap\setup.exe" finished and returned: 67
Aborting queue processing as nested installer has completed
Message pump returning: 67

SQLSetup0012_NODENAME02_Core(Local):
Running: CreatePipeAction at: 2009/3/21 13:58:45
Complete: CreatePipeAction at: 2009/3/21 13:58:45, returned false
Error: Action "CreatePipeAction" failed during execution.
Action "RunRemoteSetupAction" will be skipped due to the following restrictions:
Condition "Action: CreatePipeAction has finished and passed." returned false.

What's going on?  Any guidance really appreciated.

Regards Rich
SQL-Install-Prob.zip
0
TrickyRGH
Asked:
TrickyRGH
  • 3
  • 3
1 Solution
 
TrickyRGHAuthor Commented:
Thanks RiteshShah.
I had read this one and I am using a support account that is a domain admin account that has log on access to both cluster members.  

Rich
0
 
RiteshShahCommented:
As long as my experience concern, This kind of problem faced because of user rights issue, if you are sure that you have full access on each cluster and using the same account to install service, than I will take some more time to investigate your issue.
0
Veeam and MySQL: How to Perform Backup & Recovery

MySQL and the MariaDB variant are among the most used databases in Linux environments, and many critical applications support their data on them. Watch this recorded webinar to find out how Veeam Backup & Replication allows you to get consistent backups of MySQL databases.

 
TrickyRGHAuthor Commented:
I just tried an additional domain admin account and it too exhibited the same problem.  Is their something I can do to validate the account has appropriate permissions?
0
 
RiteshShahCommented:
this link had details about how you can set permission,

http://www.microsoft.com/technet/prodtechnol/virtualserver/deploy/cvs2005.mspx
0
 
TrickyRGHAuthor Commented:
Solution - my "Public Team " interface on one node had a trailing space.  I removed this trailing space and I also moved the install directory to the root level.  Now working through the remaining installation successfully - thanks for your assistance.
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

  • 3
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now