?
Solved

How to disabled windows update notification?

Posted on 2009-04-21
13
Medium Priority
?
4,820 Views
Last Modified: 2012-05-06
Hi,

We have 2 servers, a Windows Server 2003 SBS running as our DC and a Windows Server 2008 running as a TS that end users connect to.

The problem is the end users are prompted to restart the server, but the restart now button is grayed out. How do we disable this pop-up entirely? So the users don't have to postpone a message that they are unable action.

The end users are not local administrators. We've search Google for a solution but can find nothing out there.

We've tried enforcing a GPO with the Allow non-administrators to receive update notifications disabled but this hasn't prevent the message from appearing.
0
Comment
Question by:WizPrang
  • 5
  • 4
  • 3
  • +1
13 Comments
 
LVL 10

Expert Comment

by:Kieran_Burns
ID: 24192211
Are you applying the policy to the SERVER or the Workstations? As it is a Terminal Server, then the policy should point to the Server.
The setting you want to use is:
  • Computer Configuration
  • Administrative Templates
  • Windows Components/Windows Updates
  • Re-prompt for restart with scheduled installations - DISABLED
0
 
LVL 3

Expert Comment

by:spandexandy
ID: 24192231
Check this link with one GPO solution (http://www.online-tech-tips.com/computer-tips/disable-restart-now/). I know that this example is for Windows XP, but the GPO in Windows 2008 might be similar/the same.

Cheers.
0
 
LVL 2

Author Comment

by:WizPrang
ID: 24192254
Applying the GPO to the TS servers OU.

Applied the above,

Read the description for this policy setting and it indicates that it may then automatically re-prompt after 10 minutes.

"If the status is set to Disabled or Not Configured, the default interval is 10 minutes."

Would this prevent the message from displaying?
Or it will prompt once then disappear for good?
0
Granular recovery for Microsoft Exchange

With Veeam Explorer for Microsoft Exchange you can choose the Exchange Servers and restore points you’re interested in, and Veeam Explorer will present the contents of those mailbox stores for browsing, searching and exporting.

 
LVL 10

Expert Comment

by:Kieran_Burns
ID: 24192293
You should get ONE prompt only
You should also set this: No auto-restart with logged on users for scheduled automatic updates installations and Enable it. (also in the  TS Servers OU) or else you may get one user upsetting everyone else :-)
We actually go the other way and have a reprompt after 24 hours. This way it doesn't get forgotten, but then we have all the TS Servers reboot every night
0
 
LVL 2

Author Comment

by:WizPrang
ID: 24192367
Thanks Kieran,

Although this partially resolves the problem, we need to prevent the message popping up entirely as we continually get phone calls from the end users asking what they need to do. Training the users isn't really an option as we have new remote workers on a weekly basis. So ideally we need to prevent this message from popping up all together. The agreement is that the server is restarted on a Friday which means we generally have 2 days between update and restart where we have an increase in telephone calls of end users kindly reminding us the TS server needs to be restarted.

Could it be this is a limitation between Windows 2003 and 2008 integration? i.e. the Group Policy doesn't exist that affects this aspect of Windows 2008?
0
 
LVL 10

Expert Comment

by:Kieran_Burns
ID: 24192420
Would it not be simpler to change the install settings then?
Under Configure Automatic Updates
Chosing Option 4 (auto download and schedule the install)
set the install day to Friday and the time to 18:00, then have your Server reboot at least an hour after this
0
 
LVL 2

Author Comment

by:WizPrang
ID: 24192435
Its possible the server will need to be kept online due to workers working late, needs to be a manual process to ensure the server isn't restarted with users logged on.
0
 
LVL 10

Assisted Solution

by:Kieran_Burns
Kieran_Burns earned 300 total points
ID: 24192450
that's academic to the install time though. I presume you are just automatically updating as soon as the patches become available. Hence MS Tuesday rolling out to WSUS by Wednesday and hitting the Servers / Workstations the same day. 2 days delay to the Server reboot and prompts during that time.
Change the install day and time to Friday evening (at the end of the normal working day) and reboot as normal when everyone is out
0
 
LVL 2

Author Comment

by:WizPrang
ID: 24192516
We do not use WSUS on this system.

Although this is potentially resolving the issue, it isn't answering the question.

We need to disable this pop-up not work around it.
0
 
LVL 19

Expert Comment

by:PeteJThomas
ID: 24192894
If you use a loopback policy for your Terminal Server OU, you could apply a script that removes all update balloons completey. I've never tried this with TS, but there is definitely a registry hack that stops those balloons appearing, but bare in mind, this stops ALL notification balloons, not just those specific to Automatic Updates.

I'm not exactly sure how this would work within TS though, and would require some testing for sure!!

Let me see if I can find anything about doing it in a TS environment specifically first. I'll get back to you.

Pete
0
 
LVL 19

Accepted Solution

by:
PeteJThomas earned 450 total points
ID: 24193420
I'm afraid I can find nothing on doing this for Terminal Service sessions. The registry hack for XP itself is added in HKCU, as explained here - http://www.howtogeek.com/howto/windows/disable-notification-balloons-in-xp/

But I wouldn't even want to speculate on how to try and apply this to a TS, or even if it's possible.

However that is the only way I know of to turn off those notifications. There are no managed admin templates or anything like that that will do it for you that I can find...

Pete
0
 
LVL 2

Author Closing Comment

by:WizPrang
ID: 31572628
Thanks for your efforts.
0
 
LVL 19

Expert Comment

by:PeteJThomas
ID: 24202585
You're welcome, I'm sorry I couldn't provide a better answer. :(

Pete
0

Featured Post

Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Background Information Recently I have fixed file server permission issues for one of my client. The client has 1800 users and one Windows Server 2008 R2 domain joined file server with 12 TB of data, 250+ shared folders and the folder structure i…
Resolving an irritating Remote Desktop connection that stops your saved credentials from being used.
This tutorial will walk an individual through locating and launching the BEUtility application and how to execute it on the appropriate database. Log onto the server running the Backup Exec database. In a larger environment, this would generally be …
This tutorial will walk an individual through the steps necessary to install and configure the Windows Server Backup Utility. Directly connect an external storage device such as a USB drive, or CD\DVD burner: If the device is a USB drive, ensure i…
Suggested Courses

864 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question