[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

how to configure cisco 1841 with leased line

Posted on 2009-04-21
13
Medium Priority
?
1,247 Views
Last Modified: 2012-05-06
I have got the follwing information from ISP about leased line

ip:  83.111.32.154
default gateway:   83.111.32.153
subnet mask:  255.255.255.252

now i want to configure with leased line how i can
our internal LAN ip range is 172.172.101.1 to 254

can any one help me to configure leased line and vpn from this information on cisco router 1841
0
Comment
Question by:akhlaq2006
  • 7
  • 6
13 Comments
 
LVL 43

Expert Comment

by:JFrederick29
ID: 24200763
Here is a basic config to get Internet up and going:

int fa0/1
ip add 172.172.101.1 255.255.255.0
ip nat inside
no shut

int s0/0/0
ip add 83.111.32.154 255.255.255.252
ip nat outside
encap ppp
no shut

access-list 1 permit 172.172.101.0 0.0.0.255

ip nat inside source list 1 interface s0/0/0 overload

ip route 0.0.0.0 0.0.0.0 83.111.32.153

The VPN setup probably warrants another question once you have the T1 up and Internet access working.
0
 

Author Comment

by:akhlaq2006
ID: 24201482
dear here is my router basic configuration but still not getting internet

Router#show run
Building configuration...

Current configuration : 894 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip subnet-zero
ip cef
!
!
no ip dhcp use vrf connected
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 172.172.101.1 255.255.0.0
 ip nat inside
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0/0
 ip address 83.111.32.154 255.255.255.252
 ip nat outside
 encapsulation ppp
!
ip classless
ip route 0.0.0.0 0.0.0.0 83.111.32.153
!
no ip http server
ip nat inside source list 1 interface Serial0/0/0 overload
!
access-list 1 permit 172.172.101.0 0.0.0.255
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
 login
!
end
0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 24203600
Is the T1 up?  Can you ping 209.85.225.147 from the router itself?

Please post a "show int s0/0/0".

Do the inside clients have DNS server settings (the ones provided by your ISP)?
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 

Author Comment

by:akhlaq2006
ID: 24204151
problem is this


when internal network ( f0/0 or f0/1)  is not connected i can ping yahoo or any where outside
when internal network connected i can't ping outside but internal ok

i trying internal directly connected with one pc having following ip

172.172.101.44
255.255.0.0
172.172.101.1 (for router)



dns 195.229.241.222 ( from isp normal we are using to access internet)


this is public ip 83.111.32.154 (s0/0/0) you can try from your location that it is pinging as well


you ask about s0/0/0


router#show int s0/0/0
Serial0/0/0 is up, line protocol is up
  Hardware is GT96K Serial
  Internet address is 83.111.32.154/30
  MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation HDLC, loopback not set
  Keepalive set (10 sec)
  Last input 00:00:08, output 00:00:00, output hang never
  Last clearing of "show interface" counters 04:44:32
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations  0/1/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 1158 kilobits/sec
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     4398 packets input, 214250 bytes, 0 no buffer
     Received 1706 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     4496 packets output, 289551 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 output buffer failures, 0 output buffers swapped out
     0 carrier transitions
     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up

0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 24204221
So, from the PC, can you ping 172.172.101.1?
Can you ping 83.111.32.154?
Can you ping 83.111.32.153?
Can you ping 209.85.225.99?
Can you ping www.google.com?
Can you telnet 209.85.225.99 80?
0
 

Author Comment

by:akhlaq2006
ID: 24204312
can ping 172.172.101.1
can ping 83.111.32.154
can't ping 83.111.32.153
can't ping 209.85.225.99
can't ping www.google.com


but from directly router i can
0
 

Author Comment

by:akhlaq2006
ID: 24204426


router#show int f0/1
FastEthernet0/1 is up, line protocol is up
  Hardware is Gt96k FE, address is 0021.55a3.0341 (bia 0021.55a3.0341)
  Internet address is 172.172.101.1/16
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s, 100BaseTX/FX
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:01, output 00:00:02, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 1 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     11088 packets input, 956882 bytes
     Received 2267 broadcasts, 0 runts, 0 giants, 0 throttles
     8 input errors, 8 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog
     0 input packets with dribble condition detected
     3126 packets output, 252521 bytes, 0 underruns
     0 output errors, 2 collisions, 11 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out
router#
0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 24204562
Since you are using a /16 (255.255.0.0) mask on the f0/1 interface, add this:

conf t
access-list 1 permit 172.172.101.0 0.0.255.255
0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 24204572
Okay, so I see f0/1 in use but your config is for f0/0?  Has something changed?
0
 

Author Comment

by:akhlaq2006
ID: 24204623
before was using f0/0 but f0/1
sending you agian router configuration

router#show run
Building configuration...

Current configuration : 1322 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname router
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$gzIm$mnA3Sx.OvJXsEQsF/CrTH.
enable password boot
!
no aaa new-model
!
resource policy
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip subnet-zero
no ip routing
no ip cef
!
!
no ip dhcp use vrf connected
!
!
no ip domain lookup
ip name-server 195.229.241.222
ip name-server 255.255.255.255
ip name-server 83.111.32.153
!
!
!
!
interface FastEthernet0/0
 no ip address
 no ip route-cache
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 172.172.101.1 255.255.0.0
 ip nat inside
 no ip route-cache
 speed auto
 full-duplex
 no mop enabled
!
interface Serial0/0/0
 ip address 83.111.32.154 255.255.255.252
 ip nat outside
 no ip route-cache
!
ip classless
ip route 0.0.0.0 0.0.0.0 83.111.32.153
!
no ip http server
ip nat inside source list 1 interface Serial0/0/0 overload
!
access-list 1 permit 172.172.0.0 0.0.255.255
access-list 1 permit 172.172.101.0 0.0.0.255
access-list 101 permit udp any any eq domain
access-list 101 permit udp any eq domain any
snmp-server community cs RO
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
 password boot
 login
!
end
0
 
LVL 43

Accepted Solution

by:
JFrederick29 earned 2000 total points
ID: 24204642
Okay, here is an issue (routing is disabled).

Do this:

conf t
ip routing
0
 

Author Closing Comment

by:akhlaq2006
ID: 31572702
thank you very much now inernet is up and going well now i want vpn configuration acuallay i m new to cisco commands and configuration please help me also to configure vpn also
0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 24204739
Sure, open another question and I can assist with the VPN setup.
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Secure VPN Connection terminated locally by the Client.  Reason 442: Failed to enable Virtual Adapter. If you receive this error on Windows 8 or Windows 8.1 while trying to connect with the Cisco VPN Client then the solution is a simple registry f…
How to set-up an On Demand, IPSec, Site to SIte, VPN from a Draytek Vigor Router to a Cyberoam UTM Appliance. A concise guide to the settings required on both devices
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

830 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question