?
Solved

Load Balance Issue on Cisco 2810 Router

Posted on 2009-04-21
15
Medium Priority
?
760 Views
Last Modified: 2012-05-06
I used this as a guide to set up load balancing on our cisco router http://www.cisco.com/en/US/products/sw/secursw/ps1018/products_configuration_example09186a00809454c7.shtml

I attached the config file.

Basically it seems to only use one route (192.168.0.12 router)  and gives a lot of latency and dropped pages.  From what i can tell is it is trying to go out on the .12 router but through the other two interfaces which is causeing packet loss until it picks the correct interface (GigabitEthernet0/0).  Do you have any suggestions on what i can change?  Should i try approching this in a different manner?  We are trying to get load balancing and failover for our 3 ISP connections.  I think the problem is with how the .12 router has to go through an inside interface maybe?  Please help, i need to get this working.  Thanks!
cocisco-confg.txt
0
Comment
  • 5
  • 5
  • 5
15 Comments
 
LVL 43

Expert Comment

by:JFrederick29
ID: 24197979
Your config looks okay.  The g0/0 with "ip nat inside" is fine since I assume the 192.168.0.12 device will NAT the 192.168.0.0 traffic, right?  So, if you do a "show ip route", do you see 3 default routes?  Can you post your show ip route with all 3 interfaces up/up.  To isolate the issue, you can shutdown the g0/1 and f0/1/0 and test Internet with only the g0/0 interface up.  Then do the same for the other two interfaces, shutdown g0/0 and f0/1/0 and test using g0/1, then shutdown g0/0 and g0/1 and test with f0/1/0.  See if you only get high latency and packet loss with one provider.
0
 
LVL 28

Expert Comment

by:asavener
ID: 24198165
I don't understand why this command is issued:  "ip nat inside source route-map fixed-nat interface GigabitEthernet0/0 overload"

From your configuration, G0/0 is an inside interface.

I also don't understand why you have three default routes entered, when you only have two outside interfaces.  It seems to me that "ip route 0.0.0.0 0.0.0.0 192.168.0.12 track 123" should be removed, and you should configure routing for any inside networks.




0
 

Author Comment

by:nicolas-cableorganizer
ID: 24198868
- JFREDERICK29 - when any one interface is up and the others are down it works fine, it is just when the 3 interfaces are up together that they get the lag.
                          - The g0/0 with "ip nat inside" is fine since I assume the 192.168.0.12 device will NAT the 192.168.0.0 traffic, right - YES
                           - Show ip route - minus one connection because office is using that one while i test


Gateway of last resort is 192.168.0.12 to network 0.0.0.0

C    192.168.0.0/24 is directly connected, GigabitEthernet0/0
       74.0.0.0/29 is subnetted, 1 subnets
C              74.238.90.232 is directly connected, FastEthernet0/1/0
S*    0.0.0.0/0 [1/0] via 192.168.0.12
                                is directly connected, FastEthernet0/1/0 <-----This is where i think the problem is not sure why it is doing this.


-asavener- the .12 is a router on the internal network in our remote colocation that is on a flat network with our office.  the internet connection in the colo is connected to that router.  so one of the routes i want to set up is out through that router which is using a fiber metro-e line.

I thought i needed the command "ip nat inside source route-map fixed-nat interface GigabitEthernet0/0 overload"
to have it work like the other two outside connections.
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
LVL 28

Expert Comment

by:asavener
ID: 24198964
You have to define each interface as an inside interface or an outside interface.  I suspect your lag is coming from your G0/0 interface trying to operate as both an inside and outside interface.

Basically, you need to set up subinterfaces on the G0/0 port, each on a separate subnet, if you want to accomplish what you're trying to do here.  Or set up a loopback interface, and use policy-based routing to change what interface the traffic is going through  (that's a very convoluted method, however).

Alternately, go with the two outside interfaces you have, and quit trying to make G0/0 perform double duty.
0
 

Author Comment

by:nicolas-cableorganizer
ID: 24199058
"you need to set up subinterfaces on the G0/0 port, each on a separate subnet"
How would i do that?
0
 

Author Comment

by:nicolas-cableorganizer
ID: 24199088
I have another port "FastEthernet0/0/0"  could i set that up to be a external port that goes to the .12?  Could i give it an internal ip address or would it have to be on its own subnet?
0
 
LVL 28

Expert Comment

by:asavener
ID: 24199481
"I have another port "FastEthernet0/0/0"  could i set that up to be a external port that goes to the .12?  Could i give it an internal ip address or would it have to be on its own subnet?"

That would be a better choice.  Do you have an additional port on the 192.168.0.12 router as well?
0
 
LVL 43

Accepted Solution

by:
JFrederick29 earned 2000 total points
ID: 24200629
Having the g0/0 with ip nat inside is not an issue.  NAT is not being applied since it isn't traversing inside to outside so don't worry about it.  The router will simply route (without NAT) the traffic to 192.168.0.12 where the traffic will be NAT'd.

Try changing the route to this:

conf t
no ip route 0.0.0.0 0.0.0.0 FastEthernet0/1/0
ip route 0.0.0.0 0.0.0.0 dhcp

See if you get an IP next hop on the default route via f0/1/0 with that command.  You might need to shut and no shut the f0/1/0 interface after changing the route.
0
 
LVL 28

Expert Comment

by:asavener
ID: 24201102
NAT is being applied, because he has a NAT statement applied using the g0/0 interface address.

"ip nat inside source route-map fixed-nat interface GigabitEthernet0/0 overload"


0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 24203615
But it will only be applied if traversing between two nat enabled interfaces (inside to outside or outside to inside).  In this case, traffic is coming in a nat inside interface and going back out a nat inside interface so NAT isn't applied to the traffic.
0
 

Author Comment

by:nicolas-cableorganizer
ID: 24204231
no ip route 0.0.0.0 0.0.0.0 FastEthernet0/1/0
ip route 0.0.0.0 0.0.0.0 dhcp

I made the above changes and show ip route now shows what you see below.  Seems to have solved the problem!
Thanks for your help.  Thanks both of you for taking the time to respond to my post!!!



C     192.168.0.0/24 is directly connected, GigabitEthernet0/0
        74.0.0.0/29 is subnetted, 1 subnets
C            74.238.90.232 is directly connected, FastEthernet0/1/0
S*     0.0.0.0/0 [1/0] via 192.168.0.12
                        [1/0] via 74.238.90.233
0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 24204268
Yeah, specifying a next hop interface on a multiaccess network typically doesn't work very well.

Glad to hear it is working.
0
 
LVL 28

Expert Comment

by:asavener
ID: 24204365
"But it will only be applied if traversing between two nat enabled interfaces (inside to outside or outside to inside).  In this case, traffic is coming in a nat inside interface and going back out a nat inside interface so NAT isn't applied to the traffic."

He has equal-cost routing out all three interfaces.  If it routes traffic out the G0/0 interface, it ain't gonna work.
0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 24204597
>He has equal-cost routing out all three interfaces.  If it routes traffic out the G0/0 interface, it ain't gonna work.

It is working though.  Why won't it work if routed out the G0/0 interface?  The next hop via the g0/0 interface is handling NAT.  The router isn't/doesn't need to NAT the traffic.
0
 

Author Closing Comment

by:nicolas-cableorganizer
ID: 31572954
Thanks for your help!
0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

New Server 172.16.200.2  was moved from behind Router R2 f0/1 to behind router R1 int f/01 and has now address 172.16.100.2. But we want users still to be able to connected to it by old IP. How to do it ? We can used destination NAT (DNAT).  In DNAT…
I have seen some questions on problems with SSH/telnet access to Cisco routers that may occur despite the fact that from a PC connected to your LAN, Internet connectivity is in place and users can access Internet sites without any issues.  There are…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

862 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question