• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1650
  • Last Modified:

My Documents icon missing, option grayed out

The My Documents icon is missing on the desktop.

Right-click desktop / Properties / Desktop Pane / Customize Desktop ... My Documents is grayed out.  See screenshot1.png

Double clic My Computer / Tools / Folder Options / View Pane ... option "Show My Documents folder" is missing (not only grayed out but not there)

Computer is in the same OU as others that do not have this problem (using the same domain user).   Even tried to remove the computer from the domain, restarted, still same problem.

I applied the registry REG file shown above, restarted computer, and that didn't fix the problem.
Windows Registry Editor Version 5.00
 
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\HideDesktopIcons\ClassicStartMenu]
"{20D04FE0-3AEA-1069-A2D8-08002B30309D}"=dword:00000000
"{450D8FBA-AD25-11D0-98A8-0800361B1103}"=dword:00000000
"{208D2C60-3AEA-1069-A2D7-08002B30309D}"=dword:00000000
"{871C5380-42A0-1069-A2EA-08002B30309D}"=dword:00000000
 
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\HideDesktopIcons\NewStartPanel]
"{20D04FE0-3AEA-1069-A2D8-08002B30309D}"=dword:00000000
"{450D8FBA-AD25-11D0-98A8-0800361B1103}"=dword:00000000
"{208D2C60-3AEA-1069-A2D7-08002B30309D}"=dword:00000000
"{871C5380-42A0-1069-A2EA-08002B30309D}"=dword:00000000
 
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\HideDesktopIcons\ClassicStartMenu]
"{20D04FE0-3AEA-1069-A2D8-08002B30309D}"=dword:00000000
"{450D8FBA-AD25-11D0-98A8-0800361B1103}"=dword:00000000
"{208D2C60-3AEA-1069-A2D7-08002B30309D}"=dword:00000000
"{871C5380-42A0-1069-A2EA-08002B30309D}"=dword:00000000
 
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\HideDesktopIcons\NewStartPanel]
"{20D04FE0-3AEA-1069-A2D8-08002B30309D}"=dword:00000000
"{450D8FBA-AD25-11D0-98A8-0800361B1103}"=dword:00000000
"{208D2C60-3AEA-1069-A2D7-08002B30309D}"=dword:00000000
"{871C5380-42A0-1069-A2EA-08002B30309D}"=dword:00000000

Open in new window

screenshot1.PNG
0
mfecteau
Asked:
mfecteau
  • 5
  • 4
  • 3
  • +3
1 Solution
 
wantabe2Commented:
Hmm, try right clicking my documents & them give it another path (make sure you write down its current path first) & hit apply. Reboot & change the path back to default. This is just a thought though...To make sure a computer policy is not in place you do not know about, also try renaming the computer & leave the domain then come back.
0
 
houssam_balloutCommented:
0
 
MYCUCommented:
Try this in order to get it back.
http://support.microsoft.com/kb/217764

Good Luck!
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
mfecteauAuthor Commented:
wantabe2 : I cannot give another path to the icon if the icon doesn`t exist yet.  Also, the domain or OU GPOs cannot be at fault (correct me if I`m wrong) because it is working on another computer that is in the same OU (and I`m using the same domain user) ...
JDominguezNY : This fix seems to be for the My Computer icon.
 houssam_ballout: My solution needs to be for all user that will connect to that computer (so Default User on that computer should be configured correctly).  The solution you gave needs to hardcode the path to My Documents for one user...  
MYCU: This solution applies to Windows 98.  I tried it and didn`t work.
0
 
Donald StewartNetwork AdministratorCommented:
Just out of curiosity try windows enabler
http://www.angelfire.com/falcon/speedload/index.html
 
just click on the executable and it will go into systray then click on it in systray to enable it. Then see if you can re-enable my documents
0
 
JDominguezNYCommented:
mfecteau: If you follow the first step of my fix just select Remove My Documents icon from the desktop rather than My Computer it should work.

As a side note your Local Computer has a gpedit.msc that is not associated with the domain group policy.  
0
 
Donald StewartNetwork AdministratorCommented:
JdominguezNY
Your "FIX" is a copy/paste from http://billjr.spaces.live.com/blog/cns!28CBD6442F406227!642.entry that is gonna get deleted
0
 
JDominguezNYCommented:
I stated on my first comment that I found the steps.
0
 
mfecteauAuthor Commented:
dstewartjr:  With Windows Enabler, I was able to make the checkbox selectable, but that didn`t fix the problem.  My Documents icon is still not on the desktop.  Log off and on, still same problem. Went back in the config and the option is still grayed out and unchecked.
0
 
Donald StewartNetwork AdministratorCommented:
You need to give credit to the site, not plagiarize
0
 
Donald StewartNetwork AdministratorCommented:
mfecteau
 
Ok was curious
0
 
mfecteauAuthor Commented:
JDominguezNY:  the "Remove My Documents icon on the desktop" policy is already at "Not Configured" in gpedit.msc.
0
 
Donald StewartNetwork AdministratorCommented:

see if the MaxCachedIcons value will fix it
http://www.pcmag.com/article2/0,1895,1206406,00.asp 
0
 
JDominguezNYCommented:
These are the registry fixes specifically for My Documents

Manual Steps Using Windows XP Registry

   1. Click Start and then Run.
   2. Type regedit.exe in the Run dialog box.
   3. Press ENTER on your keyboard.
   4. Navigate to:

      HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\NonEnum
   5. Right-click {450D8FBA-AD25-11D0-98A8-0800361B1103} to select Modify.
   6. Change the value to 0.
   7. Navigate to:

      HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\NonEnum
   8. Right-click {450D8FBA-AD25-11D0-98A8-0800361B1103} to select Modify.
   9. Change the value to 0.
  10. Quit the Registry Editor (Regedit.exe).

    NOTE: You may need to log off then log on to your user account or restart your computer for the changes to take affect.

Manual Steps Using REG ADD

   1. Open a Command Window.
   2. Type:

      REG ADD "HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\NonEnum" /v {450D8FBA-AD25-11D0-98A8-0800361B1103} /t REG_DWORD /d 0
   3. Press ENTER on your keyboard.
   4. Type:

      REG ADD "HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\NonEnum" /v {450D8FBA-AD25-11D0-98A8-0800361B1103} /t REG_DWORD /d 0
   5. Press ENTER on your keyboard.
   6. Type EXIT and press ENTER on your keyboard.

    NOTE: You may need to log off then log on to your user account or restart your computer for the changes to take affect.

Source: http://billjr.spaces.live.com/blog/cns!28CBD6442F406227!644.entry
0
 
mfecteauAuthor Commented:
Used the REG file on the web site given and it fixed the problem.  Seems the problem is because of "Internet Explorer Enhanced Security Configuration".  See Citrix article CTX112996.  Thanks a lot !
0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

  • 5
  • 4
  • 3
  • +3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now