• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 7671
  • Last Modified:

The form you selected cannot be displayed. The form required to view this message cannot be display. Contact your administrator.

[Edited for clarity]

When Outlook clients try to access published forms, we receive the error shown in the title.  

We recently started getting this message after making some of the following changes on our Exchange 2003 SP2 Server (due to the number of changes, I am not sure if/which one actually could caused the problem):

+ Installed Windows Server 2003 SP2, IE7, and all updates
+ Installed McAfee 8.7i
+ Uninstalled GroupShield 6 and installed GroupSheild 7 w/ SP1

I have tried disabling the local AV on the client and server to see if that was blocking it, but I still get the error.  I have also tried clearing local cache, but the reality is that is happens now on every machine with Outlook 2007, 2003, etc... trying to access Organizational Forms.  We have not physically modified any of the client or directory permissions through AD or ESM.

The error is,  "The form you selected cannot be displayed.  The form required to view this message cannot be display.  Contact your administrator."

Have any of you seen anything like this before?  
0
CecilAdmin
Asked:
CecilAdmin
1 Solution
 
peakpeakCommented:
Hints here:
http://www.outlookcode.com/article.aspx?id=64
Seems like you need to delete the cache, not only clear it.
0
 
CecilAdminAuthor Commented:
^I have tried clearing, deleting, renaming, etc... on client machines.

When I create/publish a new form, it works fine; everyone can access the new form just like they accessed one of the old ones.  It sounds like either the previous permissions have become corrupt or the old forms themselves were deleted.  I just cannot seem to pinpoint exactly what happened.  I know for a fact though that the problem started happening after one of those updates/installs.

I am contemplating a restore of the EForms Registry, but there does not seem to be an 'easy' way of doing it without restoring the entire public folder store.
0
 
CecilAdminAuthor Commented:
+ Dismounted the Exchange Public Folder Store
+ Restored an older Public Folder database from tape using Symantec Backup Exec
+ Mounted the old database
+ Used Outlook Design a Form to save all Forms as .oft from the Organizational Forms Library
+ Dismounted the old database
+ Mounted the latest database
+ Used Outlook to delete all corrupt forms using an account that has been granted Owner access to the Organizational Forms Library
   1. Click on the "Tools" menu
   2. Click on "Options"
   3. Click on the "Other" tab
   4. Click the "Advanced Options" button
   5. Click the "Custom Forms" button
   6. Click the "Manage Forms" button
   7. Click the Form you want to delete and select the "Delete" button
   8. Close and OK through all Outlook Property/Option windows
+ Used Outlook Design a Form to select User Templates in Files System grab the old .oft forms.
+ Reestablished all Property links to other forms and Published all old forms into the existing Organizational Forms Library
+ Had clients clear the form cache
   1. Click on the "Tools" menu
   2. Click on "Options"
   3. Click on the "Other" tab
   4. Click the "Advanced Options" button
   5. Click the "Custom Forms" button
   6. Click the "Manage Forms" button
   7. Click the "Clear Cache" button
   8. Close and OK through all Outlook Property/Option windows
+ Clients were then able to access the forms again.  We paid to work with Microsoft Support too to assist throughout this entire process but never determined the root cause.
0
 
jweisbordCommented:
Thanks!!! Very helpful guys
0
 
ILLMOCommented:
To add a little to this thread...
If clearing the Form Cache does not help, check the properties of the calendar that is giving the error message.  (In Outlook, click on Calendar.  Then right click on your the calendar that is giving the error and select properties).  Verify that the "When posting to this folder, use:" is set correctly.  If it is set to Private, that may be causing your issue.  Try setting it to IPM.Appointment.  Then try to create your appointment again.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now