Configure dual monitors in Ubuntu 9.04 with ATI HD 2600

Hi experts,

I am fairly new to linux and want to delete Windows forever but I am having trouble with my monitor setup. I am running Ubuntu 9.04 RC1 (Jaunty Jackelope) on my ASUS notebook with an ATI HD 2600 plugged in to a 22" LCD. I want the notebook screen to run at 1440x900 and the LCD to run at 1680x1050. The display should not be mirrored but should be extended, with the panels spanning only one monitor (the big one).

Using the open source drivers this is absolutely fine, except it is laggy when running flash and I can't enable visual effects etc, so I assume I need to install the propietary driver. I downloaded the 9.4 ati catalyst driver from ati.com but when that's installed I can only set it to 1440x900 mirrored and changing the settings through the ubuntu control panel says "please log out and log back in" but results in no change. Catalyst control centre doesn't give me the option to change how multiple displays are set up.

Can some one please advise if this is possible or am I doomed to use Windows forever? Is there anybody out there that can write me a kick awesome xorg.conf file?

THANKS HEAPS IN ADVANCE
LVL 10
mstrelanAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

 
WizRd-LinuxCommented:
Someone else might correct me, but I'm pretty sure the Linux drivers from ATI do not support different screen resolutions.
0

Experts Exchange Solution brought to you by ConnectWise

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
 
mstrelanAuthor Commented:
Well nonetheless can I run it side by side not mirrored at 1440x900 (obviously not a permanent fix)? Or even disable the laptop monitor and just use the big one? With the current ATI drivers I can't do squat.
0
 
WizRd-LinuxCommented:
There should be an ATI specific control panel in the gnome menu at the top as part of the installation.  Are you able to change the settings through here, restart X - CTRL-ALT-Backspace?

0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
mstrelanAuthor Commented:
There is an ATi Catalyst Control centre. The displays option lists my 2 seperate displays but it is locked to mirror displays. I cannot change it to Big Desktop or Xinerama or anything like that. I have tried rebooting and CTRL ALT Backspace etc and cannot change it.

PS Ctrl Alt Backspace is removed from Jaunty Jackelope... but you can enable it with the following.
sudo apt-get install dontzap
sudo dontzap --disable

Open in new window

0
 
WizRd-LinuxCommented:
Try "aticonfig --desktop-setup=horizontal --effective=now".  This option won't work if you did aticonfig --initial=duel-head when you first configured it.
0
 
mstrelanAuthor Commented:
Thanks I'll load up the initial config and then try this. Will report back in 8 hours or so.
0
 
mstrelanAuthor Commented:
Hi.
I get the following error.
Error: Options, e.g. --dtop and --desktop-setup, are not supported when RandR 1.2 is enabled!
0
 
mstrelanAuthor Commented:
I tried xrandr -q
And these are the results. Don;t know if this helps

Screen 0: minimum 320 x 200, current 1440 x 900, maximum 1680 x 1680
LCD connected 1440x900+0+0 (normal left inverted right x axis y axis) 304mm x 190mm
   1440x900       60.0*+
   1152x864       60.0  
   1280x768       60.0  
   1280x720       60.0  
   1024x768       60.0  
   800x600        60.0  
   720x480        60.0  
   640x480        60.0  
   640x432        60.0  
   640x400        60.0  
   512x384        60.0  
   400x300        60.0  
   320x240        60.0  
   320x200        60.0  
DFP1 connected 1440x900+0+0 (normal left inverted right x axis y axis) 474mm x 296mm
   1680x1050      59.9 +
   1400x1050      60.0  
   1280x1024      75.0     60.0  
   1440x900       59.9*
   1280x960       60.0  
   1152x864       75.0     60.0  
   1280x768       59.9  
   1280x720       60.0  
   1024x768       75.0     70.1     60.0  
   800x600        72.2     75.0     70.0     60.3     56.2  
   720x480        60.0  
   640x480        75.0     72.8     75.0     60.0  
   640x432        60.0  
   640x400        75.1     59.9  
   512x384        60.0     74.9  
   400x300        75.0     60.7  
   320x240        75.6     60.0  
   320x200        75.5     60.1  
CRT1 disconnected (normal left inverted right x axis y axis)
TV disconnected (normal left inverted right x axis y axis)
COMPONENT_VIDEO disconnected (normal left inverted right x axis y axis)
0
 
mstrelanAuthor Commented:
This sucks. I will not use linux solely for this reason. I was excited about Ubuntu 9.04 and was ready to delete Windows permanently but its not even worth it if I can't use my 22" monitor properly. I guess I'll wait for 9.10 or 10.04.
0
 
mstrelanAuthor Commented:
PROBLEM SOLVED!

The key was to disable RandR1.2 via instruction at http://is.gd/urrT
Then I was able to modify xorg.conf as below
# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg
 
Section "ServerLayout"
    Identifier     "Default Layout"
    Screen      0  "aticonfig-Screen[0]" 0 0
EndSection
 
Section "Files"
EndSection
 
Section "Module"
EndSection
 
 
Section "Monitor"
    Identifier   "aticonfig-Monitor[0]"
    Option        "VendorName" "ATI Proprietary Driver"
    Option        "ModelName" "Generic Autodetecting Monitor"
    Option        "DPMS" "true"
EndSection
 
Section "Monitor"
    Identifier   "aticonfig-Monitor[1]"
    Option        "VendorName" "ATI Proprietary Driver"
    Option        "ModelName" "Generic Autodetecting Monitor"
    Option        "DPMS" "true"
EndSection
 
Section "Device"
    Identifier  "aticonfig-Device[0]"
    Driver      "fglrx"
    Option    "EnableRandR12" "false"
    Option        "DesktopSetup" "horizontal,reverse"
    Option        "OverlayOnCRTC2" "1"
    Option        "Mode2" "1280x768"
    Option        "VideoOverlay" "on"
    Option        "OpenGLOverlay" "off"
    Option        "EnableMonitor" "tmds1,lvds"
    Option        "PairModes" "1680x1050+1440x900"
EndSection
 
Section "Screen"
    Identifier "aticonfig-Screen[0]"
    Device     "aticonfig-Device[0]"
    Monitor    "aticonfig-Monitor[0]"
    DefaultDepth     24
    SubSection "Display"
        Viewport   0 0
        Virtual   1440 900
        Depth     24
        Modes    "1440x900"
    EndSubSection
EndSection
 
Section "Screen"
    Identifier "aticonfig-Screen[1]"
    Device     "aticonfig-Device[0]"
    Monitor    "aticonfig-Monitor[1]"
    DefaultDepth     24
    SubSection "Display"
        Viewport   0 0
        Virtual   1680 1050
        Depth     24
        Modes    "1680x1050"
    EndSubSection
EndSection

Open in new window

0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.