Vmware Converter and Volume Shadow Copy Service

Posted on 2009-04-21
Last Modified: 2012-05-06
I keep getting the following error on 2 different server 2003 enterprise R2 edition servers when I try to run the vmware Converter on them.

These servers are currently virtual servers that are running under the old free VMware server 1.0.8 and I am trying to move them onto an esx 3.5 server. if I simply copy the servers over I get all kinds of errors regarding the drive paths. so I am trying to bring them over using the vmware converter but it keeps failing with the error below and I can't figure out why.

"Volume Shadow Copy Service error: An internal inconsistency was detected in trying to contact shadow copy service writers.  Please check to see that the Event Service and Volume Shadow Copy Service are operating properly."

Question by:mattolan
    LVL 22

    Assisted Solution

    Have you tried shutting down the virtuals and importing?
    LVL 7

    Expert Comment

    65td has a valid point.Try shutting down the VMs and then try to do a cold migration.
    LVL 42

    Expert Comment

    Make sure that you don't have any errors with your VSS.  You can do this with in cmd prompt by typing "vssadmin list writers"  Report back and let us know.

    You also may want to try installing the agent within the guest OS if you haven't done so already.

    Also make sure that you're using vConverter 4.0 Standalone, the new version has many improvements.
    LVL 2

    Author Comment

    I am using the Converter 4.0 Standalone. and if I run a vssadmin list writers on either machine the command runs but it doesn't have any writers listed.

    not sure how to install the agent within the OS, it does seem to install fine from converter

    by cold migration /importing are you refering to using converter and selecting a source typ of "vmware workstation or other vmware virtual machine"? becuase I did try this but it gives me an error. I can't remember what the error is off hand but I will try it again and post the error here.
    LVL 42

    Accepted Solution

    You can install the vConverter within the guest OS or from a different machine.  If you're doing it from a different machine try installing it within the OS itself.

    If you are not showing any VSS Writers than there may be an issue on the OS.  Check to see if you have Volume Shadow Copy Service running, if not start it and try again
    LVL 2

    Author Comment

    I installed vConverter onto a different machine. the windows server 2003 box that the VM's in question are on and offline conversion seems to be working. It is running and will complete in a few hours. I will let you know if this works. I tried to do an offline conversion before but from a remote computer and it was failing so maybe it had to do with the fact that it was remote?

    will post back the results
    LVL 2

    Author Closing Comment

    The Cold import worked, but I had to install converter directly onto the machine that the vm's where residing on. I could not get it to work remotely it kept giving me an error regarding the hard drives on vm's

    Featured Post

    What Security Threats Are You Missing?

    Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

    Join & Write a Comment

    In VMware vSphere 4 1 and 5.0, if you have two or more hosts, using shared storage, (SAN/NAS) you can create a VMware vSphere Cluster and enable High Availability mode (HA), if you have the correct VMware vSphere Licensing. VMware vSphere High Av…
    One of the new features of a version 7.0 or later virtual machine, supported in VMware vSphere 4.1, 5.0 or the VMware vSphere Hypervisor ESXi 4.1, ESXi 5.0 often overlooked by VMware Administrators is the ability to add and connect USB devices conne…
    Teach the user how to install ESXi 5.5 and configure the management network System Requirements: ESXi Installation:  Management Network Configuration: Management Network Testing:
    This video shows you how to use a vSphere client to connect to your ESX host as the root user. Demonstrates the basic connection of bypassing certification set up. Demonstrates how to access the traditional view to begin managing your virtual mac…

    734 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    24 Experts available now in Live!

    Get 1:1 Help Now