Help with HP Switches and Optic Fiber

Posted on 2009-04-21
Last Modified: 2013-11-13
We have a fibre optic link between two levels of our building.  A few weeks back, the connection between the levels failed early in the morning.  I was the only person here, and know that there was nobody else in the building when it failed.

We immediately had a technician come in to test the fibre, which was OK.  We tried changing switches to no avail, spoke to HP who thought it may be a faulty transceiver, they sent out a replacement which didn't fix them problem.

The original configuration was, Upper level fibre was plugged into a HP Procurve 2650 (J4899B) with a Gigabit Transceiver (J4858B), the fibre end on the lower level was plugged into a HP Procurve 2324 (J4818A) with a Gigabit SX Transceiver (J4131B).

We have a second switch on the lower level, a HP Procurve 2142 (J4868A) with a 100FXSC Transceiver (J4853A) we plugged the fibre into that.  A link light on this switch illuminated, however there was no link light on the switch upstairs.

We moved the J4858B Transceiver to a HP 2824 (J4903A) upstairs, and had exactly the same results, link light was on downstairs, nothing upstairs.  Spoke to HP who thought the J4858B was faulty, sent a J4858C replacement.  I upgraded the firmware on the HP 2824 to cope, plugged in the new transceiver, and had exactly the same problem.  No link light upstairs, link light downstairs, no data being transmitted.

I've ensured the TX and RX cables are plugged into the right spots, even tried switching them around.

We had a second company come in to test the fibre link yesterday, they again confirmed that the fibre cable is functioning properly, and their equipment can send and receive data.  They too could not work out why our equipment could not communicate with each other, given we've tried every possible of switches, transceivers, and fibre cores.

No now I turn to the experts.  Please help!  We're currently "functioning" via a long Cat 6 cable running through the fire escape.  Doesn't look good.

Thanks in Advance.
Question by:EBASupport
    LVL 6

    Accepted Solution

    Fiber plugged directly into the modules? Or are there fiber patch cables involved?

    If there are patch cables, did the fiber techs test the patch cables?
    If not... is it possible there is an intermitent connection on the link that is out? Possibly damaged at one end of the run or the other?

    One other dumb question the module is MM. Does your fiber match the modules that you are using?

    Can you move the switches close together and use a short fiber patch cable to test? If they work on the short cable its the fiber. If they don't it is one of the switches and or modules.

    Do you have one running in full-duplex and one running in half duplex mode?


    Author Comment

    Turned out to be one of the Transceivers.  In my ignorance I failed to realise that I could not replace an SX tranceiver with an SC tranceiver, hence why the connection would not establish when trying these different parts.

    Ended up calling HP and had them send one of every component until we got it working again.

    Thanks for your input.

    Featured Post

    Highfive Gives IT Their Time Back

    Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

    Join & Write a Comment

    Suggested Solutions

    Broadband over Power Lines Broadband over Power Lines is the technology of transmitting computer data through power lines. This method of connectivity allows the user to have access to the internet without having to rely on additional cables, suc…
    This solves the problem of diagnosing why an internet connection is no longer working. It also helps identify the likely cause of the lost connection if the procedure fails to re-establish your internet connection. It helps to pinpoint the likely co…
    To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…
    This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor ( If you're looking for how to monitor bandwidth using netflow or packet s…

    728 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    23 Experts available now in Live!

    Get 1:1 Help Now