[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 565
  • Last Modified:

ftp connection refused

This question has been asked before, but proposed solutions aren't working. I have Linux kernel 2.6.27.7-smp, Slackware release 12. I am trying to ftp to this computer. I get "connection refused". I have ALL:ALL in my hosts allow, I have uncommented the line: ftp     stream  tcp     nowait  root    /usr/sbin/tcpd  proftpd, in my inetd.conf file. the /usr/sbin/tcpd file exists. I have no firewall running.

Wassup?
0
jmarkfoley
Asked:
jmarkfoley
  • 3
  • 2
  • 2
  • +1
1 Solution
 
asethi19Commented:
When you try and connect can you check if it is trying in active mode or passive mode?

Please try switching between the 2 modes usally that works
0
 
niimCommented:
1. try using active or passive mode with your ftp client
2. load ftp module on ftp server: "modprobe ip_nat_ftp"
0
 
omarfaridCommented:
connection refused could be due to

- ftp server is not not running
- a firewall is denying your connection
- connecting to the wrong system due to network issue
0
Veeam and MySQL: How to Perform Backup & Recovery

MySQL and the MariaDB variant are among the most used databases in Linux environments, and many critical applications support their data on them. Watch this recorded webinar to find out how Veeam Backup & Replication allows you to get consistent backups of MySQL databases.

 
jmarkfoleyAuthor Commented:
omarfarid: ftpd is not running, but neither is it running on a machine I can ftp to. ftp is configured in inetd.conf. As I said in my initial post: no firewall. I am using the correct system; I can ssh to it and http to it, just not ftp.

niim: modprobe ip_nat_ftp didn't help. I am using bash command line ftp, so that should be active on the client side.

asethi19: Given what I sait to niim above, I'm not sure what you mean by switching between active and passive, nor do I know how to do that.
0
 
omarfaridCommented:
on the same system and after you ssh to it, can you run

ftp 0

0
 
jmarkfoleyAuthor Commented:
OK folks, I've done some more messing and rebooted the system and it is working now. I think it did not take my kill -HUP 1 to cause initd to re-read the inetd.conf file. Not sure why. But, the reboot worked. omarfarid, interesting suggestion, but I want to be able to use the site for normal ftp connections for dreamweaver uploads, etc.
0
 
omarfaridCommented:
good that you could solve it. my last command was to see if your system really accept ftp connections
0
 
niimCommented:
"for normal ftp connections" i suggest to use filezilla (http://filezilla-project.org), its good and free ftp client, you might choose (in settings) active or passive connection mode.
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 3
  • 2
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now