Am installing WSS, single server install with default settings - fails with Exception E_ACCESSDENIED

Am trying to install WSS 3.0, single server install using default settings.  Install works fine.  When running configuration job, it rails on Task 5 With System.UnauthorizedAccessException
Access is denied.  ExceptionFromHResult: 0x80070005 (E_ACCESSDENIED)
wahoo2youAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

melli111SharePoint Administrator / DeveloperCommented:
A lot of install/config fails are caused by the user ID not having the correct permissions.  The setup account needs the following:

§   Domain user account.
§   Member of the Administrators group on each server on which Setup is run.
§   SQL Server login on the computer running SQL Server.
§   Member of the following SQL Server security roles:
·          securityadmin fixed server role
·          dbcreator fixed server roleIf you run Stsadm commands that affect a database, this account must be a member of the db_owner fixed database role for the database.
I attached the full list of user accounts and properties.  The attached is for MOSS but the setup user account has the same requirements for 3.0

MOSS-Single-Server-Service-Accou.doc
0
wahoo2youAuthor Commented:
Hi melli111 -
Your comments are correct, but not helpful.
I am doing a single server installation, using a domain user account that is a member of the Administrators group on the server.  I assume since embedded SQL was installed along with the single server installation that my user account was used.
When you use default settings, it does not prompt for a separate SQL Server access account.
I suspect there is something oddball in general regarding security at this client.  They are quite security conscious and perhaps they have turned off some service that is needed during the registration process.  I notice that the failure occurs while backing up the registry prior to update.
Rich
0
melli111SharePoint Administrator / DeveloperCommented:
Yes.... I had the same error doing a single server install.  And even though I was using the embedded SQL for my content and configuration databases I still had to have the user ID doing the install have the SQL permissions on my SQL server.  Why?  I don't know, that I can't explain (I don't know much about SQL), but once I was given those permissions my configuration no longer gave me an access denied error.  I then get an error in a later step about already having a configuration database, so I deleted the previous config db and tried again and voila!  It was successful.
 
0
wahoo2youAuthor Commented:
I discovered the answer to this question myself.  It had to do with the SQL connection string that was entered during configuration.
Once I modified the connection string to include instance name and port, it worked just fine.
Had nothing to do with permissions.
Rich Elliott
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
C#

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.