• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 406
  • Last Modified:

A simple network not working?!

Hi

I've got a new Cisco 2811, I configured on it a sub-interface like so:
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/1.20
 encapsulation dot1Q 20
 ip address 10.20.0.3 255.255.255.248
 no snmp trap link-status
!

I've configured it the same way I already have on another existing 2811:
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/0.20
 description New_Buffer_Net_20
 encapsulation dot1Q 20
 ip address 10.20.0.2 255.255.255.248
!

Both sub-interfaces at the 2 2811 are at the same 10.20.0.0/29 network & there's just no ping between the 2.

When I issue a "sho arp" at the existing router I see:

Internet  10.20.0.3              43   0015.fa20.90c9  ARPA   FastEthernet0/0.20

which is cool (the MAC is correct) but when I issue it at the new router (right after I ping 10.20.0.2) I get:

Internet  10.20.0.2               0   Incomplete      ARPA

I tried adding the MAC manually but still no pings.

These 2 routers are connected through a Cisco 2950 switch, both switches ports are configured the same way:
!
interface FastEthernet0/9
 description V20_To_Hub_Router
 switchport access vlan 20
 switchport mode access
 no ip address
end
!
interface FastEthernet0/20
 description To_Hub_Router_#2
 switchport access vlan 20
 switchport mode access
 no ip address
end

The existing 2811 is working for a year now & is able to ping another (3rd) 2811 on the same network (10.20.0.1), of course I'm not able to ping from this 3rd router to my new one as well & it's the same thing with the ARP table..

This new 2811 has a built-in ERM (whatever that may be), I tried playing with it but just ended up adding commands I wasn't sure how to delete:


resource policy
  policy test global
   system
   !
  !
  user global test


Here are the full running-configs of:

1. The new 2811:

Current configuration : 1729 bytes
!
version 12.4
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Hub_Router_2
!
boot-start-marker
boot-end-marker
!
enable password x
!
no aaa new-model
!
resource policy
  policy test global
   system
   !
  !
  user global test
  !
!
ip subnet-zero
!
!
ip cef
!
!
ip flow-cache timeout inactive 10
ip flow-cache timeout active 5
ip multicast-routing
no standby redirect
!
username x password 0 x
!
!
!
interface FastEthernet0/0
 no ip address
 ip pim sparse-dense-mode
 ip route-cache flow
 duplex auto
 speed auto
!
interface FastEthernet0/0.5
 encapsulation dot1Q 5
 ip address 10.7.0.200 255.255.255.0
 ip pim sparse-dense-mode
 no snmp trap link-status
 standby mac-address 2233.4455.6677
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/1.20
 encapsulation dot1Q 20
 ip address 10.20.0.3 255.255.255.248
 no snmp trap link-status
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.20.0.2
ip route 10.7.x.x 255.255.255.0 10.20.0.1
ip route 10.7.x.x 255.255.255.0 10.20.0.1
ip route 10.7.x.x 255.255.255.0 10.20.0.1
ip route 69.x.x.x 255.255.255.248 10.20.0.1
ip route 77.x.x.x 255.255.248.0 10.20.0.1
ip route 83.x.x.x 255.255.255.192 10.20.0.1
ip route 83.x.x.x 255.255.255.0 10.20.0.1
ip route 83.x.x.x 255.255.255.0 10.20.0.1
ip route 83.x.x.x 255.255.255.0 10.20.0.1
ip route 92.x.x.x 255.255.240.0 10.20.0.1
ip route 195.x.x.x 255.255.255.0 10.20.0.1
ip flow-export version 5
ip flow-export destination 77.x.x.x 2048
!
ip http server
ip pim bidir-enable
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
 password x
 login
!
scheduler allocate 20000 1000
!
end

2. The existing 2811:

Current configuration : 4112 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname x_Router
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
enable secret 5 $1$oJZf$Ios1h6M4yT/x6Ts4ZZcNK.
!
no aaa new-model
!
!
ip cef
!
!
ip domain name yourdomain.com
!
!
password encryption aes
!
crypto pki trustpoint TP-self-signed-2435588180
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-2435588180
 revocation-check none
 rsakeypair TP-self-signed-2435588180
!
!
crypto pki certificate chain TP-self-signed-2435588180
 certificate self-signed 01
  30820256 308201BF A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 32343335 35383831 3830301E 170D3038 30343039 30343231
  30345A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D32 34333535
  38383138 3030819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100BC52 A68C513B C6F8443D 3C3882E0 478C7212 ECB15EA3 F7F92D7D 4F2A7987
  B60FDDDD 1D41A60D 2BBF7FE3 4AF3C638 8050EB9A 79FF1616 9AACBD78 42052BF2
  4D79F089 AABC00AB 39E3FD4F 4E4B8953 3511DD41 87578A2A AD5535D1 ACDABAB0
  E9A90B56 5199AE49 9E5B12DC 1E62121D C24AC496 823813ED 1EEBFFAB 4609C60A
  91970203 010001A3 7E307C30 0F060355 1D130101 FF040530 030101FF 30290603
  551D1104 22302082 1E536B79 6C696E6B 735F526F 75746572 2E796F75 72646F6D
  61696E2E 636F6D30 1F060355 1D230418 30168014 FFFB3185 7A1BF87B 2745966E
  85B25551 93E4B8F0 301D0603 551D0E04 160414FF FB31857A 1BF87B27 45966E85
  B2555193 E4B8F030 0D06092A 864886F7 0D010104 05000381 81004C2C F27A294E
  C5C320CD 9C4F9D6E 22A2C2F4 8DF925CE A771CDD4 BB8D8104 ADC9D020 0BFA3687
  50FFFCE6 E847F24F 484B1BD4 291C41C8 D189AB3F DAC6EDA5 9537AE0A 8D1B487F
  57BA0AD8 8A60110B 33968668 279E1688 B5C16FB8 954B716C 4F9E55FA 410EE643
  88812488 BFC26174 89DA4717 0DCD544F 5030D9C7 FF0157D1 0D2B
  quit
username x secret 5 $1$CEG8$nAIhVJyr7xTFCC7EQcQXe1
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/0.20
 description New_Buffer_Net_20
 encapsulation dot1Q 20
 ip address 10.20.0.2 255.255.255.248
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/1.38
 encapsulation dot1Q 38
 ip address 77.x.x.x 255.255.255.240
!
interface FastEthernet0/1.77
 description "x_Servers
 encapsulation dot1Q 77
 ip address 77.x.x.x 255.255.255.240
!
interface FastEthernet0/1.78
 description "x Servers 2"
 encapsulation dot1Q 78
 ip address 77.x.x.x 255.255.255.248
!
interface FastEthernet0/1.79
 description "x Servers3"
 encapsulation dot1Q 79
 ip address 92.x.x.x 255.255.255.0
!
interface FastEthernet0/1.100
 description x's_Internet
 encapsulation dot1Q 100
 ip address 69.x.x.x 255.255.255.248
!
no ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 77.x.x.x
ip route 10.7.x.x 255.255.255.0 10.20.0.1
ip route 10.7.x.x 255.255.255.0 10.20.0.1
ip route 10.7.x.x 255.255.255.0 10.20.0.1
ip route 69.x.x.x 255.255.255.248 10.20.0.1
ip route 77.x.x.x 255.255.248.0 10.20.0.1
ip route 77.x.x.x 255.255.254.0 10.20.0.1
ip route 77.x.x.x 255.255.255.0 10.20.0.1
ip route 77.x.x.x 255.255.255.0 10.20.0.1
ip route 83.x.x.x 255.255.255.192 10.20.0.1
ip route 83.x.x.x 255.255.255.0 10.20.0.1
ip route 83.x.x.x 255.255.255.0 10.20.0.1
ip route 83.x.x.x 255.255.255.0 10.20.0.1
ip route 92.x.x.x 255.255.240.0 10.20.0.1
ip route 192.x.x.x 255.255.255.0 10.20.0.1
ip route 195.x.x.x 255.255.255.0 10.20.0.1
!
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
!
!
control-plane
!
!
!
line con 0
 login local
line aux 0
line vty 0 4
 privilege level 15
 login local
 transport input telnet ssh
line vty 5 15
 privilege level 15
 login local
 transport input telnet ssh
!
scheduler allocate 20000 1000
!
end

3. The 2950 switch connecting them together:

Current configuration : 3993 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Intersky_3
!
enable password shiron
!
username shiron privilege 15 password 0 shiron
!
vlan 2
 name x_DVB
!
vlan 4
 name Tx_Data
!
vlan 5
 name Rx_Data
!
vlan 6
 name x
!
vlan 7
 name Redundancy
!
vlan 10
!
vlan 12
 name QoS_in
!
vlan 20
!
vlan 38
 name x
!
vlan 39
!
vlan 40
!
vlan 77
!
vlan 78
!
vlan 79
!
vlan 83
 name Buffer_Internal
!
vlan 100
ip subnet-zero
vtp mode transparent
!
!
interface FastEthernet0/1
 description Uplink of V77 to BKP_SW_1
 switchport access vlan 77
 switchport mode access
 no ip address
!
interface FastEthernet0/2
 description Uplink of V78 to BKP_SW_1
 switchport access vlan 78
 switchport mode access
 no ip address
!
interface FastEthernet0/3
 description x_Router_FE0/1_Internal
 switchport trunk allowed vlan 4,38-40,77-79,83,100,1002-1005
 switchport mode trunk
 no ip address
!
interface FastEthernet0/4
 description "x GRAPHER"
 switchport access vlan 4
 switchport mode access
 no ip address
!
interface FastEthernet0/5
 switchport access vlan 79
 switchport mode access
 no ip address
!
interface FastEthernet0/6
 description MGMNT_Allot_10M
 switchport access vlan 77
 no ip address
!
interface FastEthernet0/7
 switchport access vlan 79
 switchport trunk allowed vlan 4,77-79,1002-1005
 switchport mode trunk
 no ip address
!
interface FastEthernet0/8
 description To_Internal_Buffer_R
 switchport trunk allowed vlan 20,1002-1005
 switchport mode trunk
 no ip address
!
interface FastEthernet0/9
 description V20_To_Hub_Router
 switchport access vlan 20
 switchport mode access
 no ip address
!
interface FastEthernet0/10
 description "IP Forwanding #2 F0/1"
 switchport access vlan 5
 switchport mode access
 no ip address
!
interface FastEthernet0/11
 description "a #1 IP Data"
 switchport access vlan 5
 switchport mode access
 no ip address
!
interface FastEthernet0/12
 description "a #2 IP Data"
 switchport access vlan 5
 no ip address
!
interface FastEthernet0/13
 description "a #3 IP Data"
 switchport access vlan 5
 switchport mode access
 no ip address
!
interface FastEthernet0/14
 description "x Not Installed"
 switchport access vlan 6
 no ip address
!
interface FastEthernet0/15
 description "x #1 x Control"
 switchport access vlan 6
 switchport mode access
 no ip address
!
interface FastEthernet0/16
 description "x #2 x Control"
 switchport access vlan 6
 switchport mode access
 no ip address
!
interface FastEthernet0/17
 description "x #1 xControl"
 switchport access vlan 6
 switchport mode access
 no ip address
!
interface FastEthernet0/18
 description "b #2 xControl"
 switchport access vlan 6
 switchport mode access
 no ip address
!
interface FastEthernet0/19
 description To_x_SW1_Port16_V38
 switchport access vlan 38
 switchport mode access
 no ip address
 duplex full
 speed 100
!
interface FastEthernet0/20
 description To_x_Router_#2
 switchport access vlan 20
 switchport mode access
 no ip address
!
interface FastEthernet0/21
 description To_x_Internet
 switchport access vlan 100
 switchport mode access
 no ip address
 duplex full
 speed 10
!
interface FastEthernet0/22
 description "Port Damage!!!!!!!!"
 switchport access vlan 7
 switchport mode access
 no ip address
 shutdown
!
interface FastEthernet0/23
 description To_Wireless_Linksys
 switchport access vlan 100
 switchport mode access
 no ip address
 duplex full
 speed 10
!
interface FastEthernet0/24
 switchport access vlan 79
 switchport mode access
 no ip address
!
interface Vlan1
 no ip address
 no ip route-cache
 shutdown
!
interface Vlan6
 ip address 192.168.1.41 255.255.255.0
 no ip route-cache
 shutdown
!
interface Vlan10
 ip address 10.0.0.41 255.255.255.0
 no ip route-cache
!
!
!
line con 0
 password shiron
line vty 0 4
 password shiron
 login local
line vty 5 15
 password shiron
 login local
!
end
0
meirjean
Asked:
meirjean
1 Solution
 
bkepfordCommented:
Since you are running dot1q on the router both switchports need to be trunks not access ports.

Change your switchports to below to fix the problem.

switchport trunk encapsulation dot1q
switchport mode trunk
0
 
meirjeanAuthor Commented:
Thanks
0

Featured Post

Never miss a deadline with monday.com

The revolutionary project management tool is here!   Plan visually with a single glance and make sure your projects get done.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now