Video card in RHEL5

Hi there,

I'm trying to get blender to work on RHEL5, but whenever I try to launch it, I get the following error message:

Compiled with Python version 2.4.3.
Checking for installed Python... got it!
Xlib:  extension "GLX" missing on display ":0.0".
intern/ghost/intern/GHOST_WindowX11.cpp:177: X11 glxChooseVisual() failed for OpenGL, verify working openGL system!
X Error of failed request:  BadWindow (invalid Window parameter)
  Major opcode of failed request:  18 (X_ChangeProperty)
  Resource id in failed request:  0x23b51b90
  Serial number of failed request:  12
  Current serial number in output stream:  13

It seems as though the video card drivers aren't installed, but I can't seem to figure out how to do so. I've downloaded the NVIDIA driver off of Dell's website, RPM'd it but even when scrolling in firefox, it seems to be a bit choppy.

Attached is a copy of the xorg.conf
# Xorg configuration created by system-config-display
 
Section "ServerLayout"
        Identifier     "single head configuration"
        Screen      0  "Screen0" 0 0
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Keyboard0" "CoreKeyboard"
EndSection
 
Section "InputDevice"
 
    # generated from default
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Protocol" "auto"
        Option      "Device" "/dev/input/mice"
        Option      "Emulate3Buttons" "no"
        Option      "ZAxisMapping" "4 5"
EndSection
 
Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option      "XkbModel" "pc105"
        Option      "XkbLayout" "us"
EndSection
 
Section "Monitor"
 
 ### Comment all HorizSync and VertSync values to use DDC:
        Identifier   "Monitor0"
        ModelName    "LCD Panel 1280x1024"
 ### Comment all HorizSync and VertSync values to use DDC:
        HorizSync    31.5 - 64.0
        VertRefresh  56.0 - 65.0
        Option      "dpms"
EndSection
 
Section "Device"
        Identifier  "Videocard0"
        Driver      "nv"
EndSection
 
Section "Screen"
        Identifier "Screen0"
        Device     "Videocard0"
        Monitor    "Monitor0"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Depth     24
                Modes    "1280x1024" "1280x960" "1280x800" "1152x864" "1024x768" "800x600" "640x480"
        EndSubSection
EndSection

Open in new window

LVL 5
bswinnertonAsked:
Who is Participating?
 
kazimurCommented:
An installation is straightforward.
1. Download NVidia driver for Linux from NVidia site. Don't forget set execution attributes on it.
2. Install rpm: kernel-headers and kernel-devel for your version and type of system.
3. Backup your xorg.conf
4. Run the command: init 3
5. Run Nvidia script for installing driver, like: NVIDIA-Linux-x86-180.51.pkg1.run
6. In the end of installation say 'yes' on the question about changing xorg.conf
7. Run the coomand: init 5
0
 
arrkerr1024Commented:
You are using the opensource driver for nvidia, which has really bad performance.  You need to enable the nvidia driver that is actually made by nvidia.  To do that, go to System->Administration->Hardware Drivers and check the box to enable the restricted drivers for your card.

Take a look here for more details:
https://help.ubuntu.com/community/BinaryDriverHowto/Nvidia
0
 
bswinnertonAuthor Commented:
Unfortunately, I'm running Red Hat, how would I do that in that OS?
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.