• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 529
  • Last Modified:

FTP Problem ASA 5505

HI There
I am trying to allow the users on my LAN to access files by FTP in our web space. I have setup my new ASA5505 and all is working fine but I cant get FTP to work. The result of show starup-config is shown below
NRBC-FW01(config)# show startup-config
: Saved
: Written by enable_15 at 14:24:26.166 GMT/BDT Wed Apr 8 2009
!
ASA Version 7.2(4)
!
hostname NRBC-FW01
domain-name default.domain.invalid
enable password ############# encrypted
passwd ############ encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 172.16.30.254 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 84.##.###.42 255.255.255.248
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
clock timezone GMT/BST 0
clock summer-time GMT/BDT recurring last Sun Mar 1:00 last Sun Oct 2:00
dns server-group DefaultDNS
 domain-name default.domain.invalid
object-group network ExchSVR
 network-object host 172.16.30.3
object-group network Inside_subnet
 network-object 172.16.30.0 255.255.255.0
object-group service ExchSVR_services tcp
 port-object eq smtp
 port-object eq pop3
 port-object eq https
access-list outside_access_in extended permit tcp any interface outside object-group ExchSVR_services
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
no failover
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-524.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 172.16.30.0 255.255.255.0
static (inside,outside) tcp interface smtp 172.16.30.3 smtp netmask 255.255.255.255
static (inside,outside) tcp interface pop3 172.16.30.3 pop3 netmask 255.255.255.255
static (inside,outside) tcp interface https 172.16.30.3 https netmask 255.255.255.255
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 84.##.###.41 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
http server enable
http 172.16.30.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
telnet 172.16.30.0 255.255.255.0 inside
telnet timeout 20
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
 
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:####################################
NRBC-FW01(config)#

Open in new window

0
Rob_Smuker
Asked:
Rob_Smuker
1 Solution
 
HotwafflesCommented:
you need to add an acces-list rule and static entry for the ftp port service.

assuming your ftp and exchange server are the same server
from config terminal run this
object-group service ExchSVR_services tcp
 port-object eq ftp

then

static (inside,outside) tcp interface ftp 172.16.30.3 ftp netmask 255.255.255.255

0

Featured Post

The IT Degree for Career Advancement

Earn your B.S. in Network Operations and Security and become a network and IT security expert. This WGU degree program curriculum was designed with tech-savvy, self-motivated students in mind – allowing you to use your technical expertise, to address real-world business problems.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now