• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2551
  • Last Modified:

W32Time. No valid response has been received from manually configured peer

We have a Microsoft Windows Server 2003 environment with 7 Domain Controllers, 2 of them are in our headquarters and the rest in different offices around the world, and everything is interconnected using a MPLS.

I just installed a brand new DC on one of our satellite offices and after restarting I noticed a warning message stating:

Source: W32Time
Event ID: 47
Time Provider NtpClient: No valid response has been received from manually configured peer x.x.x.x. (Where x is a server that is not even part of the domain.

I want all of my DCs to synchronize their time with a headquarters server, so question:

How can I manually configure my new DC to synchronize with a server of my choice?
0
AQNSYS
Asked:
AQNSYS
  • 10
  • 7
  • 5
5 Solutions
 
oBdACommented:
All domain members should sync using the domain hierarchy, that is, domain members sync with the DC authenticating them, DCs with the PDC emulator, and only the PDC should use a manually configured ntp server.
Normally, when you promote a DC, it should just use the domhier; that does'nt have seem to have happened here.
Start with opening a command prompt, and enter these commands:
w32tm /config /syncfromflags:DOMHIER /update
w32tm /resync

If that doesn't help, reset the time service to its default:
net stop w32time
w32tm /unregister
w32tm /register
net start w32time

You can check the sync type by looking at the Type value in HKLM\system\currentcontrolset\services\w32time\parameters; it's NTP for manual NTP, and NT5DS for domain hierarchy.
0
 
Darius GhassemCommented:
All clients and server should be getting their time from your server that is holding the FSMO role holder PDC. For a quick fix run w32tm /resync /rediscover on the server. You can also make the server point to an IP address by double clicking on the time clock then select Internet Time tab type over the current settings like time.windows.com


http://support.microsoft.com/kb/816042
0
 
AQNSYSAuthor Commented:
I just ran the w32tm /resync command, and it ended successfully, how do I know if it worked?
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
oBdACommented:
If /resync didn't throw any errors, it worked ...
You can check the system event log as well for events with the source W32Time; this should tell you which server it's syncing with; if Type is NT5DS, then the time server should be the PDCe.
0
 
Darius GhassemCommented:
I agree with oBdA if resync came back with no errors you should be good.
0
 
AQNSYSAuthor Commented:
These are the parameters in the registry

NtpServer: time.windows.com,0x1
Type: NT5DS
0
 
oBdACommented:
Yes, looks just fine. There should now be an entry in the event log that the server is syncing successfully with the PDCe.
0
 
AQNSYSAuthor Commented:
How can I force a time sync? That would bring up the warning if the problem is still there.
0
 
oBdACommented:
net stop w32time & net start w32time
will definitely force a time sync with a subsequent entry in the event log from source W32Time (event id 35 indicates success).
0
 
AQNSYSAuthor Commented:
Thanx oBdA,
I just did that and I got the W32Time (envet id 35).
0
 
AQNSYSAuthor Commented:
The most extrange thing just happend. It just poped up the original error after the event id 35.

Any ideas?
0
 
oBdACommented:
If the new error has the correct server in it, just let it run for a day; the occasional sync error can be ignored, it's just UDP after all.
0
 
AQNSYSAuthor Commented:
No, the error has the wrong server in it.

A quick summary of the current situation:

After a W32Time restart I have

Source: W32Time

event id: 35 indicating success on a syncronization with the main domain controller (PDCe)

4 minutes later
event id: 47 indicating a problem that it cannot syncronize with some other server that is not even in the domain.

How can I get rid of that "other server" it must be geting that other IP somewhere.

Any ideas?
0
 
oBdACommented:
Check your policies (run a report for the machine in question in the GPMC), you can configure time sync through policies as well, which would override the default settings.
0
 
Darius GhassemCommented:
You can also make the server point to an IP address by double clicking on the time clock then select Internet Time tab type over the current settings like time.windows.com
0
 
AQNSYSAuthor Commented:
dariusq,
I just double click on the time clock (Windows Clock in the lower right corner of the screen you are talking about right?) and I can't find that options.
0
 
AQNSYSAuthor Commented:
OBdA,
How can I "run a report for that machine with GPMC"?
0
 
Darius GhassemCommented:
When you double click the Time you don't see the Internet Time Tab?
0
 
oBdACommented:
No he doesn't, because that tab is removed on domain members.

Enterprise Management with the Group Policy Management Console
http://www.microsoft.com/windowsserver2003/gpmc/default.mspx
0
 
AQNSYSAuthor Commented:
I just found the reason, OdBA was right, the main Domain Controller Policy was set to syncronize with the wrong server.

Thanks for your help.
0
 
AQNSYSAuthor Commented:
Thanx for your accurate anssers OdBA
0
 
Darius GhassemCommented:
Well crap that is right.
0

Featured Post

Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

  • 10
  • 7
  • 5
Tackle projects and never again get stuck behind a technical roadblock.
Join Now