FTP instalation on W2K3 server

I have a client who has requested that we install FTP on one of their W2K3 boxes.  The server already has the application server role installed as the file and print role installed so I go to add remove programs windows components iis and try to install FTP services and it looks like it finishes correctly but then when you check FTP did not install.  I am logged into the server as Administrator and when I go back to check in add remove programs windows components it shows FTP as not installed.  I need to get this service installed for the client.
LVL 2
FallbackpuppetAsked:
Who is Participating?
 
dj_relentlessConnect With a Mentor Commented:
Does this server contain any websites or requirements for iis? You could try removing IIS altogether than putting it back on with ftp selected.
0
 
dj_relentlessCommented:
Do the event logs shed any light during the installation? I take it you're definately not seeing it in the iis console.
0
 
FallbackpuppetAuthor Commented:
.No it is not showing up in the IIS console and no there is nothing showing up in the Logs it is as if I had never made the installation attempt
0
Cloud Class® Course: Certified Penetration Testing

This CPTE Certified Penetration Testing Engineer course covers everything you need to know about becoming a Certified Penetration Testing Engineer. Career Path: Professional roles include Ethical Hackers, Security Consultants, System Administrators, and Chief Security Officers.

 
Vince GlissonOwnerCommented:
Are you logged in as a Local Admin or a Domain Admin...
 
0
 
FallbackpuppetAuthor Commented:
The server is also running WSUS.
0
 
FallbackpuppetAuthor Commented:
I have tried both.
0
 
Vince GlissonConnect With a Mentor OwnerCommented:
Was IIS already installed prior to trying to install the FTP portion?
If not then could you uninstall IIS then reinstall with FTP option?
0
 
Vince GlissonOwnerCommented:
Sorry dj just noticed you had already suggested the same course of action...
0
 
dj_relentlessCommented:
I remember seeing a thread about activating logging for adding / removing programs but I think someone else would have a better idea than that.
0
 
FallbackpuppetAuthor Commented:
Ok I solved this.  I had to uninstal WSUS and IIS then reinstall IIS with FTP and after I had that up and running correctly I then reinstalled WSUS and now everythign is fine.
0
 
FallbackpuppetAuthor Commented:
they were partialy accurate there were more steps
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.