Crystal Reports ActiveX Printing

Hi All,

I'm trying to have my CrystalReportsViewer be able to print in activeX mode for all of my users.  If I'm an admin on the machine I can install the activex component with no issues.  When a user tries to print, they get a blank box with the crystal reports printing.  I've seen some issues where IE has stated that it's a permissions issue, but even setting IE on low permissions I'm not able to install it.

I've tried the resolution here to store the printcontrol cab locally, but that just gets rid of the yellow IE warning box and does not resolve my issue. (https://www.sdn.sap.com/irj/scn/thread?threadID=1080708)

How do I install this so that it's enabled for all users?  Anyone get this working before for a normal user?

LVL 41
Kyle AbrahamsSenior .Net DeveloperAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
Kyle AbrahamsConnect With a Mentor Senior .Net DeveloperAuthor Commented:
Finally found out what was going on.  I'm going to try to be as detailed as possible as there's not a lot of documentation on any of this.

After various poking around, I noticed the CAB version on the server was off compared to what I had on my local.  

The way you tell cab version for you local for CR 2008:

%install dir%\Business Objects\Common\4.0\crystalreportviewers12\ActiveXControls\printcontrol.cab
(the cab file is just a zip file)

Inside find printcontrol.inf.  Under [printcontrol.dll] find fileversion.

My current file version of of this date is 12,0,0,683.


For the server:
open "%windir%\Downloaded Program Files"
you should see a reference to crystal reports and windows will give you the version by default.

After updating the CAB, we were able to install it as administrator, then a normal user could run the active X without an issue.  If you click on the properties of that object, you can see the path where it's coming from.  (mine was http://Myserver/aspnet_client/crystal12/...)

In order to make this easier for deployment, I have attached a zip file with the necessary dll,s and registry files so that an administrator can just put this on a server, type it a password, and leave.  (or call via Active Directory or what not).

Essentially all you need to do is modify install.bat with path and credentials, and the rest is handled by install2.bat

I've also included a copy of the current cab which is working for me in case anyone else needs access to it.








0
 
mlmccCommented:
It isn't an IE install permissions it is a Windows install permissions.  Probably need ADMIN permissions to install.

I haven't used that method so I don't know but you should be able to install it on a box and allow all users to use it.

mlmcc
0
 
Kyle AbrahamsSenior .Net DeveloperAuthor Commented:
Even if I install as admin . . . a normal user can't access it after it has been installed.  
0
Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

 
wykabryanCommented:
You could try the following.

Right click on the internet explorer icon, go to the properties. Next go to the advance tab. Click the Reset button. Sometime the application just get hung and a little reset clears it right up.
0
 
mlmccCommented:
After installing as an Admin do you change the permissions on the dll?

mlmcc
0
 
Kyle AbrahamsSenior .Net DeveloperAuthor Commented:
wykabryan:  Tried that already.  Reset it to low and made sure all was enabled.  I think this is giving a cryptic error message (specifically: "your security setting do not allow websites to use ActiveX control installed on your computer. This page may not display correctly")

Have googled the error message and tried a number of things but still no luck.


mlmcc:  where can I find the DLL for this?  
0
 
mlmccCommented:
Check the CR Developer help.

I don't know what one it is.

mlmcc
0
 
Kyle AbrahamsSenior .Net DeveloperAuthor Commented:
it's the printcontrol.dll . . . but when it gets installed on the local machine where does it put the file?  I did a search but couldn't find it?
0
 
mlmccCommented:
I don't know.  I don't have a web server to test from.

I would expect it to be in SYSTEM32 or a web folder.
It is probably marked as hidden or system so you may have turn on the display of hidden and system files

mlmcc
0
 
Kyle AbrahamsSenior .Net DeveloperAuthor Commented:
I was able to find the DLL.  Permissioned it but still no luck.  Same error about activeX.  

0
 
mlmccCommented:
0
 
Kyle AbrahamsSenior .Net DeveloperAuthor Commented:
Already tried adding that to my web.config.  If I do that I still get the blank box, however I don't get prompted for the activeX install.  Is there anything in the GPO that could be preventing the activeX install?
0
 
mlmccCommented:
Could be.

I am not a Windows admin expert.

mlmcc
0
 
mlloyd103Commented:
Hi,
I have the same exact problem in my environment.  I'm looking for the attached zip file mentioned in the solution.

Thank you!
0
 
Kyle AbrahamsSenior .Net DeveloperAuthor Commented:
I'm trying to upload the file but not sure if EE cleans it up.

The file can be found on my website:
www.keasolutions.com/printcontrol.zip

Modify install.bat for the server share you intend to install from (should be read only to all users).

Note: users will need administrative privileges to install.  In our environment this wasn't possible so we ran under a domain account via install and then support people just needed to type in the password for the account.  otherwise just take the runas portion of the command out.
0
 
hossam_loginCommented:
Please could you tell me in more details as I am trying to print through activeX print mode in a local network but till now i coudn't work this out, by the way %intsall dir% is not working

I want to install activeX for crystal report on the local client computers and I have all the ADMIN priviliges on the server and the clients also, please help me in this as i searched alot and reached nothing
Thank you  
0
All Courses

From novice to tech pro — start learning today.