[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

Linux problem Pls help

Posted on 2009-04-22
12
Medium Priority
?
564 Views
Last Modified: 2012-05-06
i wanted to discuss an RHCE question with you Guys
 
Bind to the NIS domain
RHCE provided by 172.24.254.254 for user authentication. Note the following:
{
nisuserx should be able to log into your system, where x is your station number, but will not have
a home directory until you have completed the
autofs requirement below
{
All NIS users have a password of password
Con gure autofs to automount the home directories of NIS users. Note the following:
{
server1.example.com (172.24.254.254) NFS-exports /rhome/stationx to your system, where
x
is your station number
{
nisuserx's home directory is server1.example.com:/rhome/stationx/nisuserx
{
nisuserx's home directory should be automounted locally beneath /rhome as /rhome/nisuserx
{
home directories must be writable by their users
{
While you are able to log in as any of the users nisuser1 through nisuser20, the only home
directory that is accessible from your system is nisuser
x.
Example:
station100 would con gure the automounter such that nisuser100's home directory
/rhome/nisuser100
gets mounted automatically upon login. The NFS share would be
server1.example.com:/rhome/station100/nisuser100
.
 
I changed the NIS setup to LDAP and all users can login succesfully on client side...but accroding to this question the users home dir shold be loaded to /rhome/station15/nisuser15 ...HOW?by default all users dir is made under /home


but even after working autofs on client side user nisuser15 cant login and it doesnt give me ANY error i ran migrate_commaon_offline.sh and restarted ldap service on server too still result r same i wonder how this clients can login to /rhome/station15/nisuser15 when default is /home for home dir on server ...nd even after changing /etc/default/useradd   /home=/rhome/station15 and running whole process again results r same

Help me pls
Thanks
0
Comment
Question by:mast007
  • 4
  • 3
  • 2
  • +2
11 Comments
 
LVL 13

Expert Comment

by:WizRd-Linux
ID: 24210031
I don't remember the exact answer to this, but you need to use autofs to mount anything under /home/station100/*, this includes the directory that matches the username.

Basically the directory /home/station100/ should be empty until a user logs in.  Knowing that their directory exists they can easily access it, otherwise it will be empty.

I believe a good starting point should be : http://kbase.redhat.com/faq/docs/DOC-9586;jsessionid=5EE19DB1A6EF5E63FF5A20398789D499.ab46478d
0
 

Author Comment

by:mast007
ID: 24210135
may be u didnt read the question completely the question demands /rhome/station15/nisuse15 /home dir is succesfully loading via nfs and users can login via ldap easily thing is this WEIRED path /rhome/stationx

i hope u got me now properly
0
 
LVL 62

Expert Comment

by:gheist
ID: 24218014
Try looking inside logs.
0
Efficient way to get backups off site to Azure

This user guide provides instructions on how to deploy and configure both a StoneFly Scale Out NAS Enterprise Cloud Drive virtual machine and Veeam Cloud Connect in the Microsoft Azure Cloud.

 
LVL 81

Expert Comment

by:arnold
ID: 24226451
Do you have an autofs auto.home map setup in NIS?
The question wants an on-deman mount of the /rhome/ such that the directory will be mounted only when the user logs in.
Not sure whether autofs can be configured with variables that reference the logged in username.
0
 

Author Comment

by:mast007
ID: 24233563
@arnold
may be u didnt read the question completely the question demands /rhome/station15/nisuse15
 /home/nisuser15 dir is succesfully loading via nfs and autofs and users can login via ldap easily thing is this WEIRED path /rhome/stationx

i hope that you  understand me now properly :-)
 Thanks and Regards
0
 

Author Comment

by:mast007
ID: 24233574
one more thing if the server having /rhome dir as its users /home dir then only on client side i can mount it right?
 
 
but how rhome can be home dir i used -d option for adding new users still it didnt work
0
 
LVL 62

Expert Comment

by:gheist
ID: 24233579
You mention RHCE - best you can get is pointers for learning, nobody will solve your excersises...
0
 

Accepted Solution

by:
mast007 earned 0 total points
ID: 24236243
MR GhEIST i came here to to get help like many does DONT BE a PREACHEr.......WhAcK...
0
 
LVL 62

Expert Comment

by:gheist
ID: 24236287
Praise you, owner of last NIS domain in the world. Rest is on Kerberos anyway....
0
 
LVL 81

Expert Comment

by:arnold
ID: 24238278
If you want people to help you, you should act accordingly.

It seems that you do not realize what the exercise is designed to do.
The exercise is designed to make available a remote home /rhome/ mapping that is handled through a NIS map for autofs auto.home that differs from one user to another.  This type of mapping limits the nisuserx from accessing nisusery's home dir since it is not accessible while a /home/ based mapping mounts all the users' home dirs and only the permissions on the /home/username determines whether the user can view the files listing, access the files, etc.

The user's home dir in the NIS user map has to reflect /rhome/nisuserx.
auto.home either in NIS or locally on each workstation has to be setup such that autofs mounts the requisite folder.

You should reread the assignment and write out the logic to get nisuserx setup and be able to login into a system with the specified home dir.
0
 

Expert Comment

by:surfing4ever
ID: 24992392
try it please...

your machine is 192.168.1.11
your  NIS server  192.168.1.254

in /etc/auto.master

/rhome/station11   /etc/auto.home  --timeout=50

in /etc/auto.home

*    -rw,soft,intr    192.168.1.254:/rhome/station11/&

service autofs restart

please try it  and waiting for your comments

0

Featured Post

NFR key for Veeam Backup for Microsoft Office 365

Veeam is happy to provide a free NFR license (for 1 year, up to 10 users). This license allows for the non‑production use of Veeam Backup for Microsoft Office 365 in your home lab without any feature limitations.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

FreeBSD on EC2 FreeBSD (https://www.freebsd.org) is a robust Unix-like operating system that has been around for many years. FreeBSD is available on Amazon EC2 through Amazon Machine Images (AMIs) provided by FreeBSD developer and security office…
I. Introduction There's an interesting discussion going on now in an Experts Exchange Group — Attachments with no extension (http://www.experts-exchange.com/discussions/210281/Attachments-with-no-extension.html). This reminded me of questions tha…
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:
This video shows how to set up a shell script to accept a positional parameter when called, pass that to a SQL script, accept the output from the statement back and then manipulate it in the Shell.
Suggested Courses
Course of the Month20 days, 2 hours left to enroll

873 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question