How to work around missing AAAA (ipv6) record in Exchange 2007

I have a client running Red Hat Enterprise Linux v4 for web and email services. Their accountants have just implemented Exchange 2007 on Windows Server 2008, and have ipv6 enabled.

My client can send the accountants emails without issue. Unfortunately, when the accountantd send a message to my client, DNS resolution fails in ipv6, but does NOT fall back to ipv4. The accountants' tech guy says:

> > It seems our server can ping enterprise.xxx.net.au,
> >
> > However when I do a wireshark capture and send an e-mail the DNS resolve seems to fail.
> >
> > I think this is because your server is responding Server Failure for your AAAA (IpV6)
> > record, and as we are using exchange 2007 and Server 2008, ipv6 name resolution is
> > supported and enabled by default - and because it is returning failure instead of missing
> > record,  exchange doesn't move on to ipV4 (while windows does).

Our DNS is handled by PlanetDomain, with only provides ipv4, so my guess is that something needs to be done by the accountants on Windows 2008 and/or Exchange 2007 to allow them to send out emails to my client's server. Alternatively, perhaps we need to make a change at the RHEL end.

Has anybody got any suggestions as to what to try?

Thanks.
davidiwharperAsked:
Who is Participating?
 
Chris DentConnect With a Mentor PowerShell DeveloperCommented:

It's discussed here under "5.  Operational Experience":

http://www.ietf.org/rfc/rfc3974.txt

They're right that the DNS server shouldn't return SERVFAIL, however... If you don't manage the DNS service yourself then there might not be a great deal you can do about it.

You might raise it with PlanetDomain and see what they say.

In the meantime the sender could do any of...

1. Disable IPv6 (shouldn't have to, but...)
2. Create a Send Connector for your domain, directing mail at your mail servers, bypassing the MX lookup
3. Create a fake version of your domain internally with correct MX records on a DNS server that does support IPv6

Chris
0
 
davidiwharperAuthor Commented:
This could well be a problem with RHEL 4. I had the accountants send another client a test message. The other client is running Windows SBS 2003, also with PlanetDomain and ipv4 only.

From memory, the RHEL server is running TinyDNS, not BIND.
0
 
Chris DentPowerShell DeveloperCommented:

Why can't they just disable IPv6? It's not like it's a requirement (for either Windows or Exchange), and if the infrastructure doesn't support that it's far more of a hindrance than an advantage.

Chris
0
 
davidiwharperAuthor Commented:
Thanks for the input. They don't want to disable IPv6 at all. Given the small size of the organisation, IPv6 is (IMHO) just a toy right now... but try telling them that.
0
 
davidiwharperAuthor Commented:
Thank you, the Send Connector worked a charm.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.