Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
?
Solved

HACMP 4.5 Failover test is failing

Posted on 2009-04-22
6
Medium Priority
?
779 Views
Last Modified: 2013-11-17
Hi experts.
a)HACMP verstion 4.5 .        b)AIX 5.3         c)Two node cluster.
1) we have HACMP version 4.5 two node cluster, when performing failover test, then RG moves to another node, but the application (Oracle application ) is not starting. Experts what will be the cause, Y the application is not starting? Where i m going wrong.

thanks in adv

siva



 
0
Comment
Question by:Maddy
  • 3
  • 3
6 Comments
 
LVL 68

Accepted Solution

by:
woolmilkporc earned 1500 total points
ID: 24212661
Now this one, sivaji,
1) do you really mean HACMP 4.5? Not 5.4?
2) your problem seems to be related to start/stop scripts. Are they correctly defined within the application server definition? Do they exist on both nodes, in exactly the same path with exactly the same content?
Please post details, e.g. the output of '/usr/es/sbin/cluster/utilities/clshowres' and '/usr/es/sbin/cluster/utilities/cldisp'
wmp

0
 

Author Comment

by:Maddy
ID: 24232529
hi sir the scripts and path all r exactly defined. sir can u tel me when RG moving one node to another node ,what action will take place in the back ground. sir then i what to b expert like u in HACMP , what books i wat to read and how can archive my dreams :-)

Your student

sivaji
0
 
LVL 68

Assisted Solution

by:woolmilkporc
woolmilkporc earned 1500 total points
ID: 24240440
OK sivaji,
what happens during resource group migration?

Although this is a rather complicated process, the basics are simple.
-> Note that processing not necessarily takes place exactly in the sequence I write it down below!

The cluster manager on the releasing node -
- brings the resource group's application down by running the configured stop script(s).
- removes the service IP address(es) from the affected interface(s)
- unmounts the configured file systems
- varies the affected volume group(s) offline (and back on in passive-only mode if enhanced-concurrent)

- The cluster manager on the receiving node (which has already been notified about what's going on) -
- varies the affected volume group(s) offline (if enhanced-concurrent) and varies it back on in active mode
- mounts the resource group's filesystems
- activates the service IP address(es) on the designated interface(s)
- brings the resource group's application up by running the configured start script(s).

All the above is accompanied by lots of messages sent between the two nodes.
There are much more things that happen "behind the scene",
let alone things like application dependencies, user-defined events and so on.

HTH for a first insight, to learn more please look here:

http://www.redbooks.ibm.com/cgi-bin/searchsite.cgi?query=hacmp 
http://publib.boulder.ibm.com/infocenter/systems/topic/com.ibm.aix.doc/doc/base/hacmp.htm?tocNode=toc:front/front.cmb/0/0/16/ 

What about your original problem (application not starting)?
Could you solve it?

Cheers

wmp
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:Maddy
ID: 24249373
Hi sir good morning ,

Not yet solved sir , we come to know that the problem in JAVA version one node has lower version and one more node has higher version. we said application team to check the same still waiting for response.

0
 
LVL 68

Expert Comment

by:woolmilkporc
ID: 24290103
Hi sivaji,
thanks for the points, but why grade B?
If what I said in my comments was wrong/not enough you could have notified me, so I would have been able to correct/improve it.

Cheers

wmp
 

0
 

Author Comment

by:Maddy
ID: 24290383
Hi sir,
sorry for that .
:-)

sivajiiii.

0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This tech tip describes how to install the Solaris Operating System from a tape backup that was created using the Solaris flash archive utility. I have used this procedure on the Solaris 8 and 9 OS, and it shoudl also work well on the Solaris 10 rel…
I promised to write further about my project, and here I am.  First, I needed to setup the Primary Server.  You can read how in this article: Setup FreeBSD Server with full HDD encryption (http://www.experts-exchange.com/OS/Unix/BSD/FreeBSD/A_3660-S…
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…
Suggested Courses

578 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question