• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 592
  • Last Modified:

network trouble in Solaris 10

Hi.
I've tried to setup my solaris 10 using three ipaddresses.
the first two is on the 192.168.204.x net with subnet 255.255.255.0 with 192.168.204.1 as gateway

the third one is on 10.174.1.x with subnet 255.255.255.0 and 10.174.1.1 as gateway.

From the solaris everything seams to work as expected. I can ping both 192.168.204.1 and 10.174.1.1.

But from the net 192.168.204.x the connection seams unstable.
Somtimes I can access the solaris using ssh, other times not. And the ssh client looses contact after a short time. But there is no consistens.

Any ideas?
pasted
netstat -rn
and
ifconfig -a
in the code window
bash-3.00# netstat -rn
 
Routing Table: IPv4
  Destination           Gateway           Flags  Ref     Use     Interface 
-------------------- -------------------- ----- ----- ---------- --------- 
default              192.168.204.1        UG        1          3           
default              10.174.1.1           UG        1          4           
10.174.1.0           10.174.1.2           U         1          2 bge2      
192.168.204.0        192.168.204.30       U         1          2 bge0      
192.168.204.0        192.168.204.31       U         1          0 bge1      
224.0.0.0            192.168.204.30       U         1          0 bge0      
127.0.0.1            127.0.0.1            UH        4        125 lo0       
bash-3.00# ifconfig -a
lo0: flags=2001000849<UP,LOOPBACK,RUNNING,MULTICAST,IPv4,VIRTUAL> mtu 8232 index 1
        inet 127.0.0.1 netmask ff000000 
bge0: flags=1000843<UP,BROADCAST,RUNNING,MULTICAST,IPv4> mtu 1500 index 2
        inet 192.168.204.30 netmask ffffff00 broadcast 192.168.204.255
        ether 0:14:4f:2d:3b:d0 
bge1: flags=1000843<UP,BROADCAST,RUNNING,MULTICAST,IPv4> mtu 1500 index 3
        inet 192.168.204.31 netmask ffffff00 broadcast 192.168.204.255
        ether 0:14:4f:2d:3b:d1 
bge2: flags=1000843<UP,BROADCAST,RUNNING,MULTICAST,IPv4> mtu 1500 index 4
        inet 10.174.1.2 netmask ffffff00 broadcast 10.174.1.255
        ether 0:14:4f:2d:3b:d2 
bash-3.00#

Open in new window

0
kristian_gr
Asked:
kristian_gr
  • 5
  • 4
  • 2
  • +1
8 Solutions
 
omarfaridCommented:
why do you have to give two ips from same network?
0
 
kristian_grAuthor Commented:
I will install several zones on this server, I like to have one for the zones, and one for the global. But if you think this might bee the problem, I'll remove it?
0
 
omarfaridCommented:
can you bring it down and see if you get the same behavior?
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
kristian_grAuthor Commented:
bash-3.00# ifconfig bge1 unplumb
bash-3.00# ping 192.168.204.1
192.168.204.1 is alive

bash-3.00# ifconfig -a
lo0: flags=2001000849<UP,LOOPBACK,RUNNING,MULTICAST,IPv4,VIRTUAL> mtu 8232 index 1
        inet 127.0.0.1 netmask ff000000
bge0: flags=1000843<UP,BROADCAST,RUNNING,MULTICAST,IPv4> mtu 1500 index 2
        inet 192.168.204.30 netmask ffffff00 broadcast 192.168.204.255
        ether 0:14:4f:2d:3b:d0
bge2: flags=1000843<UP,BROADCAST,RUNNING,MULTICAST,IPv4> mtu 1500 index 4
        inet 10.174.1.2 netmask ffffff00 broadcast 10.174.1.255
        ether 0:14:4f:2d:3b:d2
bash-3.00#

but at the moment no response from ping / ssh 192.168.204.30
0
 
omarfaridCommented:
can you clear the arp table from the other systems and then try again?
0
 
kristian_grAuthor Commented:
a reeboot of my client should have cleared the arp.
Still no connection.

but if i do
bash-3.00# ifconfig bge2 unplumb

everything seams to work as expected.
0
 
omarfaridCommented:
when you say

"but at the moment no response from ping / ssh 192.168.204.30"

from where are you trying to ping / ssh?
0
 
Brian UtterbackPrinciple Software EngineerCommented:
In general, Solaris does not support having multiple interfaces on the same subnet, unless you are using IPMP or exclusive IP
zones.

You usually assign virtual IP addresses to Zones, so that multiple IP addresses are used on a single interface. If you want to
have separate interfaces for a zones, then you can use the xclusive IP option, which will instruct the kernel to maintain entirely
separate IP/network stacks for the interfaces. However, in that case, you can only assign one zone to an interface. You can mix and match those, having two zones with their own interfaces, and more zones that share their IP addresses with an interface in the global zone. But you cannot do what you are doing, having two interfaces on the same subnet.
0
 
kristian_grAuthor Commented:
ok. Thanks for the uppdate.
I've done a sys-unconfig, and reconfigured the network. I now only have one interface on each subnet.
But I still can't connect to 192.168.204.30.

bash-3.00# ifconfig -a
lo0: flags=2001000849<UP,LOOPBACK,RUNNING,MULTICAST,IPv4,VIRTUAL> mtu 8232 index 1
        inet 127.0.0.1 netmask ff000000
bge0: flags=201000843<UP,BROADCAST,RUNNING,MULTICAST,IPv4,CoS> mtu 1500 index 2
        inet 192.168.204.30 netmask ffffff00 broadcast 192.168.204.255
        ether 0:14:4f:2d:3b:d0
bge2: flags=201000843<UP,BROADCAST,RUNNING,MULTICAST,IPv4,CoS> mtu 1500 index 4
        inet 10.174.1.2 netmask ffffff00 broadcast 10.174.1.255
        ether 0:14:4f:2d:3b:d2
bash-3.00# netstat -rn

Routing Table: IPv4
  Destination           Gateway           Flags  Ref     Use     Interface
-------------------- -------------------- ----- ----- ---------- ---------
default              192.168.204.1        UG        1          0          
default              10.174.1.1           UG        1          1          
10.174.1.0           10.174.1.2           U         1          1 bge2      
192.168.204.0        192.168.204.30       U         1          1 bge0      
224.0.0.0            192.168.204.30       U         1          0 bge0      
127.0.0.1            127.0.0.1            UH        4        127 lo0      
bash-3.00#

If I do
bash-3.00# ifconfig bge2 unplumb

I can connect. But I can't use 10.174.1.x
0
 
nyaarCommented:
I had some similar issue configuring zones, and I think it was all because of the use of several default gateways.
 We changed our zone configuration, and we gave the interfaces to the zones instead to the global zone, and now it all runs smooth because the own zone is controlling its default gateway.

Plus, I recommend you putting the local-mac-address to true.

Hope this helps.
0
 
kristian_grAuthor Commented:
Plus, I recommend you putting the local-mac-address to true??

This is new to me. Care to explain?
0
 
Brian UtterbackPrinciple Software EngineerCommented:
By default, Sun systems use the same ethernet address on all the interfaces. If you set local-mac-address to true, then it does not do this, instead using the native ethernet address of the interface. Not all Sun manufactured interfaces have ethernet addresses pre-assigned however. All the newer ones do, bge included.

Since your interfaces are showing as different ethernet addresses in the ifconfig output, I think you already have it set. Or perhaps the system is smarter these days about assigning ethernet addresses. In any case, they are different, so don't worry about it.
0
 
nyaarCommented:
Ops. I was in a bit of hurry when I posted, and didn't realized that they are already different=) but blu explained it perfectly. I had issues with a global zones with six different lans with the local_mac_address=false,  (I think it was a issue with the switches), and that's why I suggested it =)
0

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 5
  • 4
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now