• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2029
  • Last Modified:

Exchange 2007 OAB problem

I keep getting Sync errors in outlook regarding the OWA:

Not downloading Offline address book files.  A server (URL) could not be located.
0X8004010F

In the Exchange console I have an OAB setup and pointing to a web based virtual directory called OAB(Default Web Site).  When I go into IIS 7 and look at the default web site there is no item called OAB, do I need to add one manually?  If so, how come Exchange can 'see' this virtual directory?  

When I try to use a browser to query the oab.xml I get the following error:


HTTP error 404.0 not found
The resource you are looking for has been removed, had its name changed, or is temporarily unavailable.

Error code 0x80070002
0
-Juddy-
Asked:
-Juddy-
1 Solution
 
madhuskCommented:
I have the sam issue with you,but only for outlook 2007.

After I references Exchange 2007 Offline Address Book Web Distribution know outlook 2007 need autodiscover Service Connecion Point(SCP),so I create Autodiscover A record in my AD DNS and point to my Exchange 2007 CAS IP.Later,no error anymore in my outlook 2007 OAB sync 0x8004010.

Note:Before Autodiscover service can successfully runing,you need config you CAS to use Certificate.For more information please see

http://technet.microsoft.com/en-us/library/aa995942.aspx
0
 
MesthaCommented:
If the OAB virtual directory is missing then you need to recreate it.
http://technet.microsoft.com/en-us/library/bb123735.aspx

However it should be there, manual creation should not be required.

Simon.
0
 
-Juddy-Author Commented:
Right, here's the state of play.  I have recreated my OAB and my virtual directory, and I am now getting the following error in my Outlook Sync Errors folder:

14:09:59 Microsoft Exchange offline address book
14:09:59              Not downloading Offline address book files.  A server (URL) could not be located.
14:09:59       0X8004010F

On my Exchange / IIS server I gave a shared ExchnageOAB folder which contains lots of LZX files (?) and an oab.xml.  What steps do I need to take to rectify this problem please guys?
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
MesthaCommented:
Ensure that you have the correct URL set on the OAB configuration in EMC.
Under Server Config, Client Access, OAB, it needs to be in the format of

https://host.example.com/OAB

And that URL needs to resolve internally.

Simon.
0
 
ikshf143Commented:
Go to IIS and expand OAB Virtual Directory and see if you can find a folder which would named as a GUID value.

If yes Proceed to step 2 if no Follow Step 1 and then Step 2

1. As you have recreated the OAB Virtual Directory check for the web dribution if it is enabled if yes check if we have the OAB (Default Web Site) selected for the Exchange CAS server. Restart the MSExchange File Distribution service and Background Intelligent Transfer Service and then check if the GUID is created under the OAB Virtual Directory in IIS.

2. Run the command Get-OABVirtualDirectory | FL and looked for an attribute InternalURL. Make sure this is the same as the issued to name on the Certificate. If that is not the case then follow Microsoft KB article http://support.microsoft.com/kb/940726/
0
 
-Juddy-Author Commented:
That was it, my URL was poinging at http:// not https://
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: MCSA MCSE Windows Server 2012

This course teaches how to install and configure Windows Server 2012 R2.  It is the first step on your path to becoming a Microsoft Certified Solutions Expert (MCSE).

Tackle projects and never again get stuck behind a technical roadblock.
Join Now