• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2450
  • Last Modified:

Opening port 1521

Greetings!

The background is that I am trying to get my Oracle Thin Client to work. However my question is based on a friend's suggestion as to why it doesn't work - He suggested that port 1521 is being blocked.  My question is how to open the port.

My laptop is connected to the company network which is connected to the Internet using a sweex AnnexA Router.

As a novice in Routers, I would be much appreciative of some help.

This is what I did so far.
1. I turned off all firewalls on my computer.

2. I went to http://www.yougetsignal.com/tools/open-ports/ and checked port 1521.
It said that the port was closed.

3. I then went to my router and added port 1521. See attached screenshot. I restarted router.

4. Again yougetsignal said the port was closed.

5. I then downloaded Port Forwarding Wizard. See attached screenshot.

6. Again yougetsignal said the port was closed.

7. I telephoned my ISP who said that they did not close the port.

Now I am a little stuck.  It could be that yougetsignal doesn't always work, and really the port is open. Or that I have put some settings in wrongly to the Router....



sweex.jpg
portforwarding.jpg
0
gordontm
Asked:
gordontm
  • 8
  • 6
2 Solutions
 
louislietaerCommented:
Hello,

Wich os is runnig on your laptop. If it is windows xp vista there is a integrated firewall.

So you have to open the port on windows
0
 
gordontmAuthor Commented:
Hello
It is Windows XP Vista 64 Home Premium. However I shut down the firewall.
What do you mean by open the port on windows?

0
 
TheVeeeCommented:
Ok so let me follow this, your client is trying to connect to third party vendor oracle database and your not the network?

You may have your port open, but they may not have you defined to their system so they our not letting you log on.  I doubt if its a oracle application, that the ports blocked on their end.

Try going to your dos command and doing a couple things...
1.  First Ping the server ip address to see if it fails or is not recognized.
2.  Next if 1 does fail, then do a tractert on the ip address again.

For tracert you may have to download it....

Then tell me your results, thanks
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
gordontmAuthor Commented:
ping failed.
I attach the traceroute.

traceroute2
0
 
gordontmAuthor Commented:
I will now add more information about what I am trying to do.

1.      I am using Thin Client: Oracle OC4J Standalone Server 10.1.3.n on my laptop
2.      I connect to Oracle Database 9.2.0.1.0 which is installed on our server (in another city)
3.      My laptop has Windows Vista Home Premium 64 bit. I am using Eclipse.
4.    The setup was working very well until a few weeks ago. My (ex-)colleague uses the same system (from a different city) and he had no problems even after mine stopped working.

Upon attempting to start the Thin Client, the console gets to "09/04/22 13:34:17 Oracle Containers for J2EE 10g (10.1.3.4.0)  initialized" and then times out.

I was told that it was probably a problem with the port 1521.  I did ask the full question in Experts Exchange under Oracle, but no one replied at all! so I was re-asking part of the question in the Routers section.
0
 
TheVeeeCommented:
ok your defining my system to a T.  Im developing using eclipse using the OracleOC4J standalone server so thats a good thing....

Ok the ping didnt hit the ip server.  Im taking it you didnt put the port on the back.... correct?

so you should have done PING xxx.xxxx.xxxx.xxxx

If you cant ping the server, then its not about the port, its about the server itself.  You must be able to ping the server first, then once that successful, then we have a start.   Get that going first... If your trying the DSN entry vice the actual ip address, switch to the ip address on the ping.. you alias may not be set up for dsn alais.. so just do the ip address.  My email id down this morning so will check back in periodically on results...
0
 
TheVeeeCommented:
ONce you get that going , then ensure your data-source.xml located under the OC4J-1013/j2ee/home/config directory has your production entry Example below:

<?xml version = '1.0' encoding = 'UTF-8'?>
<data-sources xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="http://xmlns.oracle.com/oracleas/schema/data-sources-10_1.xsd" schema-major-version="10" schema-minor-version="1">
   <managed-data-source connection-pool-name="Example Connection Pool" jndi-name="jdbc/OracleDS" name="OracleDS"/>
   <managed-data-source connection-pool-name="XXXX Pool-PROD" jndi-name="jdbc/DTMSDS" name="DTMSDS"/>
   <connection-pool name="Example Connection Pool">
      <connection-factory factory-class="oracle.jdbc.pool.OracleDataSource" user="scott" password="tiger" url="jdbc:oracle:thin:@//localhost:1521/ORCL" commit-record-table-name=""/>
   </connection-pool>
   <connection-pool name="XXXX Pool-PROD">
      <connection-factory factory-class="oracle.jdbc.pool.OracleDataSource" user="XXXX_app" password="XXXXXXXXX" url="jdbc:oracle:thin:@XXX.XXX.XX.XX:1521:XXXXXX"/>
   </connection-pool>
</data-sources>

Also load try connecting with a 3rd party tool like TOAD or AQT and hitting the server and port.  This way its nothing related to the oracle container setup...
0
 
gordontmAuthor Commented:
OK. Thanks for your detailed replies. Interesting you have the same set-up

1. Although ping fails, I can connect to the server where the database is using Remote Desktop. I assume that the port for ping is blocked by the firewall on the server, but not the port for Remote Desktop [or the port for Oracle for that matter, because as I mentioned my ex-colleague had no problem]

2. I did do ping XXXX.XX.XX.XXX
[I didn't know you could add the port]

3. This is my data-sources file.  It looks pretty similar to yours...

<?xml version="1.0" standalone='yes'?>

<data-sources
  xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
  xsi:noNamespaceSchemaLocation="http://xmlns.oracle.com/oracleas/schema/data-sources-10_1.xsd"
  schema-major-version="10"
  schema-minor-version="1"
>

      <data-source
              class="com.evermind.sql.DriverManagerDataSource"
              name="OracleDS"
              location="jdbc/OracleCoreDS"
              xa-location="jdbc/xa/OracleXADS"
              ejb-location="jdbc/OracleDS"
              pooled-location="jdbc/CharmPoolDS"
              connection-driver="oracle.jdbc.driver.OracleDriver"
              max-connection="45"
            min-connection="15"
            username="XXXX"
            password="XXXX"
            url="jdbc:oracle:thin:@XXXX.XXXX.XXXX.XXXX:1521:XXXX"
            inactivity-timeout="30"
       />
      
</data-sources>


0
 
TheVeeeCommented:
Yeh the reason I said to use TOAD or AQT, is they will connect to oracle.  Also you just do a odbc entry under you admin on you desktop and just test it.  Thinking you will need to load the odbc driver to do this.

This way we know you oracle setup is correct.  
0
 
gordontmAuthor Commented:
I went to Administrative Tools/Data Sources(ODBC) but I do not have an ODBC driver for Oracle installed or a possibility for installing it.

I wasn't quite sure whether you meant that Toad needed an ODBC driver or not, but I could not get it to work anyway.  See attached picture.  I feel though that trying to get Toad to work is a can of worms...


toad.jpg
0
 
TheVeeeCommented:
Sorry our email is down and been swamped.   Yeh you will need a odbc driver and if your not the admin this will be fruitless.  I would get with your network guy to find out why you cant ping that server... you machine first needs to be able to locate it before any software will work
0
 
gordontmAuthor Commented:
Thanks for your advice TheVeee.  I will let you know if anything transpires....
0
 
gordontmAuthor Commented:
Solved it!

The problem was in the C:\windows\system32\drivers\etc\hosts file
I needed the line 127.0.0.1 localhost in the hosts file

Apparently  according to http://www.wampserver.com/phorum/read.php?2,50860  this was changed by a Windows Update

Now it works great.
0
 
gordontmAuthor Commented:
Thank you very much TheVeee for all your time you invested trying to help me fix the problem
0
 
TheVeeeCommented:
Dang forget all about that one...been awhile since had to mess with that one...least you got it going! Have a great day!
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

  • 8
  • 6
Tackle projects and never again get stuck behind a technical roadblock.
Join Now