AD backup and restore

Posted on 2009-04-23
Last Modified: 2012-05-06
I am currently involved in doing backup restore/verifications on HP G5 servers with LTO tape drives with symantec 12 backup and have done over 50 now with almost no problems , I am using a local server to do the restores which is an exact replica of all the other servers that I am checking. once I collect the tape I do a restore firstly by doing inventory,catalog then restore , I am doing everything as I normally do but for some reason this one job will not restore, see the attached screenshot of the error , on this occassion I noticed that the ntds.dit file and logs did not restore so I managed to get a backup of those files and applied them to the restore |I was busy with buit still couldn't get it to work , The one odd thing I have noticed is that when I go to log in after doing a restore I normally have to use our admin login but it only accepts my own login which is not supposed to work once Ive done a restore , also sql server does not work , I have tried several tapes from this server in case it was a bad backup tape but all come back the same and I have remoted on to the original server to check that the backup had ran ok the night before, all checks out ok there.

After doing my tape /inventory/catalogue/restore
authoritative restore
restore database

Like I say I have done many of these restores now with 99% success however this one job has now stretched my brain cells to its limits and I need some assistance to help me figure this one out, much appreciated if you can help,

Question by:AynsleyPaterson
    LVL 23

    Expert Comment


    you have not mentioned the version of windows and if this is the only DC or if there are other DCs in the environment.

    check this post which will try to let you retrospect what you have been missing.

    one thing that i wanted to verify is if you have already restored the system state or have restored the system state to alternate location and tried applied the ntds.dit file.

    as for the logon unless you reboot the changes which are applied by the restore will not become effective

    revert back with a little more details of the OS and the process of the restore. i.e if you have restored the C drive on the new machine and then restore of system state and stuff.


    Author Comment

    Hi bhanu thanks for the reply , I am using server 2003 svc pk 2 and the server I am restoring to is a test server (non networked), this is solely to verify that the backups that are running on the servers on our network are actually backing up what they should and can be restored if needed, so what i do is build the server from scratch every time and rename it exactly to the name of the server that i have the tape for .

    I always check every option in the restore process so C,D,E system state & shadow copy are restored on the new machine .So everything that was backed up from the original should in theory be restored to the test DC

    Like I said before I have done over 50 of these restores now using the exact same process and all have worked as they should have except for this one , the one important thing I see that is missing is from the C:windows\NTDS is the NTDS.dit  and log file why is this happening ? ( I can work around by getting the .dit file again from the original server but this isn't really a viable option)

    So to recap /built new DC from scratch
    Windows Server 2003 svc pk 2
    Symantec 12
    LTO tape with backup
    did inventory for C,D,E,system state & shadow copy
    catalogued C,D,E,system state & shadow copy
    tested all after catalogue /successful
    Restore C,D,E,system state & shadow copy
    after restore completed
    authoritative restore
    restore database

    This is where my problem starts with jet 1
    Opening DIT database...
    Could not initialize the Jet engine: Jet Warning 1.
    Authoritative Restore failed.
    Error 8000ffff

    It just seems that the domain hasnt recreated as when I restart the pc I cant log in with the admin password only the one that i created when I first built the server from scratch which should no longer work after the restore , I have also noticed that the ntfrs jet folder also hasn't restored see attached file

    Sorry if I'm not more specific but I am relatively new to this kind of backup/restore work. I did have a look at the above mentioned post which seems to be the same problem as i am having.

    thanks again


    Author Comment

    Hi again chaps , ok success I managed to get it working today, what I did last night was to schedule a backup of system state using nt backup rather than symantec, I collected the tape this morning and restored as normal using symantec then I located the nt backup file that i had created from last night , restored that file and using some of wdjacksons post from I managed to get the restore fully operational again .

    many thanks guys
    LVL 23

    Accepted Solution

    when you try to recover a DC normally the restore of AD (ntds.dit) is done when you reboot the server in DSR mode and then it does the restore.

    if the same has been done and if you still did not find the ntds.dit in the location then thats a strange thing that is happening.

    good to hear that you could resolve the issue by following the post i have provided.

    revert back if you have any further queries.

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    Top 6 Sources for Identifying Threat Actor TTPs

    Understanding your enemy is essential. These six sources will help you identify the most popular threat actor tactics, techniques, and procedures (TTPs).

    Life is full of imperfections – we all know it. Sometimes bad things happen to people for no particular reason. As they say: “it happens”. All we can do is to find a way to make some unavoidable situations… avoidable. Every kind of hardware has i…
    VM backup deduplication is a method of reducing the amount of storage space needed to save VM backups. In most organizations, VMs contain many duplicate copies of data, such as VMs deployed from the same template, VMs with the same OS, or VMs that h…
    To efficiently enable the rotation of USB drives for backups, storage pools need to be created. This way no matter which USB drive is installed, the backups will successfully write without any administrative intervention. Multiple USB devices need t…
    This tutorial will show how to inventory, catalog, and restore media from legacy versions of Backup Exec into both 2012 and 2014 versions of the software. Select Storage from the tabs along the ribbon bar as the top: Ensure the proper storage devi…

    758 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    12 Experts available now in Live!

    Get 1:1 Help Now