• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1167
  • Last Modified:

Deleted VMDK Snapshot

I am running ESXi 3.5 with 5 virtual machines.  I ran out of disk space and decided to delete the snapshots for one of my vm's.  I deleted one snapshot with snapshot manager and it appeared to be deleted, but the vmdk file was still in the vm's folder, so  I deleted it from the datastore browser (21GB VMDK file). This was a bad move because I found after the fact that I needed to wait for it to merge.  I had 3 VMDK snapshot files and the one I deleted was #2 of 3.  Needless to say, I cannot boot the machine without it.

I think I can recover the vm if I can get to a backup image that I have stored within the vm, probably in snapshot #3, but I have not been able to mount the snaphshot using winimage or VMWare Diskmount.  I'm not sure if I'm doing something wrong or if it is just not working.  What is the best way for me to either recover my vm or at least extract my backup image out of the vm so I can create a new vm from that image?  Thanks!
0
sfrancy
Asked:
sfrancy
1 Solution
 
Mesik2ppCommented:
Hi

If you deleted snapshot #2, then snapshot #3 is useless.
Did you do the backup before deleting the snapshot manually?
If not then only thing you can do is manually change vmx file that it uses only original vmdk and snapshot #1. The data you had in snapshot #2 and snapshot #3 is lost.
0
 
kumarnirmalCommented:
We once experienced this problem when the user had deleted snapshots randomly instead of deleting them sequentially.
I used the vConverter 4.0 to clone the VM to another Source and then recovered the VM successfully.
0
 
sfrancyAuthor Commented:
I tried the procedure from the article in the first reply, so snapshot manager does not list any snapshots; however, the snapshot files (data and flat) still exist on disk.

Mesik2pp,
I did not run a backup before deleting the snapshot, so I will have to revert back to snapshot #1.  I edited some files and I am posting them.  Can you please review them to see if I have configured them correctly to use snapshot #1?  Do I need to do something to have snapshot #1 show up in snapshot manager again?  Thanks.
HPWBFX1-000001.vmdk.doc
HPWBFX1.vmdk.doc
HPWBFX1.vmsd.doc
HPWBFX1.vmx.doc
0
 
sfrancyAuthor Commented:
I went ahead and changed the vmx to use snapshot #1, as per my previous post, and the vm now boots successfully.  I only lost about a month and fortunately, very few changes were made during that time frame.  Thanks to all for your help.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now