• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 4725
  • Last Modified:

Cisco ISDN Connection is not working State = TEI_ASSIGNED

Hello

I have a problem with my Cisco LAB isdn .

I have to routers with 2 e1 which i'm trying to connect together and use it as an isdn simlator .  Router 1 has one E1 and the router 2 has one E1 i 'm using RJ45 cable to connect them together and route calls between them .
when i type the command show isd staus i get ISDN  State = TEI_ASSIGNED .

can you please help and review my configuration please.
Router 1
 
Building configuration...
 
Current configuration : 1964 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname voice
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
no aaa new-model
!
resource policy
!
network-clock-participate wic 1
!
!
ip cef
!
!
ip domain name ntsuk.local
!
isdn switch-type primary-net5
!
voice-card 0
 dspfarm
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
controller E1 0/1/0
 pri-group timeslots 1-8,16 service mgcp
!
controller E1 0/1/1
 shutdown
!
!
!
!
!
interface Tunnel11
 no ip address
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/0.1
 encapsulation dot1Q 1 native
 ip address 10.0.38.95 255.255.255.0
 no snmp trap link-status
!
interface FastEthernet0/1
 ip address 172.16.2.1 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0/0
 no ip address
 shutdown
 clock rate 2000000
!
interface Serial0/0/1
 no ip address
 shutdown
 clock rate 2000000
!
interface Serial0/1/0:15
 no ip address
 encapsulation hdlc
 isdn switch-type primary-net5
 isdn incoming-voice voice
 isdn bind-l3 ccm-manager
 no cdp enable
!
ip route 0.0.0.0 0.0.0.0 10.0.38.1
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
!
!
voice-port 0/1/0:15
 cptone GB
!
ccm-manager mgcp
ccm-manager music-on-hold
ccm-manager config server 172.16.2.201
ccm-manager config
!
mgcp
mgcp call-agent CCM06 2427 service-type mgcp version 0.1
mgcp dtmf-relay voip codec all mode out-of-band
mgcp rtp unreachable timeout 1000 action notify
mgcp modem passthrough voip mode nse
mgcp package-capability rtp-package
no mgcp package-capability res-package
mgcp package-capability sst-package
no mgcp package-capability fxr-package
mgcp package-capability pre-package
no mgcp timer receive-rtcp
mgcp sdp simple
mgcp rtp payload-type g726r16 static
!
mgcp profile default
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
!
scheduler allocate 20000 1000
!
end
 
 
Router 2
 
Building configuration...
 
Current configuration : 2024 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname voice1
!
boot-start-marker
boot-end-marker
!
enable password 7u8i9o0p
!
no aaa new-model
network-clock-participate wic 2
ip cef
!
!
!
!
ip domain name test.local
ip name-server 10.0.38.10
isdn switch-type primary-net5
!
voice-card 0
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
controller E1 0/2/0
 pri-group timeslots 1-8,16 service mgcp
!
controller E1 0/2/1
!
!
!
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Service-Engine0/0
 no ip address
 shutdown
!
interface FastEthernet0/1
 ip address 172.16.2.209 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/1/0
 no ip address
 shutdown
 clock rate 2000000
!
interface Serial0/1/1
 no ip address
 shutdown
 clock rate 2000000
!
interface Serial0/2/0:15
 no ip address
 encapsulation hdlc
 isdn switch-type primary-net5
 isdn incoming-voice voice
 isdn bind-l3 ccm-manager
 no cdp enable
!
ip default-gateway 172.16.2.1
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 172.16.2.1
!
!
no ip http server
no ip http secure-server
!
disable-eadi
!
!
!
control-plane
!
!
!
voice-port 0/2/0:15
 cptone GB
!
ccm-manager mgcp
ccm-manager music-on-hold
ccm-manager config server 172.16.2.201
ccm-manager config
!
mgcp
mgcp call-agent CCM06 2427 service-type mgcp version 0.1
mgcp rtp unreachable timeout 1000 action notify
mgcp modem passthrough voip mode nse
mgcp package-capability rtp-package
mgcp package-capability sst-package
mgcp package-capability pre-package
no mgcp package-capability res-package
no mgcp package-capability fxr-package
no mgcp timer receive-rtcp
mgcp sdp simple
mgcp rtp payload-type g726r16 static
!
mgcp profile default
!
!
!
!
line con 0
line aux 0
line 66
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
line vty 0 4
 password 7u8i9o0p
 login
!
schedule
 
 
router 1 show CCM-Manager
 
voice#show ccm-manager
MGCP Domain Name: voice.ntsuk.local
Priority        Status                   Host
============================================================
Primary         Registered               CCM06 (172.16.2.201)
First Backup    None
Second Backup   None
 
Current active Call Manager:    172.16.2.201
Backhaul/Redundant link port:   2428
Failover Interval:              30 seconds
Keepalive Interval:             15 seconds
Last keepalive sent:            15:23:12 UTC Apr 23 2009 (elapsed time: 00:00:01)
Last MGCP traffic time:         15:23:12 UTC Apr 23 2009 (elapsed time: 00:00:01)
Last failover time:             None
Last switchback time:           None
Switchback mode:                Graceful
MGCP Fallback mode:             Not Selected
Last MGCP Fallback start time:  None
Last MGCP Fallback end time:    None
MGCP Download Tones:            Disabled
 
Backhaul Link info:
    Link Protocol:      TCP
    Remote Port Number: 2428
    Remote IP Address:  172.16.2.201
    Current Link State: OPEN
    Statistics:
        Packets recvd:   3
        Recv failures:   0
        Packets xmitted: 4
        Xmit failures:   0
    PRI Ports being backhauled:
        Slot 0, VIC 1, port 0
Configuration Auto-Download Information
=======================================
Current version-id: 1239975665-6496dbcc-b516-4a59-92f1-14bea363a47e
Last config-downloaded:00:00:00
Current state: Waiting for commands
Configuration Download statistics:
        Download Attempted             : 3
          Download Successful          : 3
          Download Failed              : 0
        Configuration Attempted        : 2
          Configuration Successful     : 2
          Configuration Failed(Parsing): 0
          Configuration Failed(config) : 0
Last config download command: New Registration
Configuration Error History:
controller E1 0/1/0no pri-group timeslots 1-31
 
 
Router 2 Show ccm-manager 
 
voice1#show ccm-manager
MGCP Domain Name: voice1.ntsuk.local
Priority        Status                   Host
============================================================
Primary         Registered               CCM06 (172.16.2.201)
First Backup    None
Second Backup   None
 
Current active Call Manager:    172.16.2.201
Backhaul/Redundant link port:   2428
Failover Interval:              30 seconds
Keepalive Interval:             15 seconds
Last keepalive sent:            15:11:58 UTC Apr 23 2009 (elapsed time: 00:00:05)
Last MGCP traffic time:         15:11:58 UTC Apr 23 2009 (elapsed time: 00:00:05)
Last failover time:             None
Last switchback time:           None
Switchback mode:                Graceful
MGCP Fallback mode:             Not Selected
Last MGCP Fallback start time:  None
Last MGCP Fallback end time:    None
MGCP Download Tones:            Disabled
TFTP retry count to shut Ports: 2
 
Backhaul Link info:
    Link Protocol:      TCP
    Remote Port Number: 2428
    Remote IP Address:  172.16.2.201
    Current Link State: OPEN
    Statistics:
        Packets recvd:   4
        Recv failures:   0
        Packets xmitted: 6
        Xmit failures:   0
    PRI Ports being backhauled:
        Slot 0, VIC 2, port 0
Configuration Auto-Download Information
=======================================
Current version-id: 1240496138-f9f1fe2f-ad6e-4f2c-8670-0624f2b8f726
Last config-downloaded:00:00:00
Current state: Waiting for commands
Configuration Download statistics:
        Download Attempted             : 3
          Download Successful          : 3
          Download Failed              : 0
          TFTP Download Failed         : 6
        Configuration Attempted        : 2
          Configuration Successful     : 2
          Configuration Failed(Parsing): 0
          Configuration Failed(config) : 0
Last config download command: New Registration
Configuration Error History:
voice-port 0/2/0:15
echo-cancel coverage 8
 
controller E1 0/2/0
no pri-group timeslots 1-31
 
controller E1 0/2/0
no pri-group timeslots 1-31
 
FAX mode: cisco
 
 
 
Issue:   show isdn status
ISDN Serial0/1/0:15 interface
        dsl 0, interface ISDN Switchtype = primary-net5
        L2 Protocol = Q.921 0x0000  L3 Protocol(s) = CCM MANAGER 0x0003
    Layer 1 Status:
        DEACTIVATED
    Layer 2 Status:
        TEI = 0, Ces = 1, SAPI = 0, State = TEI_ASSIGNED
    Layer 3 Status:
        0 Active Layer 3 Call(s)
    Active dsl 0 CCBs = 0
    The Free Channel Mask:  0x00000000
    Number of L2 Discards = 0, L2 Session ID = 1
    Total Allocated ISDN CCBs = 0

Open in new window

0
greekstones
Asked:
greekstones
1 Solution
 
harbor235Commented:


A state=TEI_ASSIGNED indicates that the router has lost connectivity to the switch. This is normal if Layers 1 and 2 are deactivated when there are no active calls. If this is not the case, you may need to trouobleshoot more.

harbor235 ;}
0
 
ged125Commented:
First you need to make sure that you have rolled pin 1&2 on one side of the cable to pair 4 & 5 on the other.  After that you need to set up one side as network and the other as user.
0
 
blue-screenCommented:
Follow these rules for a back to back E1 PRI  connection

http://puck.nether.net/pipermail/cisco-nas/2003-December/000421.html

You need a physical crossover cable and one side has to be set to emulate a switch.
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
greekstonesAuthor Commented:
thanks for the reply

do i make the cable like this

one end            
RJ-45
   1  -----  4
   2  -----  5

Second end
RJ-45 ----- RJ-45
   4  -----  1
   5  -----  2
   
0
 
blue-screenCommented:
Yes, just as the link said.
0
 
greekstonesAuthor Commented:
It works
0

Featured Post

Restore individual SQL databases with ease

Veeam Explorer for Microsoft SQL Server delivers an easy-to-use, wizard-driven interface for restoring your databases from a backup. No expert SQL background required. Web interface provides a complete view of all available SQL databases to simplify the recovery of lost database

Tackle projects and never again get stuck behind a technical roadblock.
Join Now