• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1313
  • Last Modified:

Modify XP background color through GP (or registry mod)

Hi Experts.  I am trying to set the background color of several workstations to gray.  I know I can't do that through a specific GP setting, but I was hopeful I could do it through some other means.  Please let me know the best way to do this.

Environment is a Windows 2003 AD domain with Windows XP Pro pc's.

Thanks for the help.
0
samiam41
Asked:
samiam41
  • 4
  • 2
1 Solution
 
oBdACommented:
The background color is defined in HKCU\Control Panel\Colors, REG_SZ "Background".
The original "XP gray" is "88 87 104".
The following command in a (batch) logon script should do the trick:
reg.exe add "HKCU\Control Panel\Colors" /v "Background" /d "88 87 104" /f
0
 
samiam41Author Commented:
Thanks for the post!

I put that script into the computer > startup folder for the group policy.  I am rebooting the desktop now to see if the replication has occured.  Does it matter if I disabled "registry editing tools" in the GP for that group?
0
 
samiam41Author Commented:
I rebooted the pc's and manually verified that the sync process had taken place on the DC's.  I still can't get the background colors to change unless I through the script under the GP user config login script.  If I do it that way, it takes another reboot for the color to take affect.  Any thoughts?
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
oBdACommented:
A startup script can't be used for changes to HKCU, as the user is not logged on at this time.
Remove the script again, try it with the policy template below (save as Backgroundcolor.adm or whatever.adm), import it into a test GPO, and set a color you want (you can edit the field, you don't need to restrict yourself to the values in the template).
Note that you'll need to change the View in the GP editor and disable "Only show policies that can be fully managed" for the setting to show up.
More important: if you ever want to remove the template, set the policy back to "Not configured" *BEFORE* you remove the template from the object, otherwise the setting will remain in the policy and haunt you in your dreams.

CLASS USER
CATEGORY "Additional Settings"
  CATEGORY "Desktop"
    POLICY "Background color"
    KEYNAME "Control Panel\Colors"
      PART "Background color (r g b):" TEXT END PART
      PART " " COMBOBOX NOSORT REQUIRED
        VALUENAME "Background"
        DEFAULT "88 87 104"
        SUGGESTIONS
          "0 0 0"
          "58 110 165"
          "88 87 104"
          "128 128 128"
          "255 255 255"
        END SUGGESTIONS
      END PART
    END POLICY
  END CATEGORY
END CATEGORY

Open in new window

0
 
samiam41Author Commented:
That worked!  Thanks for your help!
0
 
samiam41Author Commented:
You are freakin' brilliant.  Great work as always.

Regards,
Aaron Shaw
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

  • 4
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now