• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3261
  • Last Modified:

Acer aspire 5100 has an blank screen on boot-up

Hi

I have a Acer aspire 5100 laptop which sounds as if it is booting up when it's turned on but there is nothing on the screen, it is completely blank.. I have plugged in an external monitor and tried booting, still nothing on the screen.  I have checked the following
1. Checked cabling to main board and back of screen - all appear to be OK, have also tried a known working screen and inverter.
2. replaced memory sticks
3. replaced hard drive
4.removed and reseated anything that is removable.

The only thing i haven't changed is the processor. any suggestion in resolving this will be greatly appreciated

jag
0
140160
Asked:
140160
  • 3
  • 2
1 Solution
 
JDominguezNYCommented:
When you say you hear it booting up, do you mean you hear it POST and you hear the Welcome sound for your OS, or do you just hear the HDD and Heatsink fan spinning?

If you are just hearing the fans and HDD spinning and do not hear the laptop POST, your most likely culprit is a defective motherboard and/or CPU.

This might seem obvious but when trying to boot from an external monitor are you pressing the Key Combination that tells your computer to switch to an external source. (Something Like Function+F2)
0
 
WaynejciCommented:
This is going to sound completely ridiculous but take the battery out and plug it in. Acer Aspire 5000 series notebooks had a problem with defective batteries that caused the keyboard and trackpad to stop responding. I'm thinking the same thing could essentially cause display issues.
0
 
140160Author Commented:
Hi
Thanks for your responses, I have tried battery removal, and also the Function key combination. Unfortunately I dont hear post or the windows welcome sound, only the fans and the hard drive.  With regards to the post beep I know that some laptops don't give you a post beep i can't remember i Acer laptops is one of them.
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
JDominguezNYCommented:
The Acer 5100 definitely gives beep codes.  If your wondering whether or not it gives one specifically for POST then remove the RAM and power up.  If you get no sounds then it is definitely your motherboard.  If you do get sounds it could still be your motherboard it's just that the motherboard is still slightly good enough to check the RAM.
0
 
140160Author Commented:
Hi

thanks for your response, I have already removed the memory and booted up, definitely no post beeps. I was suspecting the motherboard to be the culprit,  Thanks for helping to confirm it

jag
0
 
140160Author Commented:
Many thanks for taking the time to help

jag
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now