Relay Server Blocking Outbound Message

A client of mine is unable to send an email to someone in the Czech (across seas). I have included the Undeliverable Message, but for some background info: They are using Microsoft SBS 2003 which includes Exchange 2003. The mail is then going through our relay server which has Microsoft Server 2003 installed and Exchange 2003.

Here is the Bounce:

Your message did not reach some or all of the intended recipients.

Subject:  Test
Sent:     4/22/2009 4:49 PM

The following recipient(s) could not be reached:
<mailto:pia004@email.cz> pia004@email.cz on 4/22/2009 4:49 PM

You do not have permission to send to this recipient.  For assistance, contact your system administrator.
<mail3.marsroad.com #5.7.1 smtp;550 5.7.1 Sender Policy
Framework of `quaker-steak.com' domain denied your IP address.>


Can someone please help? Thanks

~Jake
LVL 3
Jacobh06Asked:
Who is Participating?
 
MesthaCommented:
That is brave, someone is doing a hard failure on SPF records for antispam. Wouldn't catch me doing that, as SPF record use isn't high enough.

Basically the error is self explanatory - your SPF records are not set correctly to allow that server to send email for your domain.

The remote server is rejecting the email and forcing your server to generate the NDR.

Simon.
0
 
fluk3dCommented:
Try modifying the following on the relay server. Ensure allow relay is enabled, and specify the user in active directory that is allow to relay.

http://www.shogan.co.uk/wp-content/uploads/2009/01/relay_access1.jpg
0
 
Jacobh06Author Commented:
It runs the relay through IIS... not exchange on the Windows 2003 Server. Didn't really notice that last time..
~Jake
0
Cloud Class® Course: CompTIA Cloud+

The CompTIA Cloud+ Basic training course will teach you about cloud concepts and models, data storage, networking, and network infrastructure.

 
Jacobh06Author Commented:
So is that something that can be easily fixed?
Thanks,
~Jake
0
 
MesthaCommented:
You need to look at whether you have SPF records, and if you do not, set them.
They are DNS changes made in your public DNS records.

http://www.openspf.org/
http://www.microsoft.com/mscorp/safety/content/technologies/senderid/wizard/

Simon.
0
 
Jacobh06Author Commented:
We definitely think it is an SPF record. I will update you after we get that corrected/added.
Thanks
0
 
Jacobh06Author Commented:
SPF record fixed it... sorry for the delay.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.