?
Solved

connecting two hwic-4esw interfaces

Posted on 2009-04-23
12
Medium Priority
?
827 Views
Last Modified: 2013-11-09
Had a miserable time in the data centre tonight ....
I have two routers, each with an HWIC-4ESW card ... I want to connect fast ethernet 0/0/0 on 1st router to fastethernet 0/0/0 on the second router ... Since they are L2 interfaces, i cant assign them I.P addresses so i made a vlan, assignes fa 0/0/0 to that vlan on both routers and defined I.P on vlan interface...Given below is what I did

Router A:
1. Define vlan 19
2. interface fasthernet 0/0/0
      switchport access vlan 19
      duplex full
      speed 100
interface vlan 19
 ip address 172.16.0.193 255.255.255.248

Router B:
1. Define vlan 19
2. interface fasthernet 0/0/0
      switchport access vlan 19
      duplex full
      speed 100
3. interface vlan 19
 ip address 172.16.0.194 255.255.255.248

This didnt work and i was unable to ping between the two directly connected interfaces ... I had them connected using cross over cable .... so what I did was that at both fa 0/0/0, i defined switchport mode trunk and then used both straight as well as cross and didnt work either and i was still unable to ping ....

So, I'm here for help now .. Please tell me what exactly should i be typing/configuring at both sides to make it work ? Explain it to me as if i'm totally new to networking  ....

I had 6 or 7 different cables that I tried but no luck !
0
Comment
Question by:nabeel92
  • 8
  • 4
12 Comments
 
LVL 79

Expert Comment

by:lrmoore
ID: 24219723
Try setting both interfaces to speed/duplex auto and use a regular straight-through cable. They should be auto-xover capable but only if in auto speed/duplex mode.
0
 

Author Comment

by:nabeel92
ID: 24222163
ok, ill set them to auto and what should be the configuration at both ends ?
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 24223948
Start with just what you have posted except for the speed/duplex settings
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
LVL 79

Expert Comment

by:lrmoore
ID: 24256747
Any luck yet?
0
 

Author Comment

by:nabeel92
ID: 24257207
sorry for late reply, ill be trying tomorrow in the data centre and will let u know .... am really hoping that it should have been auto auto settings on either end coz thats the only thing i didnt try .. secondly, i dont think i need to put them in trunk mode, right ? just switcport access vlan 19 ... that's it ...
0
 

Author Comment

by:nabeel92
ID: 24267468
ok, am right now trying with what you suggested and no luck ...
switchport access vlan 19 on both sides WIC cards and straight cable ... just changed to cross cable as well but didnt made any difference ... when i connect normal fast ethernet on both ends, it works but not with WIC ...
0
 

Author Comment

by:nabeel92
ID: 24268077
no luck ... all bad luck today ... its so frustrating this issue ....
straight cable between two wics ... assigned f 0/0/0 on both ends to vlan 19 .... define the vlan in vlan database ....  ip on interface vlan 19 on one side is 172.16.0.193/29 and other is 172.16.0.194/29 .... its already auto/auto ... where can i start troubleshooting this issue ? one of mate mentioned that there are often cases where we have to mention a default route or some static route even if its directly connected but that didnt made sense to me coz its directly connected interfaces ...

0
 

Author Comment

by:nabeel92
ID: 24276949
Here are configs on both sides ... It's the Interface vlan 19 in question which is unable to ping on either side ...
r2_core# sh running-config
Building configuration...

Current configuration : 6499 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname r2_core
!
boot-start-marker
boot system flash c2800nm-advipservicesk9-mz.124-15.T5.bin
boot-end-marker
!
logging buffered 51200 warnings
no logging console
!
no aaa new-model
!
crypto pki trustpoint TP-self-signed-3808612846
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-3808612846
 revocation-check none
 rsakeypair TP-self-signed-3808612846
!
!
!
ip domain name yourdomain.com
ip inspect name urlfilter http java-list 2 urlfilter
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
ip urlfilter source-interface Vlan10
ip urlfilter allow-mode on
ip urlfilter exclusive-domain permit xxx
ip urlfilter exclusive-domain permit xxx
ip urlfilter exclusive-domain permit xxx
ip urlfilter exclusive-domain permit xxx
ip urlfilter urlf-server-log
ip urlfilter server vendor websense 10.0.9.15
!
multilink bundle-name authenticated
!
!
voice-card 0
 no dspfarm
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
username admin privilege 15 password 0 xxxx
!
!
archive
 log config
  hidekeys
!
!
!
track 1 rtr 1 reachability
!
!
!
track 4 rtr 4 reachability
!
track 5 list boolean or
 object 1
 object 4
!
!
!
!
interface GigabitEthernet0/0
 no ip address
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 no ip mroute-cache
 load-interval 30
 duplex full
 speed auto
!
interface GigabitEthernet0/0.1
 encapsulation dot1Q 1 native
 ip address 172.16.0.66 255.255.255.248
!
interface GigabitEthernet0/0.100
 encapsulation dot1Q 100
 ip address 10.0.0.3 255.255.255.0
 standby 100 ip 10.0.0.1
 standby 100 priority 105
 standby 100 preempt
 standby 100 track GigabitEthernet0/0
!
interface GigabitEthernet0/0.140
 encapsulation dot1Q 140
 ip address 10.0.4.3 255.255.255.0
 standby 140 ip 10.0.4.1
 standby 140 priority 105
 standby 140 preempt
 standby 140 track GigabitEthernet0/0
!
interface GigabitEthernet0/0.160
 encapsulation dot1Q 160
 ip address 10.0.6.3 255.255.255.0
 standby 160 ip 10.0.6.1
 standby 160 priority 105
 standby 160 preempt
 standby 160 track GigabitEthernet0/0
!
interface GigabitEthernet0/1
 no ip address
 ip virtual-reassembly
 load-interval 30
 duplex full
 speed auto
!
interface GigabitEthernet0/1.180
 encapsulation dot1Q 180
 ip address 10.0.8.3 255.255.255.0
 standby 180 ip 10.0.8.1
 standby 180 priority 105
 standby 180 preempt
 standby 180 track GigabitEthernet0/1
!
interface GigabitEthernet0/1.190
 encapsulation dot1Q 190
 ip address 10.0.9.3 255.255.255.0
 standby 190 ip 10.0.9.1
 standby 190 priority 105
 standby 190 preempt
 standby 190 track GigabitEthernet0/1
!
interface FastEthernet0/0/0
 switchport access vlan 10
 duplex full
 speed 100
!
interface FastEthernet0/0/1
 switchport mode trunk
 duplex full
 speed 100
!
interface FastEthernet0/0/2
 switchport mode trunk
 duplex full
 speed 100
!
interface FastEthernet0/0/3
 switchport access vlan 20
 switchport mode trunk
 duplex full
 speed 100
!
interface FastEthernet0/2/0
 switchport access vlan 19
!
interface FastEthernet0/2/1
!
interface FastEthernet0/2/2
!
interface FastEthernet0/2/3
!
interface Vlan1
 no ip address
!
interface Vlan4
 no ip address
 load-interval 30
!
interface Vlan10
 ip address 172.16.0.4 255.255.255.248
 ip inspect urlfilter in
!
interface Vlan12
 ip address 172.16.2.1 255.255.255.248
!
interface Vlan19
 ip address 172.16.0.194 255.255.255.248
!
interface Vlan20
 description Cross-Core-and-Edge
 ip address 172.16.0.22 255.255.255.248
!
interface Vlan22
 ip address 172.16.2.20 255.255.255.248
!
router eigrp 1
 redistribute bgp 64512 metric 6500 1 255 1 1500
 network 10.0.8.0 0.0.0.255
 network 10.0.9.0 0.0.0.255
 network 172.16.0.64 0.0.0.7
 network 172.16.0.0 0.0.0.255
 network 172.16.1.0 0.0.0.255
 network 172.16.2.0 0.0.0.255
 no auto-summary
!
router bgp 64512
 no synchronization
 bgp log-neighbor-changes
 redistribute static
 neighbor 172.16.0.1 remote-as 65530
 neighbor 172.16.0.2 remote-as 65530
 default-information originate
 auto-summary
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 172.16.2.2 10 track 5
ip route 0.0.0.0 0.0.0.0 172.16.2.22 100
ip route 4.2.2.2 255.255.255.255 172.16.2.2
ip route 4.2.2.3 255.255.255.255 172.16.2.2
ip route 10.0.32.0 255.255.255.0 10.0.8.13
ip route 172.16.1.0 255.255.255.248 172.16.0.21
ip route 203.38.180.192 255.255.255.224 172.16.2.2
!
ip flow-cache timeout active 1
ip flow-export version 5
ip flow-export destination 10.152.0.80 9996
!
ip http server
no ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
ip sla 1
 icmp-echo 4.2.2.2 source-interface Vlan10
 frequency 15
ip sla schedule 1 life forever start-time now
ip sla 4
 icmp-echo 4.2.2.3 source-interface Vlan10
 frequency 15
ip sla schedule 4 life forever start-time now
access-list 2 permit any
access-list 101 permit ip any any
access-list 101 remark Allow all traffic to flow through the Zone Based Firewall
access-list 101 permit tcp any any
access-list 101 permit udp any any
access-list 102 permit ip any any
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
banner login ^C
-----------------------------------------------------------------------
Cisco Router and Security Device Manager (SDM) is installed on this device.
This feature requires the one-time use of the username "cisco"
with the password "cisco". The default username and password have a privilege le
vel of 15.

Please change these publicly known initial credentials using SDM or the IOS CLI.

Here are the Cisco IOS commands.

username <myuser>  privilege 15 secret 0 <mypassword>
no username cisco

Replace <myuser> and <mypassword> with the username and password you want to use
.

For more information about SDM please follow the instructions in the QUICK START

GUIDE for your router or go to http://www.cisco.com/go/sdm
-----------------------------------------------------------------------
^C
!
line con 0
 exec-timeout 120 0
 login local
 terminal-type vt100
 length 25
 transport output all
 stopbits 1
line aux 0
 transport output all
line vty 0 4
 session-timeout 10  output
 privilege level 15
 password 7 xxx
 login local
 terminal-type vt100
 length 25
 transport input all
 transport output all
line vty 5 15
 privilege level 15
 login local
 transport input ssh
!
scheduler allocate 20000 1000
!
end


------------------------

R2

R2#sh running-config
Building configuration...

Current configuration : 1751 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot system flash c1841-advipservicesk9-mz.124-18.bin
boot-end-marker
!
!
no aaa new-model
ip cef
!
!
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3

!
interface FastEthernet0/0
 ip address 203.38.180.222 255.255.255.224
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/0/0
 switchport access vlan 19
!
interface FastEthernet0/0/1
 switchport access vlan 19
!
interface FastEthernet0/0/2
!
interface FastEthernet0/0/3
!
interface Vlan1
 no ip address
!
interface Vlan19
 ip address 172.16.0.193 255.255.255.248
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 203.38.180.193
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
!
!
line con 0
line aux 0
line vty 0 4
 password xxx
 login
!
scheduler allocate 20000 1000
end
0
 

Author Comment

by:nabeel92
ID: 24277908
sorry one more thing if i may say which maybe a pointer towards this problem !

I used a third router a test to see which one is causing the issue. I connected the R2 router with this test router; defined switchport in access vlan 19 and then defined vlan 19 I.P address ... I was able to ping between the two  ...
Now when i used this third test router with r2_core instead with same config, it wasnt able to ping that ... so am suspecting there is an issue with teh r2_core router .. either the WIC or some vlan issue ? what do u reckon ?
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 24286591
I don't see in the config where you actually defined the vlan other than the vlan interface
Try just adding this on both routers. Or try deleting the vlan.dat file out of the flash and re-create all vlans.
 vlan 19
0
 

Author Comment

by:nabeel92
ID: 24286598
vlan was defined in vlan database  ..... when i do show vlan-switch brief, it shows the vlans on both sides !  
int fa 0/2/0 is assigned to vlan 19 on r2_core router and int fa0/0/0 is assigned to vlan 19 on the other one ...
0
 

Accepted Solution

by:
nabeel92 earned 0 total points
ID: 24391958
It will be a mystery for me ... I'll now get around this issue by using one of the fastethernet ports on the router instead of the HWIC ..
0

Featured Post

Veeam Disaster Recovery in Microsoft Azure

Veeam PN for Microsoft Azure is a FREE solution designed to simplify and automate the setup of a DR site in Microsoft Azure using lightweight software-defined networking. It reduces the complexity of VPN deployments and is designed for businesses of ALL sizes.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The Cisco RV042 router is a popular small network interfacing device that is often used as an internet gateway. Network administrators need to get at the management interface to make settings, change passwords, etc. This access is generally done usi…
#Citrix #Netscaler #MSSQL #Load Balance
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

850 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question