Solved

Exchange 2003 active sync OWA HTTP/1.1 500 Internal Server Error

Posted on 2009-04-23
3
2,187 Views
Last Modified: 2012-06-27
Hello,  
To start everything was working fine until about 8PM Sunday night.  For the past year our windows mobile 6.x phones have been syncing with no errors.  
Then it just stopped.  No updates or anything were done to the Frontend or backend exchange servers.  Also the mobile phones are the only thing not working.  OWA and https over RDP for outlook looks fine.  

Both servers are exchange 2003 SP2 with all service packs.  

On the windows mobile phone I get this error in the logs


=-=- [23/04/2009 08:51:0249.000] -=-=
=-=-=-= Client Request =-=-=-=
POST Microsoft-Server-ActiveSync?User=cluna&DeviceId=362513EE520DB0BF5B4640C10758FC7F&DeviceType=PocketPC&Cmd=FolderSync
Accept-Language: en-us
X-MS-PolicyKey: 0
MS-ASProtocolVersion: 2.5
Content-Type: application/vnd.ms-sync.wbxml
User-Agent: MSFT-PPC/5.2.1003

-=-=-=- Start of Body -=-=-=-
<?xml version="1.0" encoding="utf-8"?><FolderSync xmlns="FolderHierarchy:"><SyncKey>0</SyncKey></FolderSync>

=-=- [23/04/2009 08:51:0249.000] -=-=
=-=-=-= Server Response =-=-=-
HTTP/1.1 500 Internal Server Error
Date: Thu, 23 Apr 2009 15:51:41 GMT
Server: Microsoft-IIS/6.0
X-Powered-By: ASP.NET
Pragma: no-cache
Content-Type: text/html
Content-Length: 56
MS-Server-ActiveSync: 6.5.7638.1

And

2009-04-23 08:51:45      KeepAwake      On
2009-04-23 08:51:46      SyncBegin      <sync xmlns="http://schemas.microsoft.com/as/2004/core" type="scheduled"/>
2009-04-23 08:51:46      EngineBegin      Microsoft Exchange, 2.5
2009-04-23 08:51:46      EstConnection      WOI NOT requested
2009-04-23 08:51:46      EstablishConn      hr=0x0, handle=0xc2ab021e, pri=0x200, status=0x10, flags=0x400000, wait=0
2009-04-23 08:51:46      ConnInfo      Type=1, Subtype=1, Secure=0, Descr=Data Network Connect
2009-04-23 08:51:48      AutdMode      Old=Not Determined, New=Not Determined
2009-04-23 08:51:49      DormantHint      Dormant mode on [Sync]
2009-04-23 08:51:49      EngineEnd      hr=0x85010014, ActiveSync encountered a problem on the %1!s!.
2009-04-23 08:51:49      RetrySync      in 15 mins, retry number 82, case: Retry, reached Max Interval
2009-04-23 08:51:49      SyncEnd      
2009-04-23 08:51:49      AutdMode      Old=Not Determined, New=Not Determined
2009-04-23 08:51:49      Scheduled      2009-04-23 09:06:49, handle=0x3d00001d, hr=0x0
2009-04-23 08:51:50      KeepAwake      Off

Any ideas?
0
Comment
Question by:consult2_98
  • 2
3 Comments
 
LVL 65

Accepted Solution

by:
Mestha earned 250 total points
Comment Utility
Things don't stop working suddenly for no reason, so something must have changed. Have you checked the SSL certificate hasn't expired?

Use a test account with the Microsoft test site and see what that throws up:
https://testexchangeconnectivity.com/

Simon.
0
 

Author Comment

by:consult2_98
Comment Utility
I agree this stuff just doesn't stop working.  But as far as I can tell it did.  
Anyways..  here is the results of the test

Testing Exchange Activesync for host owa.xxxxxx.com
  Exchange Activesync test Failed
 Test Steps
   Attempting to Resolve the host name owa.xxxxxx.com in DNS.
  Host successfully Resolved
 Additional Details
  IP(s) returned: 64.xx.xx0.xx
 
 Testing TCP Port 443 on host owa.xxxxxxxxxxxxx.com to ensure it is listening/open.
  The port was opened successfully.
 
 Testing SSLCertificate for validity.
  The certificate passed all validation requirements.
 Additional Details
  Subject: CN=owa.assisted1.com, OU=Domain Control Validated, O=owa.xxxxxxxxxx.com, Issuer SERIALNUMBER=0x9xx287, CN=Go Daddy Secure Certification Authority, OU=http://certificates.godaddy.com/repository, O="GoDaddy.com, Inc.", L=Scottsdale, S=Arizona, C=US
 
 Testing Http Authentication Methods for URL https://owa.xxxxxxxx.com/Microsoft-Server-Activesync/
  Http Authentication Methods are correct
 Additional Details
  Found all expected authentication methods and no disallowed methods Methods Found: Basic realm="owa.xxxxxxxxxxx.com"  
 
 Attempting an Activesync session with server
  Errors were encountered while testing the ActiveSync session
 Test Steps
   Attempting to send OPTIONS command to server
  OPTIONS response was successfully received and is valid
 Additional Details
  Headers received: Pragma: no-cache Public: OPTIONS, POST Allow: OPTIONS, POST MS-Server-ActiveSync: 6.5.7638.1 MS-ASProtocolVersions: 1.0,2.0,2.1,2.5 MS-ASProtocolCommands: Sync,SendMail,SmartForward,SmartReply,GetAttachment,GetHierarchy,CreateCollection,DeleteCollection,MoveCollection,FolderSync,FolderCreate,FolderDelete,FolderUpdate,MoveItems,GetItemEstimate,MeetingResponse,ResolveRecipients,ValidateCert,Provision,Search,Notify,Ping Content-Length: 0 Date: Thu, 23 Apr 2009 22:46:20 GMT Server: Microsoft-IIS/6.0 X-Powered-By: ASP.NET  
 
 Attempting FolderSync command on ActiveSync session
  FolderSync command test failed
   Tell me more about this issue and how to resolve it
 
 Additional Details
  Exchange Activesync returned an HTTP 500 response.
 
 
 
 
0
 
LVL 65

Assisted Solution

by:Mestha
Mestha earned 250 total points
Comment Utility
Reset the virtual directories and try again.

http://support.microsoft.com/default.aspx?kbid=883380

Simon.
0

Featured Post

Want to promote your upcoming event?

Attending an event? Speaking at a conference? Or exhibiting at a tradeshow? Easily inform your contacts by using a promotional banner in your email signature. This will ensure your organization’s most important contacts are in the know.

Join & Write a Comment

Suggested Solutions

Resolve DNS query failed errors for Exchange
Learn to move / copy / export exchange contacts to iPhone without using any software. Also see the issues in configuration of exchange with iPhone to migrate contacts.
In this video we show how to create an Accepted Domain in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Ac…
In this video we show how to create an email address policy in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Mail Flow…

771 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now