How do I clear up Visa x64 Access Control List (ACL) Problems?

I recently upgraded the hard drive (250 to 500 Gb) on a Vista Ultimate x64 notebook computer.  Ever since I cloned the old hard drive and installed the new one.  I have had strange problems such as not being able to save notification Icon preferences,  Explorer views aren't remembered, Ouloook shortcuts disappear, and numerous other problems.  Some of these things can be reset until the computer is restarted and then they disappear.  I believe the problem has to do with registry or file permissions.

I have tried using Microsoft utilities subinacl and secedit but with no lck.  When I run secedit with the following command line:  "secedit /configure /cfg C:\Windows\inf\defltbase.inf /db defltbase.sdb /areas REGKEYS"  I get an extended error.  I have attached the resulting log file for review.  Does anybody have experience with this type of problem?
scesrv.log
jaym25Asked:
Who is Participating?
 
ComputerTechieConnect With a Mentor Commented:
How did you clone the drive?

Try This:
Run chkdsk /r c:
Opening an Admin command prompt Click Start type run then  "Windows Key + R"and running this command:
ICACLS <insert the folder name> /verify [/T]

You might have do a repair install.
CT
0
 
jaym25Author Commented:
I used Casper 5.0 for x64 machines.  I had a difficult time getting it to finish and finally had to run it while windows was in safe mode before it would complete the copy.

I am doing the chkdsk as you suggested,  however ichkdsk ran earlier today because my system crashed with corrupt files.  It did repair several files and indices.  This was the first problem with corrupt files but the permissions issue has been going on for several weeks since I installed the new drive.  It's now just getting worse.

I'm technically competant but have no idea what folder to select for the ICACLS.  Does it recurse subfolders?

Also, would a repair install keep my settings and so forth?  What is the procedure?
0
 
ComputerTechieCommented:
I think it would almost be easier to use ImageXML and Windows Vista to expand the partition to the new drive size.

http://www.runtime.org/driveimage-xml.htm

http://www.vistarewired.com/2007/02/16/how-to-resize-a-partition-in-windows-vista

When you clone the drive while windows was running it sounds like not everything go transfered.

CT
0
 
jaym25Author Commented:
I ended up doing a repair install with the Vista disk.  Nothing else of these solutions worked.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.