• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1273
  • Last Modified:

Cloning/Moving Windows 2003 on Dell PERC 6 controller

I've got a windows 2003 which came with 2.1 Tb raid 5 array split into two virtual disks 1.7Tb and 350Gb (I dont know why)

Virtual disk 0
OS C: 12Gb
Backup data is E: 1.7Tb

Virtual Disk 1
Programmes D: 350Gb

Which means I have about 300Gb of free space in the programmes partion on a different disk

Rubbish thought I, I want to use that as my backup also

I wanted to resize the 350Gb drive down to 50Gb for OS & progammes and recoup 300gb and paste it into
the 1.7Tb to give me 2Tb. Unfortunately I cant reduce the size of a virtual disk it would seem. Poo!

I wanted to increase the storage also so I've added 4 more disks in a seperate array.
It's configured as 2 disks.

Virtual Disk 2
G: Windows - clone of original C: drive, resized to 20Gb
D: Clone of original programmes partition. (original D: drive has been deleted). System works fine with this

Virtual Disk 3
E: 2048Gb  - clone and resized original drive - Original drive e erased. system works fine with it backup to/restore from.

My problem is the OS.
I thought once cloned, I'd take out the old drives and bingo it would fire up (perhaps with a tweaking of boot.ini?)
No joy - so this got me thinking about the MBR was it cloned/want it? Apparently not. MBR is created during install?

So I want to know how to boot of what the system sees as G: at the moment?

Right now I have

Array 1 - 2.1Tb
Virtual Disk 0 1.712Tb
C: OS - 12Gb partition
Remainder of virtual disk is unused space
300Gb of free space that was originally Virtual disk 1

Array 2 - 2.1Tb
Virtual Disk 2 50Gb
G: - Clone of OS 30Gb
D: - Programmes parition 20Gb

Virtual Disk 3 2048Gb
E: Backup data one partition 2048Gb

The option in the perc controller are to add the other 300Gb in as a new Virtual disk only
I cant add to the existing array.
The only other option available is to reconfigure the array as raid 0 but
a) I presume windows wont see it as it bigger than 2tb.
b) Not sure I f I could then resize the array to a smaller raid 5?

Basically I want array 2 to be live with the bootable OS (now G but would be C)
 and then take out array 1 and all its disks and reconfigure as a single virtual disk
then split into 1tb, 500gb 500gb partitions for other backup plans

Any ideas how to go about this?

0
deesloop
Asked:
deesloop
  • 12
  • 11
  • 2
1 Solution
 
noxchoCommented:
Heh, long description. Windows will not work with MBR partitioned drives bigger than 2048GB. You need to turn to GUID partitioning table style to make the extra space available.
AS for booting from drive that is G: now, remove the drive letter via Windows Disk Management and then restart the server - in boot menu select the drive when ex G: was located as first bootable device. Then it should boot from this array.
Also, think about moving to Windows 2008 as it will let you create\convert MBR to GPT and vice versa plus let you resize partitions via Windows Disk Management on GPT drives.
0
 
deesloopAuthor Commented:
Was a bit long, but needed to clear up real disks/ virtual disk etc etc etc
 I dont have any disks bgger then 2Tb either
I dont have any partitions bigger than 2Tb
Only virtual disks which windows doesnt see

I have tried removing the drive letter and leaving empty but it's not working
It gets past the SCSI stuff to the point where it should start booting and then just sits there..
No cant find ntloaders or anything like that nothing I can work with it just waits
Its a relatively new box so moving to 2008 is out of the question.
 
0
 
noxchoCommented:
OK, are you able to boot into OS at the moment? I mean OS on C: drive.
If yes, then please boot - Windows - right click on My Computer - Manage - select Disk Management snap-in and take a screen shot of the disks layout.
Post it here. We will see what we can do with your configuration.
0
Free learning courses: Active Directory Deep Dive

Get a firm grasp on your IT environment when you learn Active Directory best practices with Veeam! Watch all, or choose any amount, of this three-part webinar series to improve your skills. From the basics to virtualization and backup, we got you covered.

 
deesloopAuthor Commented:
I thought that the long explanation just wouldn't cut it eight enough!
A picture paints a thousand words etc...
Here you go. Plus heres boot.ini
[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(2)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Server 2003 0 0 0 1" /noexecute=optout /fastdetect
multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Server 2003 0 0 0 2 (def)" /noexecute=optout /fastdetect
multi(0)disk(0)rdisk(1)partition(2)\WINDOWS="Server 2003 0 0 1 1" /noexecute=optout /fastdetect
multi(0)disk(0)rdisk(1)partition(2)\WINDOWS="Server 2003 0 0 1 2" /noexecute=optout /fastdetect
multi(0)disk(0)rdisk(2)partition(2)\WINDOWS="Server 2003 0 0 2 1" /noexecute=optout /fastdetect
multi(0)disk(0)rdisk(2)partition(2)\WINDOWS="Server 2003 0 0 2 2" /noexecute=optout /fastdetect
I was trying to see if I could point at new array/disk but I'm a bit unsure of how it all works.
 
Cheers

disk.JPG
0
 
noxchoCommented:
Are you saying that Disk1 and Disk2 are the same one array? Or is 50GB actually the separate array of 2048 but only 50GB seen?
I see three drives, disk 0- 1757GB, then disk 1 - 50GB and finally disk 2 of 2044GB.
OS partition on disk 1 should be recopied and Boot.ini file updated. BTW, the problem could be in the fact that virtual drive has not boot sector. I would check it via Boot CD for HDM2009 Server, do you have any partitioning tool like Hard Disk Manager or Disk Director?
0
 
deesloopAuthor Commented:
Disk 1 and 2 are in the same array.
Disk 0 is an array of its own along - you're just not seeing the deleted 300Gb virtual disk where programme files used to be.

I thought perhaps it mght be down to MBR/boot sector but wasnt sure.
When you say check "it via Boot CD for HDM2009 Server", do you mean the $600 bit of software?
I have a few partition tools - mostly the free linux ones  Gparted, Clonezilla, PING etc. Thats how I cloned and configured the partitions.
 I dont have HDM or Disk Director - lots of cash dor something that I dont need (except today of course!)
 
0
 
noxchoCommented:
I am referring to HDM2009 as I own it. It has a boot CD that can search if your system is bootable and if OS is found it makes system to boot from found OS - disk.
After your update I came to thought that problem is in the fact that Disk 1 and Disk 2 is in the same array.
To my mind the quickest solutions would be making three arrays of smaller size.
0
 
deesloopAuthor Commented:
I dont see that the disks bein gin the same array is relevant.
They were previously in the same array and the same disk.

They are as before - just smaller and o na differnet array.
HDM is pricey - maybe Disk Director would work?
http://www.acronis.com/homecomputing/products/diskdirector/
 
0
 
deesloopAuthor Commented:
Do you mean three virtual disks?
0
 
noxchoCommented:
Acronis will not help you. First, it does not have the seach Windows option on the CD. Second you need server version and it costs 609$.
Then stick with Partition Manager 10 Server Edition, I think it has similar CD like mine HDM2009: http://www.paragon-software.com/business/pm-server/
Install this tool and run it - use Recovery Media Builder to create the CD.
Then boot the server from this CD and on first screen select Find OSes. How many OSes does it see?
Then forward to Safe Mode (DOS) and then to Partition Manager. Does it see the disks layout exactly same way like Windows Disk Management?
0
 
deesloopAuthor Commented:
OK. I'll need to find a credit card next week.
What a chuffin pain in the butt.
0
 
noxchoCommented:
=)) I am still thinking about your RAID array that shows as two HDDs in Windows Disk Management. It should not show this way. In case it is configured properly then it must show as single HDD. Take backup of data on this RAID and then try to reconfigure the drives from this RAID into two arrays - not the single one. Then it could happen that you do not need to purchase anything.
0
 
deesloopAuthor Commented:
The array has two disks because the total 2.1Tb - more than the 2Tb that windows can see
Its the way ti was configured originally.One raid array with 2 disks only they were split 1750Gb/350Gb
I'm just copying the idea but different disk sizes.
 
0
 
noxchoCommented:
You will not be able to boot from 2.1TB drive when it is MBR formatted. Only 2TB is supported. And partitioning software is useless here. Either use second array as data storage only or reconfigure it to smaller size(maybe take out 1-2 drives and connect them as standalone?).
GPT partitioning allows booting from drives bigger than 2TB.
0
 
deesloopAuthor Commented:
I'm missing somethnig here.
Windows isn't seeing any drive as being bigger than 2Tb though?
It is not aware of the hardware raid going on so it sees only a 50Gb disk, and a 2048Gb disk
 
 
0
 
noxchoCommented:
Windows 2003 sees the drives bigger than 2048GB in wrong way if they are MBR formatted. GPT drives are seen as single HDD but not MBR.
MBR partitioning has limitation of 2048GB and I've seen the way it detects RAID as single HDD but divided into two pieces of 2048 and 300GB.
This is limitation of Windows XP/2003.
Vista and 2008 works better but still if you have it MBR partitioning formatted then the same problem will occur.
0
 
deesloopAuthor Commented:
I'm lost. :(
All the drives are less than 2048Gb.
The virtual disks which appear to windows as drives are all less than 2048Gb.
All partitions are less than that size too.
I could understanf the problem if I had configure a 2.1Tb virtual disk and then split it into 2048Gb partition and a 50Gb partition.
However all the disks were deliverately sized to be less than 2048Gb. Not by much i grant you (4Gb) but surely they should work?
Windows is writing to all the drives OK just not boothing from that dumb 50Gb disk split 30/0
Wish I hadn't tried to claim back that free space now. :(
0
 
noxchoCommented:
In case disk1 and disk2 are the same array then the reason Windows won't boot from 20GB drive is  - 2048TB exceed is not supported.
As data partition you can read\write to such configurations but not boot from there. This is out of Windows loader brains =))
Take backup of data and partitions and go on with reconfiguring.
0
 
deesloopAuthor Commented:
But windows doesnt know it's an array. Its got no idea what's there
They could be 10 hard drive in that array of 100Gb each
Setting it up in the RAID card, I could make it look like 1 Disk or 3Disks or whatever.
It just see disks that are created by the RAID controller.
I keep going back to the way it was originally configured.
1 array made of 2 virtual disks.
One being 350 Gb one being 1750 both below the 2048Gb limit.
However in the RAID card they are one raid array - bigger tahn 2048Gb.
Windows booted fine and is still booting fine.
I'm just resizing what appears to windows as the disks.
One is a bit smaller and one is now a bit bigger.
Both are less than the 2048gb limit.
Single array no problems.
Maybe I've not explained it well enough.
Heres the before and after. I know it should work.
I think its the lack of a boot sector on the 50Gb (30+20) drive.

I'm sorry if I've confused the heck out of everyone following this.
I'm confused myself, and it's my mess!

changes.JPG
0
 
noxchoCommented:
Hmm, the real mess.
Reboot Windows - press del - enter BIOS and see how many disks you do see. And most important what size is reported for your RAID.
Repartitioning on RAID level could have no effect for Windows IMHO.
0
 
noxchoCommented:
Yeah, Windows must see it as 20GB and boot from it. Something with OS partition here then.
Do you have Window 2003 CD? Just as a test boot from this CD and try to install Windows onto this 20GB drive, do is see the partition? If yes then go on with Partition Manager 10.
Copy the system volume again with PM and try to boot from it. It should go then.
0
 
deesloopAuthor Commented:
Thats what I'm thinking. Hardware raid should make no differnece to windows.
I have a Dell CD (Which has no driver for the raid card so it sees no drives at all!)- and server has no floppy drive either.
What a pain in the ring! All the free unix tools see the drives but windows from Dell doesn't.

I need to figure a way of adding the drivers, installing windows in to that parition.
And overwriting theimage.

I'm thnking of buying that software you mentioned anyway.
Should be a bit of a help. I'm sure its the boot sector's knackered
0
 
FallbackpuppetCommented:
It would be quicker to boot to recovery console and if it sees the instalation and you can log into it from there run fixboot then run fixmbr.  If that failes then try and run a repair instalation of the OS.  Quicker and costs les money than many sugesstions here.
0
 
FallbackpuppetCommented:
Oh and you will need a usb floppy (plug it in before you power the server on and this file on a flopy disk as W2K3 will not find raid drivers off anything other than a floppy.


The driver for the floppy is here
http://support.dell.com/support/downloads/download.aspx?c=us&l=en&s=gen&releaseid=R194151&SystemID=PWE_R710&servicetag=&os=WNET&osl=en&deviceid=13514&devlib=0&typecnt=0&vercnt=1&catid=-1&impid=-1&formatcnt=3&libid=46&fileid=267998

If you do not have a usb floppy you can use this utillity from any usb drive (it will format the drive)

http://support.dell.com/support/downloads/download.aspx?c=us&l=en&s=gen&releaseid=R180314&SystemID=PWE_2950&servicetag=&os=WNET&osl=en&deviceid=13724&devlib=0&typecnt=0&vercnt=2&catid=-1&impid=-1&formatcnt=1&libid=7&fileid=245713

you will want to down load this and extract it then in the directory you extracted it to extract the driver to the drivers folder.  after you ahve done that plug the usb key into the system and run the .exe that is in the directory you extracted the usb utility into.  Then make sure the usb key is plugged into the servfer boot from win media and follow me recomendations in the first post.
0
 
deesloopAuthor Commented:
Paragon Disk Manager sorted the issue.
What a great, but extortionate piece of software.

Removed old array.
Fired up CD, found new array did scan for windows
Changed drive letter
Set MBR and edited boot.ini restart and bingo
Fired up first attempt.

Simple, quick - shame I couldnt quickly find a GNU version.
It's mad that linux fixes windows better than microsoft does.

Thanks for all the input....
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

  • 12
  • 11
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now