Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 4488
  • Last Modified:

Cisco to Netgear Etherchannel config - what's best?

Cisco 3560E -> Netgear GS724TS

On the Cisco switch you can configure the Aggreagate link as ON (Etherchanne), Active (LACP) or Desirable (PAgP - Cisco propietary protocol).

On the Netgear switch you can configure 'Static' or 'LACP'

I have configured 2 interface Aggregate links between the Cisco switch & Netgear switch.  I have tried 'Static' (NG) & Etherchannel (Cisco)

interface GigabitEthernet0/9
 switchport access vlan 103
 switchport mode access
 channel-group 9 mode on

& 'LACP' (NG) & Active (Cisco)

interface GigabitEthernet0/17
 switchport access vlan 106
 switchport mode access
 channel-protocol lacp
 channel-group 3 mode active

I am not 100% sure that this is the issue, but every 1000 minutes the Netgear switch becomes unpingable from our monitor server (& from elsewhere in the network).  All 7 GS724TS switches are on their own exactly 1000 minute cycle & I think maybe the Aggreagate link config may mean that the Aggregate links are unstable (NB the switches till pass traffic, just they cannot be pinged).

Does anyone else have an Aggregate link configured between a Cisco device & a Netgear device, ideally specifically a Cisco 3560E & a Netgear GS724TS (or GS748TS) & can you recommend the correct config?  Anyone experienced a similar issue?

As mentioned, not 100% sure it is the LAGs - may be something else.  I have a Netgear GS724T configured & connected exactly the same as the GS724TS & it does not alarm every 1000 mins!

Many thanks in advance,

Simon
0
Sir_Lambalot
Asked:
Sir_Lambalot
  • 3
1 Solution
 
BusbarSolutions ArchitectCommented:
have you tried the mode on instead of active
0
 
Sir_LambalotAuthor Commented:
Hi Busbar - sorry for the delay replying - didn't see your comment.

Yes - I started with 'on' which is Etherchannel (Cisco) & used 'Static' on the Netgears - as above.

I then tried 'active' (Cisco) & 'LACP' Netgears - same issue.
Then 'active' (Cisco) & 'Static' & the channel doesn't come up on the Cisco box (although shows up on the Netgear)

Now 'passive' (Cisco) - LACP only if other end is LACP - & 'LACP' - still exactly the same problem.

The switches that the Monitor server is connected to directly do not alert - i.e. if you are directly connected to a switch your connection does not drop.

Seems to be only if traffic has to go through a LAG (Aggregated link)..



0
 
QuoriCommented:
Try setting the Cisco to Active, the netgear to passive. Shutdown the applicable ports before doing so.
0
 
Sir_LambalotAuthor Commented:
You can't set the Netgear to Passive.  The only options on the Netgear are 'LACP' & 'Static' (which doesn't use LACP).

Strangely I've found if I only have 1 aggregate link (Cisco LACP Passive, Netgear 'LACP') then there is no problem.  I can then use a single link for the backup.  Cisco 'Etherchannel' & Netgear 'Static' still has problems every 1000 minutes.

I am going to try putting all the Netgear interfaces into the same aggregate link, but then still connect to two seperate Cisco switches (the Cisco switches are doing HSRP & the HSRP address is the default gateway on the Netgear switches so maybe the Netgear thinks they are 1 switch anyway).

Thanks for the input.

Simon




0
 
Sir_LambalotAuthor Commented:
Got it working OK.

Configure a single LAG on the Netgear using LACP & connect to the 2 Cisco switches with LACP passive.  Spanning-tree blocks on one of the Cisco switches.

Do not get alarms every 1000 mins with this config (although initially one of the connections reports as down)
0

Featured Post

Fill in the form and get your FREE NFR key NOW!

Veeam is happy to provide a FREE NFR server license to certified engineers, trainers, and bloggers.  It allows for the non‑production use of Veeam Agent for Microsoft Windows. This license is valid for five workstations and two servers.

  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now