64bit IIS 7.0 installation with 32bit ASP.NET module causing RPCproxy.dll to error

Hi

I'm attempting to install Dynamics CRM 4.0 on SBS 2008. Initially there were several problems in the installation preflight checks but these are all over apart from this which I've hit a wall with.

Dynamics requires that the ASP.NET 2.0 32bit/x86 is installed which isn't by default on IIS 7.0. I've installed it and now all the webservices running on the box are returning error 503. In the event viewer the WAS service is showing many 5002 errors indicating that the Application Pools are stopping, I estimate due to the failing process.

http://forums.iis.net/p/1151288/1877461.aspx

In this thread on IIS.net Anilr mentions modifying the tag parameter the globalmodules in the applicationhost.config file. I've done this, but still have the same problem and don't know what to try next. Can anyone help?

Thanks

AdoBeebo

LVL 3
AdoBeeboAsked:
Who is Participating?
 
WilyGuyConnect With a Mentor Commented:
Sounds good an hosed up, unfortunately.

So is this 32 or 64 bit Windows?  Can you uninstall the 32 bit ASP 2.0?

SOunds like you need to run the aspnet_regiis with an -i (i think) on the 64 bit version to make it the walking dog again.

What error is CRM throwing when you installed without the 2.0 ASP .NET 32bit?  Did you do the Update Files option?
0
 
AdoBeeboAuthor Commented:
This is the current error message I'm getting on the preinstallation checks from Dynamics CRM 4.0:

Setup failed to validate specified Reporting Services Report Server http://SBS/ReportServer. Error: Client found response content type of 'text/html; charset=utf-8', but expected 'text/xml'.
0
 
AdoBeeboAuthor Commented:
This is the section of applicationhost.config which I modified - I added the section highlighted in bold:
<globalModules>
<add name="PasswordExpiryModule" image="C:\Windows\system32\RpcProxy\RpcProxy.dll" preCondition="bitness64" />
</globalModules>
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
AdoBeeboAuthor Commented:
Update: After adding the preCondition="bitness64" parameter the server began to generate "HTTP Error 500.19 - Internal Server Error"  messages on browsing and indicated a malformed applicationhost.config file, so I have removed this parameter for now.
0
 
AdoBeeboAuthor Commented:
I'll go with your first line - I've norsed it.

Spoke to a high-ranking IIS guy at MS who offered to consult for a fee, but said it wasn't a supported configuration as far as he knew and there were still no guarantees. Sorry for the delay closing. Cheers
0
 
dchellCommented:

Found the following here: http://www.dovicofiles.com/kb/?View=entry&EntryID=148 and it fixed this problem for me.

Windows Server 2008 SBS

If you are installling on Windows Server 2008 SBS and have applied the above fix.  You will receive the follwoing error.

http error "500.19 - Internal Server Error"

This error is caused because Windows Update Services uses Http Dynamic Compression.  Http Dynamic Compression is not supported in 32bit mode.

In order to resolve the problem Http Dynamic Compression must be disabled.  Perform the following to disable Http Dynamic Compression.

1.  Navigate to Start, Run,

2.  In the Run command type cmd.

3.  In the DOS Prompt run the following command.

%windir%\system32\inetsrv\appcmd.exe set config -section:system.webServer/httpCompression /-[name='xpress']

After this command is applied Http Dynamic Compression is disabled.  However, both Windows Update Services and DOVICO Timesheet will now work.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.