XenApp 5 User Session "Locks" or "Overlays" local server console session in Windows 2008

Having an issue with a new farm install that I cannot figure out. Hoping someone here can help. We recently put up a new Windows 2008 XenApp 5 farm and it would seem that whenever someone tried to open a Citrix session, it will "lock" the local console session with "Initializing Desktop". In some cases I've noticed it removing the local console desktop and replacing it with whatever the user is currently running. No start bar, no anything. It requires the user logging off it to actually restore the console back to it's original self. I am not sure if it is something misconfigured in XenApp or whether it is something wonky with the terminal services on each server itself. Any help is greatly appreciated.
fcs_jpattersonAsked:
Who is Participating?
 
fcs_jpattersonConnect With a Mentor Author Commented:
Figured it out. Ended up being an issue with an older version of the Dameware service loaded on the servers.  Whenever a user would try to log in via Citrix or RDP, it would the screen at "Initializing Desktop" through both Dameware and the local console.  Updated the Dameware client and services on the affected servers to resolve the issue.
0
 
fcs_jpattersonAuthor Commented:
It also appears to happen in standard RDP sessions as well.. so I'm not sure where to go from here.  Maybe something odd with how Terminal Services was set up or perhaps I forgot to install a Role.  Is present on all three Citrix servers in the farm though.
0
 
pfcjokerConnect With a Mentor Commented:
Have you rechecked all your Terminal Services GPOs? I've tested on one of our 2008 TS servers and it doesn't seem to be doing the same thing... Points maybe to corrupt OS install (hope not) or maybe more likely a GPO related issue.
0
 
fcs_jpattersonAuthor Commented:
Well, being it is happening to 3 fresh WIndows 2008 installs, I am not thinking it is a corrupt OS install.  We do not currently have any GPOs in place that modify Terminal Services.
0
 
fcs_jpattersonAuthor Commented:
Figured it out. Ended up being an issue with an older version of the Dameware service loaded on the servers.  Whenever a user would try to log in via Citrix or RDP, it would the screen at "Initializing Desktop" through both Dameware and the local console.  Updated the Dameware client and services on the affected servers to resolve the issue.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.