Remote Desktop Connection issue

Trying to connect to Windows XP SP3 PC via RDC from a windows xp pc, with in the same network and it fails with below error:
"The two computers couldn't connect in the amount of time allocated. Try connecting again"
The remote PC seems to be not acceping in coming RDC connections, but I can do a RDC from that remote PC to others.
Also the remote PC hangs up when a RDC is initiated against it and needs to be rebooted to login again.

Checked network cables, no issues.
Checked by plugging in different monitors, no issues.
Checked and no firewall is enabled on remote computer.

Please let me know how to resolve the issue.

Thanks.
sreesunAsked:
Who is Participating?
 
sreesunConnect With a Mentor Author Commented:
Thanks Briandunkle. Tried all, but nothing worked. I know it worked at some point befire I installed various applications. I am un-installing them to check if any those could have caused the issue.
0
 
sysreq2000Commented:
Make sure you have remote desktop connections enabled. I've seen SP3 turn it off. Right click on My Computer, Properties, then Remote tab and make sure Allow Users to Connect remotely is checked.

0
 
briandunkleCommented:
Well, if the remote machine hangs up that would pretty much stop you from establishing the session. :)
Start with the remote hangup. Anything networky running on it? Anything from file sharing programs to a VPN?
Also, do you have any more luck when the remote computer has just been restarted? I have had issues where programs on the remote computer seem to somehow soil the networking and it needs a reboot before it can handle an incoming request.

Anyway, I'd reboot and try it, then disable any networking background stuff and reboot it and try again.
0
Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
sreesunAuthor Commented:
Remote desktop is enabled on remote pc.
When the remote PC hangs, tried rebooting and tried to connect to it again via RDC and it hangs up again.
Have McAfee running, Cold Fusion services, SQL server services.
But not sure why would the remote PC hang up.
0
 
sysreq2000Commented:
Are there any errors in the event viewer?
0
 
sreesunAuthor Commented:
No errors reported in event viewer.
0
 
briandunkleCommented:
Sounds like terminal services is potentially hosed.
You could try a few other semi-random things -
Uninstall and re-install the network card driver;
change the IP address (yeah, I know, makes no sense);
disable any services that you can disable, momentarily. Especially stuff like itunes/bonjour and the like, if they're there;
You might also run something like cports (http://www.nirsoft.net/utils/cports.html) and see if anything is running that you DON'T know about and might be messing with your networking;
Change the port remote desktop uses...

Worst-case, you could use VNC, gotomypc, or something else. :)
0
 
briandunkleCommented:
Worth a try. Also if you had anything firewall- or security-related programs - specifically thinking of McAfee or Norton-type programs that offer "internet protection" - those can hose things on the way out. Or, for that matter, while installed.

Wow, looking back, II missed McAfee somehow - have you tried removing it, or at least disabling all of its protection?

Those programs actually load their own layer over all the networking stuff, which could cause problems even if they think remote desktop should be allowed (it does think that, right?)



You could also potentially try windows repair - we actually had that work on a PC here, which amazed me.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.