Mount Windows Share Linux Knoppix 6 vs 5.1

Posted on 2009-04-24
Last Modified: 2013-11-05
I've been using the Knoppix 5.1 live CD to boot client machines up so that I can make/restore images using partimage by mounting a windows share directory.

The normal commands i've been using and still works is as follows

sudo su
cd /mnt
mkdir windows
mount -t smbfs -o username=administrator,password=mypass //myserver/images /mnt/windows

Once i started using the Knoppix 6 CD using the same command, i get an error message saying that smbfs is an unknown file type. the error says

mount: unknown filesystem type 'smbfs'

I've read all kinds of posts about using cifs or ntfs-3g and other file system types and I haven't had any luck. I even tried options adding the windows domain but no luck.

Any thoughts on why its different? I like the 3d Desktop Environment on the Knoppix 6 cd and im currently downloading the 5.3 dvd iso hoping its similar, but i'd also like to be using the latest version of Knoppix. BTW is there is Knoppix 6 live dvd loaded with more extras or is that the same as 5.3 dvd?

Also I've posted this question in the Knoppix Forums and am still waiting for a response.
Question by:forcefeeld
    LVL 87

    Accepted Solution

    I'm not sure why you are reading posts relating to ntfs-3g, that is totally unrelated. It is only used when you want to mount an HD partitioned with an ntfs filesystem directly, not via the LAN.

    Try the following command to mount your windows shares:

    mount -t cifs -o username=administrator,password=mypass //myserver/images /mnt/windows

    newer versions of windows use a more secure version for filesharing, and than has been taken care of with cifs on the samba side, so the smbfs filesystem often isn't included in the kernel modules anymore.

    Anyway, knoppix 6 hasn't really given me that much satisfaction, I prefer 5.3.1 which includes everything I need. After all it is still a preview version.

    Author Comment

    that command did not work.  I understand samba is not installed in the newer version and maybe the cause. I guess i'll have to revert back to 5.3.1 for now, until they come out with a version of 6 that isn't so introductory in terms of whats preinstalled.
    LVL 87

    Expert Comment

    It should work, I tried it with knoppix 6. Smbfs isn't included in most new distros, although I didn't notice that, as I've always been using cifs (it has more security included, and when mounting server 2003 shares smbfs normally won't work).

    Author Closing Comment

    I ended up using the 5.3.1 version because of the lack of samba in version 6. I didn't realize it was a preview edition and lacking certain files.  I'm pretty sure i attempted the use of the same command using CIFS and it didn't work, but i dont believe i installed samba when i attempted to do that.  I'll post an update soon as i'll be updating some more systems in a couple weeks using the same procedure.

    Featured Post

    Gigs: Get Your Project Delivered by an Expert

    Select from freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely and get projects done right.

    Join & Write a Comment

    I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
    Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
    Need more eyes on your posted question? Go ahead and follow the quick steps in this video to learn how to Request Attention to your question. *Log into your Experts Exchange account *Find the question you want to Request Attention for *Go to the e…
    This video is in connection to the article "The case of a missing mobile phone (". It will help one to understand clearly the steps to track a lost android phone.

    755 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    16 Experts available now in Live!

    Get 1:1 Help Now