• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1576
  • Last Modified:

Trying to install app-swift on CentOS

Trying to install app-swift, following instruction from: http://nerdvittles.com/?p=202

I am trying to install app-swift using instruction from url above.

Here's the log:

[trixbox gcc-4.4.0]# cd /usr/src
[trixbox src]# wget http://pbxinaflash.net/source/app_swift/app_swift-1.4.2.tar.gz
--22:47:18--  http://pbxinaflash.net/source/app_swift/app_swift-1.4.2.tar.gz
Resolving pbxinaflash.net...
Connecting to pbxinaflash.net||:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 12497 (12K) [application/x-tar]
Saving to: `app_swift-1.4.2.tar.gz'

100%[=======================================>] 12,497      61.8K/s   in 0.2s

22:47:19 (61.8 KB/s) - `app_swift-1.4.2.tar.gz' saved [12497/12497]

[trixbox src]# tar -zxvf app_swift*
tar: app_swift-1.4.2: Cannot read: Is a directory
tar: At beginning of tape, quitting now
tar: Error is not recoverable: exiting now

gzip: stdin: unexpected end of file
tar: Child returned status 2
tar: app_swift-1.4.2.tar.gz: Not found in archive
tar: app_swift-1.6.2: Not found in archive
tar: Error exit delayed from previous errors
[trixbox src]# cd app_swift-1.4.2
[trixbox app_swift-1.4.2]# make
gcc -I/opt/swift/include -g -Wall -D_REENTRANT -D_GNU_SOURCE -fPIC   -c -o app_swift.o app_swift.c
make: gcc: Command not found
make: *** [app_swift.o] Error 127
[trixbox app_swift-1.4.2]# make install
if ! [ -f /etc/asterisk/swift.conf ]; then \
                install -m 644 swift.conf.sample /etc/asterisk/swift.conf ; \
if [ -f app_swift.so ]; then \
                install -m 755 app_swift.so /usr/lib/asterisk/modules ; \
[trixbox app_swift-1.4.2]#


Please help, I've been working on this the whole night...

  • 3
  • 2
1 Solution
Kamran ArshadIT AssociateCommented:

Seems corrupt package. Have you tried to Install it from different location?
davidlu766Author Commented:
Is it possible that gcc is not installed? And I did tried a different location...
Kamran ArshadIT AssociateCommented:
What is the result of ?

#gcc -v
davidlu766Author Commented:
-bash: gcc: command not found

How do I install gcc? I think it's not installed.
Kamran ArshadIT AssociateCommented:
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now